Newly bought My Book 3TB USB3.0 not recognized by my new laptop running Window 8.1

MyBook 3TB is not being read by my Lenovo Y510P running Window 8.1.

MyBook  USB 3.0 port on my Lenovo will read a USB 2.0 flash drive but not the My Book 3TB.

The packaging on the My Book 3TB said that it was compatible with MAC and Window 8!

Anyone has this problem?


Make sure the drive is plugged in directly into a wall outlet since a power strip, extension cord and surge protector may not be providing enough power to spin the drive properly.

Did u try in safe Mode???

Make sure all the USB drivers are up to date. How is the drive formatted? A drive formatted for Mac will not be visible on Windows.


I have tried plugging the My Book directly into the wall socket - makes no difference. Still does not read. 

When I use a USB 2 cable and connecct to the My Book USB 3.0 port and my Lenovo it does not read as well.  Tried it on my Desktop PC running Window 7 - does not work as well.

See the packaging photo  below of the My Book it says “Window 8 compatible” , MAC and Superspeed USB. I suspect it is one of those rush product that the product marketing people at Western Digital push out just to fill up the product line and store shelf in time for X’mas to maximise the billing. You know what they say “store  return is somebody else’s problem” especially if it is via a distributor or reseller, the store return only comes back in the next FY. Probably the product has not been rigorously tested for compatibility with Window 8 or USB3.0 Superspeed.

Going to return it to the store for something that works.

Return it to the store for a new unit.

 The customer service took out a new unit of My Book and tested each of the component with the current My Book that I have. We tested the USB3.0 cable and then the power adapter. The problem was with the power adapter it was not sending enough power to the spin the disk.

The quality of the component used is not good. All you need is a bad power adapter and the My Book is screwed.