Newbie here - part 2, new questions <g>

Thanks to everyone yesterday answering questions about our 4 year old DX4000 and a failed hard drive (1 of 4 in the raid 5 array).

With the info you offered and I found on the web, I pulled the bad 2TB drive, the WD dashboard said the raid was degraded, saw a drive missing.

Then I installed .net 4.5 and the intel RST software. after a successful reboot, RST said similar things about a missing hard drive / raid degraded.

I bought a 3TB WD red drive and hot swapped into the box. The RST software offered to rebuild the array onto this drive.

Before I did that, I did a GRACEFUL shutdown and pulled each drive (one at a time with the box powered off), connected the disk via an external USB cradle and connected to an SBS 2011 server, I ran CrystalDiskInfo just to see if the old 3 or 1 new drive had problems / close to failure. The SBS box said before using the drive, it needs to be formatted. I SAID NO to that window. Crystal Drive info saw the drive info and said the SMART info looked OK.

I reinstalled the drives IN THE SAME LOCATIONS THEY WERE TAKEN FROM (all with the sentinel powered off) and booted up the box.

I got the startup failed 0xD9 message that others have talked about.

With the power off, I removed that 3TB Red drive (thinking the WD didn’t like the non compatible drive / won’t boot with it). Still that same 0xd9 error at bootup

With the box powered off, I remeoved and reseated each drive (again, making sure not to swap locations). same 0xd9 at startup

I do NOT need the data.

This is now just an experiment before I see about putting this on ebay

searching this forum, older pages about 0xd9 talk about making a restore thumb drive, but I can’t find that file.

which brings up a question: Should there have been DVDs that came with the box? A previous tech had supplied and installed it. I don’t see any WD disks or storage server disks around. Just the COA on the box itself with a license key.

The storage server OS is not in firmware, right? Are there needed files / disks / thumb drives that I need to have to do a clean reinstall of the OS? Should those have been supplied with the box? Would WD sell them? Are they available for download?

Any thoughts what of the many things I did was the cause of the 0xd9?

It was rebooted before / after the intel RST install yesterday, so that wasn’t the issue.
Putting each drive on the SBS box - is that enough to corrupt the drives? I DID not have it format / do anything to the drives while connected to the SBS
I did NOT mix up the order of drives relative to their slots in the DX4000.
Should having a non-compatible drive in one of the bays keep the box from booting? (and I put in the non-compatible drive thinking that with the RST software, I’d be OK. And the RST software saw that new drive)

I’m taking the DX4000 offsite with me, so feel free, if you are curious / have time, to suggest how to go about playing with this in an attempt to get it functional for sale on ebay.

and again, I don’t need the data. I’d just like to get this to boot up again.

THANKS!

Not sure, anything newer than XP usually does “something” to the drives, though these 3rd party raid recovery tools work in another box.

The recovery ISO was always a download but when WD dropped windows they pulled the download. I think folks have been successful asking WD support for it.

If you get the ISO you need to check back on how to proceed with just two or three good drives. Is it worth anything on eBay ?

I’d like to do the restore for the experience (and knowing it boots up would help its value on ebay). I called 855-556-5117 and a guy said his boss will email me a link for a recovery file.

And as for value on ebay:

http://www.ebay.com/sch/i.html?_from=R40&_sacat=0&LH_Complete=1&LH_Sold=1&_sop=3&_nkw=dx4000%20wd&rt=nc&LH_ItemCondition=4&_trksid=p2045573.m1684

there was a sale for $188 for a diskless unit. (similar problem as us: From that one: 'It does power up and it did work flawlessly until the drive array went bad. "

And I’m including 3 disks!

ok, when you get your iso we need to talk :slight_smile:

talk about what!?!

don’t bother doing the reinstall?
how to do the reinstall? They are supposedly sending instructions along with the ISO link.

Something I meant to ask here but asked the WD tech - (I mention it here to make sure they are right?) the OS goes on part of one of the 4 drives you install / you can’t restore to a diskless machine (I was thinking there’s a tiny hard drive for just the OS). So you lose some space on the hard drives in the bays for the OS (yeah, not much, I know… just something I learned now).

talk about what - not that I don’t want to talk to you, just eager to know about what : )

By the way, they sent me the link to the ISO and I’m downloading it. The email says nothing about not sharing it. Can I post it here to help someone else?

nevermind. didn’t look at the bottom:

This electronic message contains information from Western Digital, is intended only for the use of the addressee and may contain information that is confidential. The dissemination of this information is strictly prohibited. If you have received this electronic transmission in error, please respond back to this e-mail or contact us by phone.

DOH!!!

Made the bootable USB drive, booted the DX4000 holding the reset button and after a few minutes, get ‘storage bad’. That was with 3 original drives (slots 1,2,4… slot 3’s drive had died). I took 1 out (slot 4), repeated and same message!

Anyone know if I need / want to do something to the drives in a PC to reset them (again, they were working OK in the dx4000, I connected them to a PC with an external drive caddy to read the smart info and then I got 0Xd9 messages.

Before starting the recovery you should recreate storage with the appropriate option of the ISO virtual CD ROM. Then you can recovery the Windows install. However I am not sure whether the recreate will work with 3 disks installed, maybe you should start with two only.

was no sense typing till you got the iso and I have been busy replacing a gas furnace :frowning:
No matter what you do you will need to put the drives in a working box and run diskpart clean on them to remove the raid config. If you restore with 3 drives it will complain one is missing and if you try with 2 drives it will just fail after 5 days of trying.

My vote would be to just use 2 drives, give 2tb usuable and you could use windows server backup to the 3rd drive in a usb caddy. Use it at home to backup computers and share stuff.

If you sell it on ebay 3 drives 4tb useable but not backup-able may be more attractive.

In any case clean the drives. Insert left to right (I think) Mount the iso on a worker PC, do the middle step recreate storage. When it says happy in the LCD power off and check the end of the log file in the wd folder of the thumb drive to make sure iit says what you expect.

If all is well do the 3rd step recover and in about 5 hours it should be up and running… Make sure to leave the worker PC on during all this and you must have a dhcp server for both the server and client pc while doing this

Thanks for the info! I’m still getting storage bad.

Unplugged the DX4000 from powerI took out each drive, inserted into USB SATA dock. Ran diskpart, (list disk, then select disk x for the drive from the DX4000, then clean it says diskpart succeeded in cleaning the disk.

put drives back in the dx4000 (starting with far left, then next one) put all 3 in. Press and held reset button, applied power and pressed power switch. (USB drive with ISO was in place).

After ‘loading recovery’, I released the reset button.

after a few minutes, I got ‘storage bad’. Tried that with 3 drives, then 2 drives then 1 drive. Same message.

Putting each drive back in the PC, diskpart shows no partitions on these drives. CrystalDiskInfo says drives are OK based on smart.

your message about recreate storage from worker PC - can’t do that till I get past storage bad?

DTMtech how do I do recreate storage BEFORE starting the recovery?

These are the 3 drives that came with the unit.

Thoughts?

You dbl click the ISO to mount it and run setup.exe
You should have a screen with 3 choices
unlock
recreate
recover

do the middle recreate first and look at the log file

Thanks for all the help. I finally got it going (is it me or does the restore process take a LONG time?!

Check my experience if you don’t mind:

make the recreate thumb drive
Boot the DX4000 off of it.
Let that work
when it’s done, make the recover thumb drive
boot off that
let that work (a long time! I stepped away / let it run overnight but the progress on the LCD was at 0 and 1% for a long time!

It came up fine with the 3 hard drives in a RAID 5 configuration. Was there a spot that lets you control the choice of raid 5 or some other configuration?

Thanks for your help!

when you say it came up 3 drives in raid 5 did you see that in the log file? If it has 2 drives it will be raid one. 3 or 4 is raid 5.

Recovery should not take more than 5 hours. Initializing may take up to 5 days. You should be able to access the ox while it is initializing, but it will be slow. I could be wrong, so if you can’t get to it don’t start over :slight_smile:

After the create disks / restore were all complete, I remote desktoped into the server, checked the d drive and it was about 4GB, so I just assumed it’s raid 5. Could be raid 0 with 1 drive unused : ) ?

Either I do not give good directions or you do not follow them well. I said at least twice to look at the log file for the raid config to see if it was correct.
I also said to recreate first then recover LOL