Newbie cannot connect through internet to cloud ultra exe2 windows 10

connect to home cloud in own network - good admin password
connect to cloud through web - good admin@wdmycloud password
connect to cloud through device as mobile with activation code - good
connect to cloud through mapping from outside my network \192.168.178.x\share - no good

I have already turned “on” the smb file sharing within Windows Features

Anybody have ideas?

You may have better luck in the dedicated subforum for the My Cloud EX2 Ultra. The single bay My Cloud, the subject of this subforum, does not officially support mapping of a Share from a remote location unless using something like VPN.

Typically however I would think one would use the broadband IP address of the location the My Cloud is at not the internal local network IP address.

Yeah, it’s not supposed to work.

Exposing SMB to the internet is an extremely risky thing to do.

Thank you for the info. Unfortunately, my new router does not support VPN, unfortunately. Perhaps I could take the old router and connect it to the new one and make a subnet…

Okay, I will turn it off. thanks.

You may need to keep SMB1.0 enabled in Windows in order for Windows to access the My Cloud on the local network. But it is NOT recommended to allow wide open remote access to the local network, or local My Cloud using SMB.

For mapping a My Cloud in side the local network WD has the following support document explaining the process.

It is recommended, if you haven’t done so already, to read the user manual for your device. It explains how to use the options/features of the device.

The user manual for your device may have more information on how to enable remote access that allows for mapping a Share remotely. Not sure if WebDAV allows remote access but it might. Generally you would also have to enable port forwarding on the router.

Bennor, thanks for your information. It is very appreciated. I just followed the instructions on how to configure the WebDAV protocol on mycloud and double checked my router settings with port forward settings. And yeah, here at home I was able to log on with the remote email address. Great! Now, I must log on remotely outside my own network and be just as successful in making the mapping in explorer. I truely believe it will work for 99% ! :slight_smile:

No, the mapping performed remote did not work, unfortunately. Back to the drawing board.

There are a number of discussions in the EX2 subforum (see link above for subforum) that appear to discuss using WebDAV for remote access.

Here is one such post:

More discussion:

In the EX2 series subforum, use the forum search feature (magnifying glass icon upper right) and search for “WebDAV” to find other discussions.

I have tried solving the problem by configuring the FTP en DNS, used public google settings, does not find dns. Has not worked. I am going to pick this up again at the end of the week. Thanks! I really like everyone’s help. I believe it has something to do with my router.

You can do port forwarding and use DDNS. Using this, you will get a faster accessing your hard drive with reliability. For more details and support whatsApp +971559283744 or email:

If I recall; you CAN access the MyClouds from a remote location. . .the trick lies in port forwarding assignments (i.e. the device listens to specific ports for HTTP and HTTPS traffic).

Having said that. . . .it also exposes your MyCloud to the internet. . . and the Cyber protection of these devices is far from world class.