New wd tv live wont get ip address

hi all just unboxed a new wd tv live unit and im haing problems with networking

ive tried with cable and ive tried with wifi but i need it to work with wifi or ill take it back

it finds my wifi router

my laptop can find the wd tv live in explorer

but each time i goto networking and punch in all the numbers it then comes up with all 0 numbers in ip address

it has 3 bars on the wifi strength

i can restart the unit and it just keeps restarting unles si press home button

are these units pieces of poo or what


so should i ring wd tomorrow

or should i take it back and get a better brand

as it looks like a high percentage of these have issues

well after working on this issue up until 3am i got it to work

i upgraded firmware to latest and it started just rebooting all the time

which made it a pain to downgrade firmware

i let unit cool down for abit and managed to get it to read the usb stick

with the old 104 firmware

well guess what i got an ip address and it went thru the menus fast with no lag

i just love the bloody quality control of the new firmwares

not a happy customer WD

sideshow10 wrote:


i just love the bloody quality control of the new firmwares

This firmware has been out for MONTHS and only a few people have reported the issue you describe … and most of these reports only in recent days.

Ok cool I only got unit yesterday
Strange why straight out of the box mine had issues
Had firmware 110 I think worked ok just no network
Upgraded to 113 then had more issues like restarting all the time
Managed to downgrade to 104
Working ok so far

So now not sure what to do
Ill just leave it since its not broke anymore
Or I’ll wait till new firmware comes out

Is this latest firmware very good?

This is the wrong forum for the new WD Live devices

Had the same issues “out of the box”  did have a manual fix without upgrading firmeware, read this if interested.

wifi issues