New WD MyBook Essentially - not being recognized by MBP


#1

I have a Macbook Pro (OS 10.6.4) that has very little memory left. I bought a WD My Book Essential today to transfer the bulk of my photos & video off of my MBP to the external drive. When I first connected it, I got an error message saying I needed to format it for Mac. I followed those directions and everything was fine. It asked me to update the firmware. After updating the firmware for the HD and half way through updating the WDSmartWare, I ran out of memory. I had to halt the download and do some cleaning. After I deleted enough files, I was able to finish downloading the WDSmartWare. However, now my MBP doesn’t recognize the HD when I plug it into the USB port. I’ve even switched out the cables, thinking it was a faulty cable, but to no avail. It is as if the HD is not connect at all to the computer. I tried called tech support, but they are closed. Any idea what may be wrong, or maybe I have lemon?


#2

Okay, so I just read the post before mine where tons of people have had problems since updating the firmware. Perhaps it’s a firmware issue? I think I may return it tomorrow if it doesn’t magically start working again soon.


#3

We’re working on fixing that firmware and should have it out soon.   However, if you have a Windows machine you can update the firmware on it.