New WD My Passport 1 TB 3.0 - not working

Hi.

Just bought a WD Passport 1 TB 3.0 witch it’s not working. Well it works, but not with my computer. My computer won’t recognize it and I don’t know what to do. I have installed the WD SES DriverWD SmartWare Update for WindowsWD Drive Utilities for Windows and  WD Apps Setup Executable Update. Still nothing works after that. I have tried using diffirent USB ports. I have also tried updating the drives rough Windows Update. 

It’s a:

Western Digital My Passport® 1TB Silver

Model: WDBBEP0010BSL

I have Windows 7 64-bit, but not a 3.0 USB port. 

Can someone please help me with this? 

When you try the update… Does the update goes through?

If it does , try going to disk management and changing the drive letter

Hi,

I have very similar problem but my disk is not even getting recognizant on any machine.

I recently received a replaced My Passport, 1TB HDD for my previosly corrupted My Passport, 1TB HDD.

When I connected it to my laptop (win7) it was not detected at all, not even in device manager. Also I tried to connect it to my desktop(WinXP) but not good :cry: …  All I could feel is some movement in HDD, probably disk spining.

Since this is already a replaced HDD, I was hoping WD would have at least checked what they are sending to consumers. Unfortuntly it seems that I will have to raise another RMA for this and get drive replaced… Hopefully they will send me working HDD next time.