New WD Elements 1TB super slow on 2009 Macbook pro .... and another issue

Today I tried to do a time machine back up with a new 1TB WD USB 3.0 hard drive. I plugged my two current drives in via a USB hub as i only have 2 usb ports, one was a 320gb WD USB 2.0 which has all my video and one was a 320gb iomega USB 2.0 which has my DJ music.

I formatted the new 1TB drive and then started the Time Machine back up…no probs. I went to listen to music for an hour and came back to find it had stopped and there was no error message or anything.

It had only done 22GB of 750GB so I deleted the 22GB and tried again. When I plug the 320gb iomega USB 2.0 drive it is not recognised anymore.  The 320 WD was not either but afer some time trying it suddenly recognises it.

My friend is here with a linux system and so we plugged the iomega into his and it seems to work fine.

I wonder if I have confused my macbook pro by having different usb formats and I’m not sure that mine works properly with usb3 and I had two drives heading through the crappy little usb hub.

The light for the 320gb iomega USB 2.0 drive comes on but the notebook does not recognise it.

The new WD 1tb is also copying extremely slow. It took 3 mins 30 secs to move a 1.59GB film from my desktop to the root of the drive. DOes this seem normal?

I am running MAC OS X 10.6.8. The drive that is not showing has always worked fine and has all my music which I use for DJing.

I have a gig tonight using my iomega so I hope someone out there can help

Many thanks


this behaviour is not normal

run first aid to verify and repair any errors

if not able to rapair, you’ll need to replace