New WD Black not detecting properly

Hey all, new member of the community here that is having A technical issue with a couple of new drives I have purchased.

Full story:

I purchased 2x 4TB WD Black drives (WD4003FZEX) to replace my 3x 2TB WD Green drives (1x WD20EADS, 2x WD20EARS). I installed one of the Black drives in place of one of the old Greens and started my pc and navigated to ‘Disk Management’ but the drive was nowhere to be found. Couldn’t even find anything to initialize. I checked in Device Manager and found the drive listed under ‘Other Devices’ instead of ‘Disk Drives’ and it had a little white circle with a blue question mark against the drive icon. ( Edit: Sounds very similiar to this problem - )

I thought there might be a problem with the drive so I powered down and installed the second new WD Black and found the exact same issue, the HDD was in ‘Other Devices’ instead of ‘Disk Drives’.

I rebooted once more and checked the BIOS (UEFI). The drive was listed in there but said the capacity was 0.0GB!?

I tried swapping the old Green back in and it detected itself straight away again so there is nothing wrong with the power/cabling.

I am kind of lost where to go next, I am confident the drives are not DOA (I have never had an issue with a WD drive and what are the chances of them both being fried) 

Any help would be much appreciated!



Hi and welcome to the Community. Try connecting the New black drive as a single drive and verify if it’s recognized correctly on the BIOS. If possible also try connecting the hard drive to another computer. 

Well, some more diagnosis info…

Today I tried the drive in a different computer and the same problem occured so it looks like the problem is following the drives, not my PC.

Could it be a HDD software/driver or firmware issue? I find it hard to believe that 2x brand new, sealed WD Blacks would arrive dead? or 6x in the case of ShelaMonster’s post I mentioned before!?

Thanks for the help so far jubei04, I havent tried connecting one of the Blacks as a single drive yet. I’m guessing it wont boot in that configuration though?

I have tried contacting WD Tech Support but I need to register an account to do so and it won’t let me complete the form at the moment.

if you have an Intel chipset motherboard, you need to update the RST software to the latest version from Intel, so it can recognise 3TB+ drives inside the OS.

Then you will be able to clone your existing drives, using the Acronis software from WD and install your new shiny ones.

Well I have made some progress thanks to IainNIX…

After installing the Intel ‘Rapid Storage Technology’ for my CPU/Mobo The drives have moved from the ‘other devices’ section of the Device Manager into the ‘Disk Drives’ section where they should be but they are lised as ‘unknown device’ instead of the WD serial number…

(only 1 drive was plugged in at the time of this screen grab)

The drive also now appears in ‘Disk Management’ but when I try to initialise it, if I select GPT I get the error “The specified disk is not convertible because the size is less than the minimum size required for GPT disks” and if I select MBR I get the error “Incorrect Function”.

The drive is still listed in UEFI as 0.0Gb. 

I tried ASRocks 3TB+ unlocker utility (I have an ASRock X79 Extreme9 2011 Mobo) but it hasn’t seemed to have made any difference.

The problem seems to be my PC recognises the drives, but thinks they are 0Gb instead of 4TB

Both drives are showing the same symptoms so again I am confident I haven’t got dead drives, it really feels like a software issue…

Thanks again for the help so far!

cool, just installed RST 13.2.4 myself the other day (along with the latest HDClone package).

have you tried to see if your board has a BIOS update available, there might be a detection issue with the GPT disks, it looks like the system is struggling to recognise them, if the BIOS can’t see them, Windows will have no chance.

also watch the SATA cables you are using for the 4TB drives, I have seen known older basic SATA II cables not work with high cap GPT drives, you might need to use proper SATA III rated cables.  Also watch for other USB drives/devices and anything Bluetooth related on the PC, those can drive you mad looking for fixes to drive issues…

Sorry about the delay but here is the latest update:

I did have a BIOS update that I had been putting off. I flashed the BIOS with the latest ASrock files and tested and nothing relating to my HDD issue had changed.

I found out I was using Intel RST so I downloaded RST but when I try to install it I get this error:


I am using Windows 8.1 64-bit…

I tried running my PC with all extra devices unplugged (only running Keyboard, Mouse and Monitor) but they still wouldnt recognise.

I tried different SATA cables but none that I have access to specifically say SATAIII. They all just have SATA or Serial ATA printed on them… Still no luck.

Starting to run out of ideas…

I have seen this with some of our other HP workstartions, when we tried to install 13.2.4 last week.  We had to leave them on 13.1 until we could find out why, as the system chipset is still supported.  You can grab the older version if you scroll down the download page a little.

plenty of angry Intel user posting system reports back to the RST dev team!!

1 Like

Is it possible that you are facing a Power Up In Standby (PUIS) issue?

1 Like


Well it looks like I may be facing some sort of PUIS issue. I managed to get my pc to boot off a disk (all new to me, I am not used to a UEFI system…) got HDAT2 running and attempted to wake up the drives. I managed to get one to wake by plugging it into the SATA0_0 slot on my mobo where my boot drive nomally resides. The only issue was it only said it was a 8Gb drive, not a 4Tb! I tried looking into other options in HDAT2 but every menu bought up errors with the drive. I decided to try my other 4Tb black and that refused to wake at all. 

I am too annoyed to continue with it at the moment but may try the MHDD method from this thread: in a few days.

The most frustrating thing is I am thinking I will need to RMA them, which isnt much of an issue other than being stuck here in Antarctica till early April with no oppertunity to post anything out or in so I have to try to survive the summer here with my bank of old WD Greens and by the time I can send the Blacks back, there will probably be something new and better on the market…

Anyway enough of my dramas, thank you all for your help so far, I have learnt heaps about HDD’s and feel much more confident with them now. Cheers guys, really appreciate it!

You could try reading the drive’s firmware modules. Sometimes one or more of them are damaged.

SeDiv WD Read ROM & Modules: