New User - Cannot find MyCloud on Windows XP sp3 "My Network", but MyCloud Software sees it

I’ve been reading the various posts but cannot find one that answers my questions. I have just installed a 2 TB MyCloud to our in-office network. MyCloud software sees it. My Windows XP sp3 system cannot see it in “My Network”. The NAS drive is Ethernet connected to the router that I am connected to wirelessly (other office computer cannot see drive either - Ethernet connected to a different router on system - workgroup linked to my computer works fine). I have the IP address for my MyCloud. How do I find it on My Network?

Can you point me to a thread that discusses this or offer me assistance? Thank you.

Have you set the MyCloud up?

You can access the Dashboard at [IP address]/UI

Have you set the Workgroup on the MyCloud to match the that of your work network.?

I have a MyCloud accessible by an XP SP3 machine, so it is possible. But it’s so long ago, that I can’t remember any difficulty getting it to be recognised…

Do the office computers have NetBIOS over TCP/IP enabled? Is there any firewall software on the computers that are blocking local network access or blocking NetBIOS?

Thank you both for your comments. Yes, I use the Dashboard from its IP address. Yes, I have gone into the Network setting and changed the Workgroup to match my computer(s) workgroup. Yes, I have shared some of the files. No, they don’t appear…

As to the other comment, I will need some help. Where do I look to see if NetBIOS over TCP/IP is enabled? I believe my systems are set up for TCP/IP.

We are using AVG Antivirus software on all of the systems. It doesn’t inhibit any of our other internet transactions or communications with each other.


So, I found where to configure TCP/IP to use WINS, and have reset my computer to “Enable” NetBIOS over TCP/IP. It was previously set to the “Default” setting. No difference.

Obviously, my system can see the NAS drive since I can connect to it through it’s IP address, and the MyCloud software sees it. Why can I not see it on “My Network”? Is there some way I can “look” for it on “My Network” using the drive name or it’s IP address?

I’ve worked with computers for, well, decades. Internet protocols and communications are not my forte. Help me find what I need to find and do what I need to do, and I’m pretty good from there…

Did you reboot the computer after making the changes to the network settings?

Yes, I did restart my system. It didn’t change anything. My network stuff still comes up like before, so I assume that the default setting was the same as ‘enabled’, or it doesn’t matter to my other internet connections.

I realize from reading some of the other threads that even though the software is supposed to work with XP and marketed as such, that there are some caveats with this older OS. Still, I know there is a way to have the shared files visible to our office workgroup. Just need to find it…

I have some follow-up to my not being able to see My NAS drive on Windows XP. I tried pinging the IP address. It pings fine (e.g., Windows XP can locate the IP address). Can anyone tell me how to “see” it or access files on it from Windows?

Ultimately, and until I upgrade the Operating Systems on each of the computers in the network to one that the NAS software actually likes, I need to access a shared file on the My Cloud drive. Even if I cannot “see” it through Windows Explorer, is it possible to use it by specifically pointing to it (e.g., “Targeting” it as a data source in the shortcut by saying D=" specific-address-of-the-data-file-on-the-NAS-drive")?

I want to ask before trying this, since I don’t want to mess up live data. I believe the dashboard software will allow me to copy the file I want. Any thoughts?