New SSD not showing anywhere

I just bought a WD BLUE SSD 500GB to upgrade my older Toshiba laptop HD to SSD. Running Windows 10. I have the SSD attached to a SATA cable and plugged into the computer’s USB port with the intent to clone.

The laptop does not see the SSD in either File Explorer or Disk Management. Nothing. The USB ports recognize other items like thumb drives so that isn’t the issue.

I tried plugging the SATA cable and ttached SSD into my Surface 3 and it shows up there as expected. So that’s not the problem either.

What can I do?

The SATA adapter - Does it work with other HDDs?
Try formatting the new drive on the Surface and then go back to the Toshiba with it formatted.
You could remove the old HDD and connect both to another computer and then clone the old one to the new one.


Install the new SSD in the Toshiba and see if windows installation media (Requires you boot from USB thumb drive) will let you install Windows on it.

Just some things to try…

Thanks. The SATA USB cable is new so I have not tried it with other drives but it’s the same cable I successfully used with the Surface to see the SSD on that computer.

Same cable and SSD does not show on the older Toshiba.

This is my first time attempting this, so my first thought would be to do the simplest and that is to try to format it on the Surface and then see if the Toshiba “sees” it.