New Release - Windows WD SmartWare version (9/13/10)

WD is happy to announce its newest SmartWare update for Windows computers.  You can now go to the  SmartWare Download page, and pick your drive and OS to download your update.

Also, please return to post your experiences to this thread. 


I installed this new software about 6 hours ago.  My Passport Essential now appears to be turned off; only my hard drive is registering on the Home page; the passport drive is not showing up.  It is plugged in.  I followed all the instructions exactly, including pulling the UBS port and reinserting it after 10 seconds.  I don’t know how to get it going again.

firmware update for the mybook said it failed, but a powercycle and a quick refresh shows its running the current firmware, hope this doesnt do anything bad :confused:

edit: since posting this the smartware upade installed and is working decently, was a good call to have the software restart your computer

Whats the process to use this?

I have EssentialElite_FirmwareUpdater_v2.010( on the drive.

When I mount the drive, I can select to install, but this fails in a software crash.

Trying the upgrade (is this possible without a base install?), WDSmartWare_Software_Upgrader_for_Windows_1.4.1.1, ends in nothing.

Whats the process here?


It’s possible to install without base (I think you mena original) WD SmartWare.

Can you give little more details like 1. What OS, 2. Step by Step of your process, 3. How it fails (error message, etc.)?

Not sure if fails with Firmware Update or WD SmartWare Software update.

Yes another buggy version, thankssss a lot :cry:

First of all, I have a french windows XP, everything up to date, real licence, .net 3.5 as needed.

Installation OK, no problem, but now, the interface mix french and english word, top tab and right panel in english the center of the window in french.

My drive has a password before and with this update, I cannot acces to the drive because I cannot click on the image of my drive, it seems, there is no button active.

And the cross to close the Not So smartware do nothing !!!

Installed and latest driver for My Book Elite and now backup is not working.  Data for backup does not match data backed up. At top of backup page message is “Partial Backup Accomplished”.  Internal hard drive icon shows yellow band for data to be backed up.  Any one else having problem with new release?

Yes I have experienced the exact same problem after installing WD Smartware version for WD My Passport Essential. Will back up so much then backup is interrupted with “Partial Backup Accomplished”  message and stops backing. Similarly yellow lines denoting files not backed up and detail states cannot find the path. Have tried it several times, each time a bit of data is saved but is interrupted.

This is the second download of firmware and software I have installed from WD which has given rise to problems when the appliance was working perfectly before.

I have solved the problem myself.  It may not be related to the new release.  Around the same time as I updated software I also set up my gmail account to transfer emails between gmail and my normal email server and vise versa.  It was the mail updating that probably caused the backups to fail.

I had been using “detailed view” with everything checked off.  I reset with nothing checked off and applied that.  Nothing was backed up then.  I then checked off one item at a time in the detailed view and applied it.  That part backed up OK.  I repeated with other items.  When it hung up on “mail” item I unchecked it and went on the next.  It works great now for everything except mail files.  I can live with that.

I upgraded firmware and software and now I cannot access the MyBook Essential drive.  The icon in the systray just keeps flashing. When I right-click I choose WD Smartware it does nothing.  Task manager shows it running and the virtual CD drive shows up in File Explorer but nothing happens if I click on it.

I left the drive plugged into the USB port all night and it still said “Drive Discovering” 0% used.

I run an Acer laptop with Windows Vista.  All other updates have been fine and I’ve had the drive for about a year now.

I’ve tried re-booting the laptop and the drive several times.

I need a fix for the a.s.a.p.


OK this is what happens.

Windows XP SP2 with .Net 3.5 SP1. At the start I have no WD software installed. I double click on WD Software Upgrader.msi from WDSmartWare_Software_Upgrader_for_Windows_1.4.1.1/.

It ends in nothing visible, but there is a folder

C:\Program\Western Digital\WD Smartware Upgrader

Then I had to guess what to do…

I run WD SmartWare Upgrader.exe and get “WD Snartware encontered a problem…”

If I run WD SmartWare Setup.exe I get another doalog saying I need .Net 4.0.

If I run WD SmartWare Setup (x86).msi up comes some DOS winwow for a second, but then nothing, but it does something if the disk is connected. This must be the trick, it does install the Smartware software, and it seems to work now.

Working with software development and tech support myself, I must say the process of handling this from WD hasnt been the best. The info on how to perform this long time needed update was very poor. Personally I’ve bought my last WD product, sorry.


I understand you are not able to unlock the drive with WD SmartWare.  There is another way to unlock the drive.

Can you use Virtual CD (VCD)'s unlock.exe to unlock the drive? VCD should be shown my My Computer.


The icon in the systray just keeps flashing. When I right-click I choose WD Smartware it does nothing. 

This happens when Windows or WD SmartWare can’t find a writable partition/dirve.

1.  Can you check My computer and Disk Management (right click manage from My computer) and see if external drive is seen?

2.  Can you write click VCD and click open than double click unlock.exe (if drive is encrypted)?

Have tried removing all items in the detailed view, applying change and backing to refresh. Backup Successful. Then as you suggest isolating each item in turn in the “detailed view”  and attempt backup. Each time it backs up a few files and then “partial backup accomplished” appears. Tried this several times with only part backup being being attainied each time. 

Originally problem originated when I installed the firmware and software update version 1.3 with malfunction of WD and lost email data following a backup and then failed to recognise files for backup from my PC. After lengthy correspondence with WD technical support it could not be resolved and I awaited new release of next update. Indeed version did rectify the problems I was experiencing after installation of 1.3 and on release of WDs statement acknowledges their were “occassional” problems with installation of version 1.3 which the latest update rectifies.

I have resorted for the time being of removing the VCD and using Windows backup instead, and I note from other posts that others have resorted to this when WD has failed. Windows backup carried out backup without incident and I have been able to review and confirm that all the files I needed to back up are there. 

 I had the same problem with   . Left me with a dead drive. The steps i took to turnit on :

  1. Downdoad Net 4.0    It took almost 20 minutes to install this with it appearing to lock up the computer  for a large part of the time.

  2. Down load firmware and install .exe fron small windows screen.

  3. Download software and install.

  4. When the computer asked me to reboot I indicated no and shut it off without rebooting.

  5. Unplug drive usb cable and power cord to do a dead cold start, started computer, and my drive came alive after three hours of pulling my hair out. I work for the post office and when we get an upgrade to do it comes with a detailed set of instructions.

After months of WDFME.exe crash and burns, the latest WDSmartware update, version, worked right out of the box! Not one WDFME.exe crash since I installed it three days ago. Every menu function works. I have a Sony VIAO, Pentium 4 processor, 512 MB RAM, and Windows XP. WDSmartware is still a resource hog, but its better than restarting your PC every 10 minutes after every WDFME crash. A significant improvement indeed.

when installing smartware i got a microsoft message stating the new software did not pass microsoft logo test and may present a problem. any suggestions.



I downloaded the update. My Passport is useless. I tried going to the WD Smartware program.

I get this message : “WD Smatware has encountered a problem and needs to close”.  I can’t find the receipt so I’m stuck with a piece of trash.

Sorry  you might wait a bit for more replies.  If the data is just backup and expendable you might try uninstalling the Smartware (It Sure Isn’t) reformatting and using as a regular drive. For backup there is this After I uninstalled the Smatrware and everything appeared to work I went into device manager and disabled the miserable virtual CD I didn’t try their fix. The only smart person in this disaster is the guy that unloaded the Smartware on WD. It appears when WD gets a bad idea they stick with it!


1 Like

Hallo ,

 I have  problems with the former version … but now as I finally get the last version working … the when i needed its   is as a backup it failed completely…

Files I couldn’t place back to it s original position…

This software I s not a piece of apple-pie…

Tried everything …

Now I can start all over again…

Who has made this piece of bad pie…

This pie has taken me hours of frustration.