New Release - WD TV Live Streaming Media Player Firmware Version 1.15.10 (3/28/13)

WD is happy to announce our latest firmware update for the WD TV Live Streaming Media Player.

If you experience any issues with this firmware, please report them in the WD TV Live Streaming Issue Reporting exchange.

For questions or sharing your experience, you can post in this thread.


Does this update improve the slow (official) YouTube app?


This update is almost all about cosmetic issues rather then fuction issues.

Hi, i need to see teletext stream of subtitle 777 in a TS mpeg file… How can I do? I’m a deaf man…help me!!! I have various files .ts in my network server but I can’t watch them via wd tv live with subtitles…can wd update firmware with this new issue? Emtec movie cube s850h is able to do that! Please update firmware…

AFAIK the LIVE does not support this kinda subs. Can you upload a sample clip to or Mediafire?

Are they ever going to improve the speed of the YouTube Leanback app? Or at least use a Leanback app that was made to be viewed on a TV, like the one the WiiU has? The one they have is so weird to use. Navigating the menus is extremely slow and it feels like it was designed for a mobile phone. The menu displays only 2 items at a time, you have to slowly scroll to get to what you want. When watching a video, the up button takes you back (facepalm), and there’s no way to manually close the seek bar - uh, it’s so terribly designed.

Yes Techflaws, this evening i’ll upload a sample, and then i’ll tell you here when done… so you can try to display Teletext Subtitles page 777… THANK YOU!!!

Hi, i’ve uploaded the file. The link is

this is a .ts file with teletext stream. the subs are on page 777. For example if you open the file with VLC Player, the subtitles are correctely displayed…

Let me know is something is possible on WD TV Live updating a new firmware…

thank you a lot!!!

I wait for your answer…


Still having trouble playing high bitrate mkv files with this firmware. 

Having no such problem here and i got some big ones., Netflix and Slingbox seem much darker with this version.  The previous verion did not have this problem.  I have an HDMI connection to my HDTV.  I compared the brighness from the WDTV to the brightness on my Comcast activated TiVo and the darkness of the WD device is quite annoying. 

I rebooted the device and the problem is gone.  Videos are now similar in brightness to cable TV.

Now works properly with hdhomerun prime project connect.  Before I would get no sound but I can now watch live TV with sound and minimum pixelization.  So they did something in there with mpeg2.

Just installed the update, now WDTV will not connect via wifi to the existing home network. Have tried clearing wifi settings, restarting, and confrimed internet is working on other devices connected via wifi. Anyone else seeing this problem? Help?

My WD TV Live is connected via WiFi. After installing the 1.15.10 update, I am no longer able to access computers or shares on my home network.  Online services such as Netflix is working properly. 

After downgrading to 1.14.09 everything is working properly again. 

This upgrade is a minor upgrade in my opinion, i remain on 1.12.14 until some useful features (watch ideas sometime XD) and a lot of issues introduced from 1.13.18 (because this firmware it was totally horrible) are not yet fixed…

After the update I have the problem that the “options” button on the remote doesn’t work anymore. Before I could then choose to delete the file. After I start the video the options button works again but at this time there is no option to delete the file. 

This is enough to turn me off installing this new update.  1.14 has network issues already, I’m not going to risk making them worse.  In fact, until there’s an update that fixes movies hanging and having to stare at a stuck circular arrow on my TV screen for 10 mins before finally pulling the thing out of the plug and resetting, I’m not going to bother anymore with these pointless updates. It’s a shame really that such a great machine with probably the best interface out of all the ‘budget’ media players is so bad at doing what it’s supposed to do.  Play videos!  WD should give those guys at VLC a call and ask them how a player that claims to play every kind of video and audio file, manages to do just that !

1 Like

Yes! I agree.  Call VLC!   OR give us an option to move the  WD logo (aka the spinning circle) from spack dab in the middle of the screen to a less conspicuous location… like the lower right hand corner and make it be like a History channel water mark, that way when whatever crashes we could still watch the video without having to reboot!!

I understand there are certainly complexities in playing video files… but even if ONE of the formats worked correctly… and granted it seems to play ok… but god forbid should you want to stop, pause, ff, or do anything … its back to the spinning circle again.  I wouldn’t mind but the reboot time on the device is terrible…after detecting network and usb drives of 3TB… I’ve got two of these crippled SMP and it does seem to work with WD 3TB and Seagate 3TB too).  but don’t even think about using that library feature.  If you want to index the drive on your own time … fine make it a background process and let ME use the device.   Someone please give the WD SMP developers more help or a NCIS smack.  Some goodness is that WD does provide some sortda network diagnostic tool… now how about one that would scan for files that it WONT play. but even that is confusing as I thought it’d play mpg but try and play them and its unsupported file?? There is the makings of a good product here but I’m NOT going to buy the new WD player EVER…   so TO date i’ve spent more time DOWNLOADING UPDATES to the SMP than i’ve probably used using the device.  Hoping that one of them would actually fix pertinent issues vs cosmetics.  Would love to see a schedule of their Next update and what they are working on to fix… or wait let me guess… will there be another update???  Thanks for letting  me vent…

1 Like

Yikes first time posters.

Folks many of the problems your have nothing to do with the firmware.

There no ten min delay in playing files and  its likely got to do with your network.

The wireless not connecting is nothing new and well documented and just requires you deleting the wireless connection and unplugging the device and plugging back in.

A quick reboot of your router and your good to go as before.

Don’t go assuming its the devices before you rule out other possibilities.

These devices are mostly plug and play but they are at the whims of the netwrok and storage setup.

If either one of those has got proablems its affects the device.