New Release - WD TV Live Plus Firmware Version 1.06.42 (1/17/13)

LexusMike wrote:

Until last night when I installed the latest upgrade 1.06.43 v I had Iplayer . After installing this supposed upgrade I don’t. I have tried to solve this by installing the earlier version but its still not there. We used the IPlayer a lot of late and am not happy at all that this is now not available. Why would WD remove IPlayer in an upgrade.  I hope that you can issue another version quickly. As I am getting a lot of pleasure to get another media player from someone else. 

If you looked up the thread a bit you would have seen a answer to this question.

Installed this update last night after the WDTV prompted me to download it.  Now it takes 20-30 seconds to start a video off network shares.  Rolled back to 1.06.16_B, but the problem remains – totally unacceptable that this upgrade wasn’t quality tested.  Will be switching to another brand if there is no fix and the Community Manager remains silent.

I only have the 30 second delay start on avi files.

Where can we get the .16b firmware to roll back. I had to do this after the last firmware update that was **bleep**, but can’t remember where.

Would be interested to know if it solves the 30 second delay problem for you.  Rolling back did not fix the problem for me.

This firmware is no good.  It has the same problem as the update from a few months ago.  I have a Synology Diskstation ds212j.  I use it as a shared drive on my windows network to stream movies.  With the old 1.06.16B firmware it connected without issues.  With this new firmware it only connects very infrequently, seemingly with no reason.  Both devices are connected wired via lan, so wireless isn’t the issue.  Furthermore, it can connect to the NAS using DLNA, so it definitely can see the NAS, it just can’t connect as a shared drive.  (I don’t use DLNA because then I can’t play certain video formats.)  I’ve tried rebooting both devices several times, but nothing seems to fix the issue permanently, and even if it did I’m not going to reboot my NAS every time I want to watch a video.  Rolled back to the old firmware and it connects flawlessly again.  Seems whatever the bug was from a few months ago wasn’t addressed.  Now I just wish I could get it to quit nagging me to update the firmware every time I turn it on.

To the experienced “regulars” who frequent this media player forum:

Have any of you installed this final-final firmware release for your Plus or Live?  If so, are you experiencing success or any gliches with this firmware?   I confess, I have not yet taken the plung to install it.

Thanks for your replies.

mike27oct wrote:

To the experienced “regulars” who frequent this media player forum:


Have any of you installed this final-final firmware release for your Plus or Live?  If so, are you experiencing success or any gliches with this firmware?   I confess, I have not yet taken the plung to install it.


Thanks for your replies. 

Yes, I’m having the same network share issue several others have reported.   First time ever in the history of the device.

I’ve yet to spend any time troubleshooting.

TonyPh12345 wrote:> Yes, I’m having the same network share issue several others have reported.   First time ever in the history of the device.

I’ve yet to spend any time troubleshooting.

Ooo, not good news.  From my reading of the other messages, I was about to write (but decided to hear from someone, first):

 It is always good practice to turn off the media player after a firmware update to reboot it, but before turning it back on, one should turn off any additional media players, too.  While they are still off, turn off the main computer and any others, then bring the main PC back up to get the network behaving well again (and to reset the network’s master browser). 

Once the PC is good and up, then turn on the WD that had the firmware update installed.  Hopefully, this would clear any network gremlins out.  I assume you did this sort of thing, but you are having the share issues, too.  Bad news.

I thought with this fw, I could stop having me to convert every mp4 h264 file to mkv. to have it played without stuttering, but I see nothing has been done to stop this issue.

 wonder why I am one of the few lamenting…Maybe my box has some hw difference from the others?

A new issue is instead appeared: avi files (Xvid) play badly, with frequent stops and big difficulty to resume.

Youtube Leanback can’t remember older searches, and this is bad…

Rolling back put everything back as it was (unfortunately with the mp4 issue as always)

Well, this is the first firmware I’ve rolled back from, since the disastrous withdrawn firmware before the recent betas.

The slow starting of playback on the betas annoyed me, but not enough to bother reflashing it immediately.

I wanted to like it (the interface is more fluid), but it won’t see my network shares. Rolled back to 1.06.15 and all fine again.

The betas saw my network drives, but this one only sees my Buffalo LinkStation Live NAS, and none of the PCs on my network. (Though it does show my new desktop PC as an (empty) media server, but curiously not the SMB shares on the same PC.)

Since 1.06.15 was always much snappier at starting videos than the newer editions, I think I’ll be sticking with that.

Now to set up an update blocking rule in my router, as others have suggested for avoiding unwanted ‘updates’.

I have been having network issues for some time. I keep my power off when not in use using a RF on/off switch so I start from true power on and may be part of the issue but only been for last 2 updates. To get to my network shares: I have to do network auto setup, go into video scroll media servers list a few times, then move to net work shares - normally will not work, go back to media servers and scroll them again a few times then back to network shares and all my shares show up every time. No clue but seems to work for me :expressionless: Mark

Same here I just updated my firmware and when I go to Network Shares it doesnt show any of my shared drives etc.

I tried the UPDATE for the SIXTH time and it seems to be working, I notice that when I go into “About” it identifies the new version as 1.03.42_ B…has WD fixed this update?

So my box got the new upgrade.  Ugh!  I can *sometimes* see my network shares, sometimes just the Media Servers.  Regardless, it doesn’t show all the content (some folders but not all, and only a handful of the videos, and I don’t think there’s any ISOs  listed) when I do get to the network shares.  Tried rebuilding the network share, no dice.  Reset the computers and made sure my Windows 7 box which is has all the content on it is the Master Browser, no dice.  Downgraded to 1.06.16, and still no dice (same symptoms.)  Any thoughts would be helpful. 

Also, I’ve read the warning about using 1.05.?? or earlier and how it can brick the WD box.  If I choose to do a factory reset, will this also brick the device, or just if I try to load an old firmware off of a thumb drive? 


Hi mixlplex…this is my experience…I wish I could guarantee it will work for you but alas I can’t…give it a try.

If WD has re-issued a FIXED firmware update disregard the following but IF you’re still having NETWORK SHARE problems you might try the following…it SEEMS to have worked for me…SO FAR!

When I first downloaded an installed the new upgrade the first thing I did was to go to Netflix, I was concerned that I would have to RE-enter my logon information - which I loathe doing - I was pleased to find that wasn’t necessary the system “remembered”. Then I was in for my next pleasant surprise…I hit HOME on the remote and it took me straight there, I didn’t have to answer yes or no to the question…are you sure you want to leave Netflix, as was necessary with the older 1.06.16_B firmware. I found I could also just power off while in Netflix and it simply shut down the WD without asking any annoying questions…. So far so good, my next test was to access a shared video on the desktop of one of the computers I have networked in my home. Again I was surprised that I WAS able to access and play it, the entire procedure also seemed QUICKER than the previous version, which in my case was 1.06.16_B. Another little perk I noticed was that I able to see and image on the folder of a “desktop” video, the only way I had this bit of fluff in the past is when I was viewing a movie folder that was attached directly to the WD device via a USB drive…nice touch.

I thought…WOW…they finally got it right!..or so I thought. I rebooted the device and when I went back in to access my “desktop” from the WDLIVE Plus it would reboot every time I double clicked on the desktop…no more “shared” files…all was lost. Netflix was still working handsomely with the improvements  mentioned above but that really was a moot point…I have eight computers on my home network and obviously accessing media on those computers from the WD plus is one of the MAIN reasons for having it in the first place.

I WON’T go into my following attempts to get the device working except to say I installed and UN-installed the update about FIVE times…all with similar results. And then I tried something different!..and it seems to have worked…at least for me it has.

I had rolled back to 1.06.16_B for the fifth time and then I had a new idea so I allowed the device to update once again to 1.06.42_B over my LAN, I did NOT download it and install it from a USB stick. Though that may work too. When the firmware finished installing and rebooted for the last time I SHUT the WD DOWN again then RE-booted AGAIN…when the unit finished re-booting completely I DIS-connected the power cord for about eight seconds then plugged it back in. When it came back on every thing was working as I mentioned above but there was a difference it CONTINUED to work even when I shut the power off with the remote and then turned it back on with the remote and this time EVERYTHING continued to work! I have since then shut the power off and turned it back on with the remote a half dozen time and all is well. I have noticed in the past that dis-connecting the power from the device while it’s on and then re-supplying the power was able to correct some issues that could NOT be corrected by a simple re-boot of the device via the remote shut off. This seems more like a cold reboot…CAUTION…when and if you dis-connect the power make very sure you do NOT have a USB hard drive connected to the WD…disconnect this first or you might mess up some files!

Another problem I noticed with the update to 1.06.42_B is I have some DVD’s I have copied to a hard drive as VOB files, it’s basically doing a FULL disk copy but rather than to blank DVD it’s copied to a HARD DRIVE. The WD plays these files well and the advantage is you will still be able to access the menu system and ALL the “extras”. After the update to 1.06.42_B when I went to play one of these files that I had stopped watching about half way through the WD crashed, everything froze so I had to once again disconnect the unit and do a cold re-boot. I have tracked the problem down to the bookmark files, when you update to the NEW firmware it seems to crash the system IF you have any of these bookmark files in the VIDEO folder. The solution is simple, just delete them, they are .bmk files. Once this is done the NEW BMK files you create with the NEW firmware update seem NOT to cause the problem.

R_Daneel - the firmware for the live plus always ends in a B just as the live firmware always ends in a V. Its the first letter of the WD codeword for the players.

Thanks for that feedback richUK…I wasn’t sure if the B designation was a reference to a new update or not…I just woke up and have rebooted my main computer in addition to my WDTV Live Plus…amazingly everything is still working, I’m still able to access shared files on the desktop of my computer and I am also able to access shared files on a second computer hooked up to my LAN.

I have two other WDTV Live Plus devices which I will try to update later today and I will report back on that experience.

At this stage I’m guessing that WD may have addressed some of the problems noted in this thread and quietly “fixed” some of them.

I just updated my SECOND WDTV Live Plus device over the internet. When the update was complete and the system rebooted to complete the installation I allowed it to stabilize for about ten minutes, I then went directly to Network Shares and clicked on it but there was no response. I tried clicking on it again several more times and no response. I shut down the WD device using the remote and then turned it back on, again using the remote. When the system was back up I went once again to Network Shares and was able to access and play files on other computers on my LAN and on another WDTV Live Plus device that had and attached USB HD…no problems. KEEP READING!!!

From past experience I still wasn’t satisfied that the system was actually working reliably so I shut the WD down once again using the remote and restarted it with the remote. When the system was back up and stable I went directly to Network Shares and once again…NO ACCESS! I’d click on “Network Shares” and nothing would happen. So I tried the method I described in an earlier post just above…with the attached USB drive PROPERLY ejected and powered down I disconnected the power from the WDTV Live Plus for about eight to ten seconds than re-connected the power cord. When it came back up Network Shares were now accessible once again…now for the big test to see if that resolved the problem of the disappearing Network Shares. I shut the WD down WITH THE REMOTE in normal fashion and then powered it back on WITH THE REMOTE. When the system was back on I went to Network Shares and was delighted to find I was able to access everything once again…I accessed other computers and another WD device with an attached USB HD.

I have now shut the system down and restarted about a half dozen times, in NORMAL fashion with the remote, and ALL Network Shares REMAIN available after each reboot. I think this might be a solution for SOME people, give it a try, the COLD REBOOT (unplugging the power cord for about ten seconds AFTER the update then plugging it back in with the power OFF ANY ATTACHED USB HD!)seems to KICK the WD in the pants and force it back to a normal state that recognizes Network Shares…I’ve done this on TWO devices and it has worked on both of them. I have a third WDTV Live Plus which I’ll work on later today…if I have the time?..:wink:

I have tested MKV, AVI and MP4 files so far and they all seem to work for me.

Good luck.

Re: New Release - WD TV Live Plus Firmware Version 1.06.42_B (1/17/13)

I cannot connect to wireless network, worked with prior firmware.

I’m using wireless router D-Link DIR-825 2.4GHz band radio and USB adapter Linksys AE1000.

I’m able to connect to D-Link DIR-825 5GHz band radio and another wireless router’s 2.4GHz band radio.

I tried changing 802.11 modes, wireless channels, channel width and security modes.

Does anyone else have this problem?

Does anyone have wireless router D-Link DIR-825?