New Release - WD SmartWare Version 2.2.1 for Windows (11/25/13)

WD is pleased to release WD SmartWare Version 2.2.1 for Windows.

  • Fixes an issue where new files are not backing up properly in some instances.

Please feel free to post your questions and experiences to this thread.

Link is broken. Cannot download.

WD is pleased to release WD SmartWare Version 2.2.1 for Windows.


This  link is brocken “File not Found”

Can you fix the link please.


Rogere H.

broken link…“File not found”…

Bill_S wrote:

WD is pleased to release WD SmartWare Version 2.2.1 for Windows.


  • Fixes an issue where new files are not backing up properly in some instances.

Please feel free to post your questions and experiences to this thread.


The Download Now Link is broken:

Please advise.



Hello all; I’m not sure what is going on, but the download link in Bill_S’s original post works for me. I tried it last night and again a minute ago. The file downloaded without a problem.

1 Like

If you already run quick view / smartware then it will inform you of the update when you boot up your computer and you can download it directly. I have just done that with success.

We tested this and it’s working fine.  Are you downloading from our SmartWare landing page, or from the software user interface?

Okay, there was a short period where the links got messed up, but all should be working fine now.

These are the results of my initial testing of the new version SmartWare.

My computer and network configuration hasn’t changed since I observed the well documented issues, my personal experience also, with earlier versions of 2.x. I mention this because the baseline should be the same for judging the testing metrics and results. I have two 1TB MyBookLive Drives (named MyBookLive and MyBookLive02) on my network; connected to my NetGear WNDR4500 Router’s Gigabit Ethernet Ports. Both drives are still on version 02.42.02-012 Core F/W. The computer I use and ran the test from is connected wirelessly through the 2.4Ghz band at 450Mbps.

Yesterday, I downloaded and installed the new software. It was a clean install since I’d uninstalled the previous version due to the not backing up new files issue, completely cleaned my hard drive and registry, and then did an install from the downloaded file. I went through the preparation and setup, set the drive named MyBookLive as the target, provided the login information, selected category backup, and left it on continuous backup, but didn’t enable backups. After a restart I launched SmartWare, enabled Backups, and the backup process started. It showed 12199 files, 12.84GB, to backup. The backup seemed to be progressing very slow and after checking my network discovered that somehow the wireless adapter on my computer had selected the 5GHz network, not the 2.4Ghz network I normally use. I left it alone and let the backup complete. It took 2 hours and 8 minutes to complete. That is roughly 1 hour longer for the same amount and distribution (photos, documents, E-mail, Movies, and Other) of data than earlier versions of SmartWare 2.x.

Since I had the weird issue with my setup using the 5Ghz band and to make sure that issue hadn’t caused the slow backup, I uninstalled SmartWare, completely cleaned my hard drive and registry, and then did an install from the downloaded file following the same setup as previously mentioned. After a restart I launched SmartWare, enabled Backups, and the backup process started. It showed 12201 files, 12.88GB, to backup. This time there were no weird network problems, my PC used the 2.4Ghz network, but the backup still took 2 hours and 15 minutes.

This version is clearly slower for an initial backup than the previous versions, by 1 hour in my case. I seem to remember this happened once before and WD corrected the problem, but it was much slower then and the initial backup was taking 3-4 hours for roughly the same amount of data.

This afternoon I added 2 photos via Photostream. Smartware found the 2 photos and added them to the backup file on the MyBookLive.

I just checked and SmartWare has already added the Word Document I used for the write-up while I was typing it. So far, it looks like this version of SmartWare is working. Sure hope the initial backup speed issue can be fixed in the event I have to do a reinstall from scratch. Sure hope SmartWare is finally fixed and useable for the long run!!!

One thing I’ve also noticed; my non-backup drive (MyBookLive02) stays active (green light) during the complete backup process even though it isn’t the target and being written to. Perhaps this is something that can be fixed too!

If anything changes, I’ll post my observations to this thread; so far so good; except for that too slow thing!!! :smiley:

Update 1: I’ve noticed two issues, for me anyway, while using Continuous Backup.

  1. Continuous Backup appears to disable or cause the Windows Power Settings that allow the computer to go to sleep after a preset period of inactivity, to not work. I’ve experienced this in previous versions (1.6x and 2x).

  2. The target backup drive (MyBookLive) stays in Active/Ready (green light) status and never goes to Standby (blue light) unless I force my computer into sleep mode.

I’ve switched to Scheduled Backup, which resolves issue number 2, the drive always staying Active/Ready, but issue number 1, which was resolved with the release of SmartWare version 2.0.0 is now once again broken.

I’ve added some new pictures, so we’ll see if they are added to the backup at the prescribed time. However, sadly, even if new files are backed up with Scheduled Backup; the return of the Sleep Mode issue will probably render SmartWare useless to me. If the recently added files are added to the backup on MyBookLive, I’ll try disabling backup, which might allow Sleep Mode to work, and then add a few files, temporarily enable backup and see if new or changed files are discovered and added to the MyBookLive backup. If so, I would probably consider this new version of SmartWare, while a huge disappointment, marginally useful. Thank goodness Windows 7 Pro’s backup works flawlessly!!!

Update 2: The eleven pictures I added were backed up to the target MyBookLive at the designated time. And, and edited Word Document was also updated on the target drive. So far, both Continuous Backup and Scheduled Backup are backing up newly added or changed files.

Also, after the scheduled backup completed this afternoon, my computer went to sleep according to the Windows Power Management Plan I’ve set. It wasn’t going to sleep earlier, but now it did. Before I make any more changes to my backup settings in SmartWare; I’ll monitor the computer sleep issues.

Well, those are my findings related to SmartWare version, so far, your mileage might vary!!! :neutral_face:

I’ll update this post if there’s anything significant to add.

I have a problem backing up files with the passport. Started about two weeks ago.

Backs up all the rubbish, but none of my word docs (since I am an author this is an issue)

I have run all three diagnostics, run malwarebytes, and tonight updated to 2.2. 1…

Nothing, it does not work.

The only way I can back up is by copy and pasting manually.

Getting to the point of just using it as a spare pen drive…one heck of an expensive pen drive!

I thought it would solve all my back up problems but I am sorely disappointed.

I hasten to add, it worked fine until I downloaded the updated software 2.2. 0…

Don’t suppose you have the link to reinstall the older version that the drive came with? 

I downloaded, installed and rebooted but 2.2.1 backs up nothing . VERY Frustrating

Same here. It doesn’t detect and backup jpg files in a folder.

The update would not install and gave an error message that I needed to check my privileges.  I am the administrator so I don’t understand why the update would not install.  Any suggestions.   Toby

I had issues with 1.6.x (I tried .2 and .5) with the backup of large files for example outlook.pst files.  I tried 2.2.0 with limited sucess, the large files got backed up but new files did not.  This version 2.2.1 seems to be working for me, its backing up large files correctly, new files and new folders.  So far so good.  Install went fine for me.  Also noted is I am running the latest MS .net 4.5.1,a requirement according to WD I found out via email support.   Vista with a passport.

I have just installed version 2.2.1, but still do not see any new files and folders being backuped (they do not appear in the retrieve folder/files structure, even though the new folder/files are checked for backup abd a backup is 'successfull according to Smartware)???

Just checked on my backups and find that it’s not working, too. It’s behaving as if I don’t have a registered copy of the Pro version… but I do. All backups except the one related to the WD drive I got the software on originally, show as grey. It was working originally so the problem might relate to the latest update of the software.

Update. Seems to be working after I did an uninstall/reinstall and re-setup my plans. I just looked at the backup drives to remind me of what was being backed up and where.

Update 3: Version has been working fine for me since 11/25 in Scheduled Backup, Category Backup mode. So far my only complaints or observations of perceived problems were discussed in my prior posts in this thread.

Hi, I have version 2.2.0 and have tried over and over, every which way, turned off security feature, to dowload 2.2.1.  I keep getting a partial download.  My drive has never worked properly and I’m getting quite frustrated.  I’d really appreciate any help you can give me.