New Release - WD Smartware Version 2.0.0 for Windows (4/16/13)

WD is pleased to announce the release of its WD Smartware update for Windows.

  • You may post your experiences in this thread.

[Edit - 4/29/13]

We released version 2.0.1 today.  However, we are keeping this thread open, since it was a minor update.

SmartWare 2.0.1 Update

  • Added capability to select a specific currency when purchasing WD SmartWare Pro.
1 Like

Works great - easy to use.

Could we have backup to other cloud services than Dropbox - maybe Skydrive or Google Drive.

Dropbox it working fine - but limited space available - unless you buy more space.

1 Like

I understand that this dropbox integration is for people who don’t want to manually upload through dropbox. But can you please keep the upgrade to smartware pro tab hidden from view for the people who do not want this service.

Does this new version solve the problem of Smartware not allowing a Win7 machine to go automatically into sleep mode that was an issue with 1.6.4 and 1.6.5?

Help! Al my MyBook Live settings are gone (probably) after the smartware update.

How can I make my user shares accessible again? Based on the data usage the data looks to be still on the drive, but isn’t visible as share.

Please advice.

Kind regards,


Hi there. I have been trying with no sucess to backup Outlook PST files since version 1.5x, 1.6x…  And now  2.0.x…

I don’t know what to do anymore.

It seems this is a known problem with this software.

Need some advice here.

I have 2 PC´s, one with Win 7 and one with Win 8 - both are able to hybernate (fall to sleep) and resume again.

I have not been using WD Smartware before version 2.0.0.x - but there is no problem in this version…

Strange … running Outlook (from Office 2010 Suite) and both my Outlook data files (outlook.pst and archive.pst) are backed up.

Are You sure that Outlook is´nt running in the background?
Try Ctrl + Alt + Del and check the processes for Outlook…

VulkanBros wrote:

I have 2 PC´s, one with Win 7 and one with Win 8 - both are able to hybernate (fall to sleep) and resume again.


I have not been using WD Smartware before version 2.0.0.x - but there is no problem in this version…

I’d given up on WD fixing Smartware, but if that is true, then I might have to try version 2.0.0; maybe other problems have been addressed too!!!

I got the software update prompt on starting smartware and mow this new version prompts me for a password to access the drive.

Meanwhile I never set up a password for my drive. How do I fix this. I thought this problem had been fixed by WD after all this time and complaints. I am running vista home premium 64 and have a 1TB my book live drive. I also updated my drive firmware to the latest version.

There seems to be a loss of functionality in version 2.0.0 compared with 1.6.5 - the prior version allowed the backup of multiple drives to a Passport drive but the latest version seems to only allow one drive to be backed up. Am I missing something?

For now I’m rolling back to (per a KB article that details rolling back from 2.0.0) andkeeping my fingers crossed that all my prior backups will be fully accessible…

Still dont work. Smartware try to start op but got a erro. assemblyen WDIO.dll plese fix it.

I runn windows 7 64bit

Thanks for the advice, but no… Outlook is not running on the background. I have tried everything possible on previous versions of Smartware…

I will keep doing some more tests…

I wish WD folks issue some comments about that, as a lot of people have the same problem… just google for it…

Running Windows XP 32 bit, with all the mentioned software, but after completing the installation my smartware is still 1.6.5

I’m using Smartware 2.0.0 with a My Passport on a Win 7 64-bit system. The initial backup was fine. Any files I create or modify while the drive is plugged in are immediately backed up. But any file I create or modify while the drive is not plugged in do NOT get backed up when I later plug the drive in.

Checking the SmartWare backup tab, the message at the top says the backup is complete. The file count on the right has no pending files. But if I look in the retrieve tab to retrieve these files, they are not there, and if I look on the drive itself, they are not there. If I then open one of these files while the drive is plugged in, modify it, and save it, it’s immediately backed up.

I have tried uninstalling and reinstalling SmartWare, rebooting, starting and stopping the WD services, with no change. In case it was just a matter of time, I’ve left the drive plugged in for 48 hours, and still these files don’t get backed up.

If anyone has a fix for this, I’d greatly appreciate it. I’m on the verge of giving up and going with another app.

AncientBrit, the backup interface is different now. On the backup tab, under your computer, there should be a dropdown list with each drive in it. You select each one, and then check folders separately, instead of the old interface where all drives were listed in the pane.

Did you do the downgrade from 2.0 to 1.6 and did it work? I’m considering trying that to see if it solves my problem with files not backing up.

New software now works great, starts up faster and also backs up outlook.

I have checked and I have the correct firmware for my Passport.  I’m at software level and the home screen says I should download 2.0.  I’ve done that and run the installer.  It finishes, but after restarting my PC and starting Smartware, it says I’m still at  I’ve tried it (5) times and the same thing happens.

Anybody got any ideas?

So, I have tried (6) times to install new software 2.0 on my Win 7 Home Premium PC.  It says it installs, but when I start Smartware, some error block comes across the screen then vanishes fast and Smartware does not come up.  And yes, I’ve performed all the documented instruections to install and restart my machine.  This version just doesn’t work, so I’m going back to rlse which works fine.

Just let me know when you have a new rlse of 2.0

This is a follow up to my post on the Smartware version 1.6.5 thread that detailed my three major problems with the 1.6.X versions of software. I’ve installed (no problems) Smartware version 2.0.0, performed an initial backup, and these are my findings compared to those three issues.

1.6.X Issue 1 – Starting with the 1.6.X versions of Smartware Windows 7’s Power Management was disrupted or disabled; specifically, the computer would never go into Sleep Mode according to the Power Management Plan. It didn’t matter whether Smartware backup was stopped or started.

Finding: I’m happy to say that this issue has been corrected in Smartware version 2.0.0!!! With Smartware installed, but with backup disabled after the initial backup (the only mode I’ve tested so far), the computer will now go to sleep according to the Windows 7 settings.

1.6.X Issue 2 – In the 1.6.X versions of Smartware it took an inordinate amount of time to perform the initial backup. Specifically, with version 1.6.5 it took me, on an idle computer (nothing else going on), 7 hours and 26 minutes to perform a dedicated initial Category Backup (11,350 Files – 11.1GB) over a Wireless N connection to one of my 1TB MyBookLives. Using Windows 7 Pro’s network backup to the same 1TB MyBookLive; it took about half that time to back up the same Data Files that Smartware did, plus a System Image of both the Recovery Partition of my local drive and the OS © for a total of 71.3GB. 11.1GB compared to 71.3GB!

Finding: I’m happy to say there’s been a dramatic improvement in version 2.0.0!!! I honestly can’t accurately quantify the improvement because I’ve improved my network since that measurement, but on the same idle computer (nothing else going on); it took 1 hour and 5 minutes to perform a dedicated Category Backup using the Continuous Backup setting (11,444 Files – 10.7GB) over a Wireless N connection to the same 1TB MyBookLive.

1.6.5 Issue 3 – I prefer to use Backup as “on demand”, not continually performing in the background. So, with versions prior to 1.6.x I would launch Smartware, turn on Backup, it would quickly categorize and back up all of my Category Files (new or changed files), and when backup was complete I would turn Backup off. With 1.6.x, after the initial lengthy Backup, when I launch Smartware it categorizes my files and if you mouse over the categories in your primary drive’s © panel, you can see the file count and note the increase from the same categories that are shown in the MyBookLive Backup panel (current backup). When you select that drive for Backup, for some reason the number of files in the categories of your primary drive are reset (decremented) to match the target MyBookLive; basically showing no files for Backup. At that point nothing happens, it doesn’t perform a Backup. Perhaps if I left Backup turned on it would eventually perform the necessary backup, but that’s not how Smartware versions prior to 1.6.x worked and not how I want to use it. With 1.6.x I’ve never seen a successful backup of files awaiting backup after that initial lengthy backup.

Comment: After the initial complete backup tonight using version 2.0.0; I disabled backup. I haven’t tested this “On Demand” so-to-speak method/issue yet; I’ll wait for a few new files to be added and then I’ll Enable Backup and see how it performs. Once I test it, I’ll update this post.

Update, Finding: I added 22 pictures and several documents since the initial backup this evening. So, I launched Smartware and Enabled Backup. Although I didn’t see a display saying it was categorizing my files, it quickly found the new files (pictures and documents) and backed them up. So, it appears that what I’d call an “On Demand” style of backup, that I prefer, works in this version, so far, good deal, thanks again!!!

Thanks WD; you’ve restored some of my confidence!!!


1 Like