New Release - WD SmartWare for Windows Version 2.3.0 (3/4/14)

WD is pleased to announce the release of WD SmartWare Version 2.3.0 for Windows.

  • WD SmartWare now works with the My Cloud EX2.

Please feel free to post your experiences in this thread.

It does not work!!!

Having waited a long time for WD Smartware v 2.2.0 to be issued to “finally” fix the problem of files not being backed up I have updated one of my PCs to version 2.3.0  only to discover that it is not backing up files. Version 2.2.0 worked perfectly on all my systems and now I am back to square 1.  Can someone give me a link to download version 2.2.0 again until this new version is sorted out. How long do we have to wait this time??

If it ain’t broke - Don’t fix it.  !!

Yes where can we get the previous version?  The new one does not work.  It just sits there saying it is copying files and does not back up anything.  DO NOT DOWNLOAD THE NEW VERSION!!!

This version does NOT work.  I am getting the Copying file message, but it isn’t copying anything.  I need a fix ASAP.

I selected a new folder to start backing up and monitoring once the update for 2.3 was installed.  It says it is copying files, but it has only copied 1 file in the past 2 days.  I have tried rebooting, disabling and re-enabling the backup, and even clearing the backup settings completely and starting over.

SmartWare 2.3 is also a huge resource hog (my laptop drive just spins and spins…sounds like a helicopter now).

Tech support told me to uninstall and reinstall.  It did not help.  This version simply does not work. Geez, what do we have to do to get the version that worked before they “fixed” it.

I lost access to my drive following 2 restarts. My network no longer shows the drive.

I began setting up a 2TB MBL last week.  I have loaded the software on one hardwired Win7 pc and 2 wireless Win7 pcs.  All 3 have discovered the MBL, but 2.3.0 SmartWare has only recognized the MBL on the wired system.  If I connect both wireless units via Cat6 cable to my router, SmartWare locates the MBL and will create a backup.  Disconnect the hardwire and the disk disappears.

WD support tells me “The issue is related to the WD SmartWare software, our server is having issues again.”  Why does their server have anything to do with my personal cloud?  Are they just saying the 2.3.0 code has a bug that won’t let my MBL appear to wireless users?

How can you backup tablets and smartphones if the system doesn’t do wireless?

I am updating my issue.  I fixed my problem by doing a cycle…unplugging for more than 20 seconds, rather than shorter unpluggings which left the blue light on. Now all is working, not sure why it broke to begin with… but…My Vista is wired, and is my only home computer.

I installed a fresh version 2.3.0 (no prior versions had been installed).  Initially it started running fine, but stalled out with no file progress being shown.  I tried uninstalling and reinstalling and it initially appeared to work.  But now it’s stalled out again.  I’ve also unplugged the drive power cord several times as suggested above with no effect.

Where’s access to the prior version?

I have my backup scheduled to run every morning @ 1AM and not once has it ever still been running when I wake up @ 7AM, however, that’s definitely not the case now that I’ve installed version 2.3. When I wake up @ 7AM now it is STILL “copying files” and completely bogging down my desktop making it unusable. Last Saturday I wanted to see how long it would run, so I stayed off my desktop all day and at 3PM I had finally had enough and just shut it off because it was still running. I’ve uninstalled/reinstalled it, and like everyone else it made no difference, it still continuously runs once it is started and will not stop until you unplug it or restart your computer. It’s been over a week now and it’s really starting to ■■■■ me off, especially since I cannot seem to find anywhere to find someplace to download version 2.2.

I have uninstalled 2.3 and reinstalled 2.2.  It is now working and I will not upgrade again.


Same problem. I had 2.2.0 installed and it was working fine for the first month. Once I updated, I started to notice that something wrong happens. It is showing “copying files” continuosly

I’ve tried everything, uninstall, re-install, clean register, everything unsuccesfully.

Please, help!!


I am running Windows 7 on an old Toshiba laptop (Satellite A105-S4211 that I’ve updated the hardware on). Awhile back I installed a WD MyBook 3TB external drive for backups. It seemed to be working. There would be flurries of CPU consumption, but they would quiet down. I’ve never had to restore, so I’m taking it on faith that I’d be able to restore something if I needed.

From time to time it tells me that a software update is available and I install it. I did that today to WD SmartWare 2.3.0. Seemingly a bad idea.

Since the update the Windows Resource Monitor tells me that the process WDBackupEngine.exe is using in the neighborhood of 50% of my CPU. It also tells me that the services WDBackup and WDDriveService are together using in the neighborhood of 50% CPU. Backup is using 90+% of my CPU? Really?!?

When I start up WD SmartWare to see what it’s doing, it doesn’t tell me much. It says “59.46 GB of 59.46 GB copied”. That sounds like it should be done.

So, why is it still using over 90% of my CPU? I disconnect the drive and reboot and my idling machine indicates it’s using 0-5% CPU. I plug the drive back in and I’m back to 90+% CPU.

Resource Monitor also tells me that WDBackupEngine.exe is doing disk I/O, reads and writes, but not a lot … less than 1% active time.

What’s it doing? How can I get my idle CPU back?


Like others suggested here, I reinstalled WD SmartWare 2.3.0. Now it seems to be behaving normally.

I booted the PC with the disk drive disconnected. I went into Control Panel >> Uninstall a program, scrolled down and Uninstalled in turn WD Quick View, WD SmartWare, and WD SmartWare Installer. After the Uninstalls were complete I downloaded, used WinZip to open it and ran WD SmartWare Installer.exe.

Once the installation was complete, I started WD SmartWare, plugged in the WD MyBook 3TB external drive, unlocked it, and performed a backup. When the backup completed, WD SmartWare reported the backup was complete and the PC returned to idle. Yay!

Where can we find release 2.2 (for those who started on 2.3 and experienced problems?

Edit: I tried uninstalling and then reinstalling the software, and the problem appears to have gone away for now. I’ll see how it does as time goes by.

_ Original message: _

I had to register just to say that this version does not work properly with my My Passport 1TB drive. I keep selecting specific folders to back-up and then try to apply the change, but it unchecks the folders by itself. Also, I experienced from prior versions not being able to back up and update the changes in the files/folders automatically. I had to manually add/remove files directly from the hard drive instead of having the software do it for me, which is what it was advertised to do.


It’s a shame that the software is making this hardware and it’s brand look bad in my eyes. A major deterrant from buying its future products.

Smartware Pro 2.3.0 on win7  will only innitiate automatic back up if I have the program open. Otherwise I will get a taskbar error message: back up failed, unable to authenticate the login information

The drive is not password protected and do not need to login to access my drive when I open smartware.

Any solutions?

I did the uninstall/reinstall and it didn’t fix the problem.

Hi Guys

Having a problem with activation - 'Smart’ware 2.3.0 keeps loosing it. When you re-installed the previous versions did you have to re-build your backup plans?.

I have the same problem with 2.3.0. I have got some advice from WD-support but so far it doesn’t work.