New Release - WD My Cloud Firmware Release 4.01.03-421 (2/23/15)

Good afternoon Bill,

I am excited to hear about the update since I am a Mac user and time machine user.  Unfortuneatly I thought this update would also fix the issue of connecting a USB external hard drive to the MyCloud or MyCloudMirror causes connectivity issues.  If you plug in the external hard drive for backup purposes you have about 10 minutes before the device loses connectivity. The only way to fix the issue is to unplug the external hard drive (via USB port).

Was I incorrect this update was to fix this issue too?

Thank you for your continued help!


Macbook Air mid 2011

Seagate External hard drive



Netgear R7000 router

Brighthouse Lighting 75

Are you using the drive in conjunction with Time Machine, or are you using it separately to copy and paste to?

Thanks for the reply Bill.

The external hard drive is used for Time Machine and for safepoint backups for the MyCloud.  Outside of those functuions the hard drive is not used.

I do not back up the MyMirror even though I have tried to plug in the external hard drive and have the same issues.

I hope I answered your question!

Thanks again,


Are you leaving the drive connected to the My Cloud, and then doing both Time Machine and Safepoint backups to it?  If so it should work.  What do you have the drive formatted as?

Updating Firmware from internet is a scary thing… since download status doesn’t change.

I risked and unpluged WD My Cloud since it stays at 0% download status for over 15 minutes,

and sicne I had latest FW 04.01.03-421 already on my local disk…

DONE – UPGRADE went well as expected, from locak disk on locak network…

To conclude: UPGRADE STATUS BAR works well while DOWNLOAD STATUS BAR does not.

All of us, your customers, would appreciate if you can fix download status bar in the future…

P.S. My internet connection is fast enough… I was downloading from your website at over 1MBps speed.

Daylight Saving Time

I have today bought a 4TB WD My Cloud and have updated to v04.01.03-421. It’s going very nicely so far!

What I do notice though is that the time shown in the web UI does not show the correct time adjusted for daylight saving - it’s one hour out. I found this post about it from about a year ago. When I ssh onto the My Cloud and run a “date” command, I can see that the time according to the operating system is correct though. It’s just the web UI that shows the wrong time.

Maybe in a future firmware this could be addressed please?

Have they fixed the issue with backups.

ive been getting the i error message from the last two updates

“Your safepoint cannot be updated due to a failed request. Please try again. (36323)”.

Its beyond frustrating at this point.

there really should be a partition on the drive itself to allow for a FULL filesystem restore.   Once the system is corrupt the average user cant fix much without knowing how to SSH into the device and force a firmware or downgrade.   I personally downgraded to version 3x and im pretty happy with it.   DNLA works good transfer speeds could be faster.  I have never tried to restore to a safepoint on version 3x as I have not needed to.  But with the 4.01.03-421 I got a dreaded cant restore error of some sort… very fustrating 


I am facing the same issue (My Cloud drive looses network connectivity after attaching external USB drive to My Cloud Drive).

I have similart Netgear R7000 AC1900 router and I am connecting WD My Book Essential 2TB drive.

Have you got any solution?


With Regards,

Kiran Nevaskar

hi Every one,

after I took last update , my WDmycloud is behaving strange again.

I lost dashboard and was not able to see it again, and all my drive appear again ( map network drive automaticly) with IP address instead. for now i accepet this , but every day all my drive stop working untill I rest the drive.

last 2 months i had issu with the update and took me time to fix everything. i started to be afraid of each update ,WD does.

Please WD , dont do update any more to the Drive, each update my drive is going backwords.

the update was successful so i dont see any reason why the drive is behaving bad.

 Please WD , dont do update any more to the Drive, each update my drive is going backwords.

Turn off automatic firmware upgrade, then…

Dashboard | Settings | Firmware | Auto update | Enable auto update | Off

A System Restore is often useful after a firmware upgrade.

1 Like

sure , when i will have my dashboard again.

when i open the browser and point to WDMYCLOUD , i got white page for 15 minutes and then error the connection was reset.

Unable to connect

Firefox can’t establish a connection to the server at

    The site could be temporarily unavailable or too busy. Try again in a few moments.
    If you are unable to load any pages, check your computer’s network connection.
    If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

Try a 40 second reset. Then you should be able to see your dashboard. It would be a good idea to downgrade your firmware to v3, which is much more stable.

Read this:

Then, disable the unnecessary scanning services. Read about it here:

1 Like

If you stay on version 4 … then set your “Cloud Access” to “Off” due to security issues … just a FYI


Hi dubie

everytime I can not access my network drive i do 40 sec reset , then I get them back , but the dashboard 80 % of the time doesnot work and when it work and I see it , then any menu I click it takes time and the end it give me different error each time.

last time i had problem when I upgrade my code , I used one of your link down to disable scanning and empty some backup that WD safe on the drive , and disabled the media server, and it start to give me better result on the dash board , so i enabled the SSH. and FTP.

now after the new code my dashboard giving me problem , to load , and when its load , I can not enable SSH so I can follow your second link.

WD should make SSH and FTP on by default after restarting the drive 40s it will make maintenance much easier.

I just wonder why every update gives such prblems everytime.?

I work for satellite company , and everytime we have new code release we have SVT team that test the code and be sure that it will work on all units , and that incase customer start to have problem , he can go back  to the old code by some commands. always there is 2 codes inside the machine.



Hi sectorGZ

thanks for advise , I will do it the first time my dashboard will work again.


I understand your problem better now and share your frustration over the previous firmware updates. Do you have any device attached to the USB port? If so, disconnect that before performing the 40 sec reset.

If your dashboard won’t let you enable SSH, I can’t suggest a solution. It’s probably time to contact WD directly and ask for a replacement drive. No doubt they will be sympathetic if their firmware upgrades have wrecked your device.

Hi Streamview, I remember your previous posts now. It does seem that your firmware is corrupted.

If you can possibly get into your dashboard and enable SSH, you will be safer to downgrade the firmware using the SSH method described here:

honestly i will try my best because i dontt like to send and drive with private data to WD .( some time i feel that they are downloading my data secretly) i will try to connect the drive to linux system and see what i can do.


hi dubie ,

yes last time i had big problem and the drive and following users instuction , ( deleting back up that wd keep on drive) and cancelling the media server , and reset 40s , and this helped alot and my drive was 90% stable and i see my drives always but after last update , its again bad  more than before, because dashboard doesnt load in good way.

the software update end with successful message , so I dont think its corrupted. and if its corrupted we should ask why? is there any reason for a software to be corrupted?? unless there is bug with it.

at work many time i saw some upgrade works on some version and corrupted on other , then engineer tweak the software and SVT team re try , untill everything is good , then we send it out.

any way i will keep trying untill the dashboard work again and my SSH worked , then maybe i have to delete the back up files again.

I will downgrade the software and remove auto update.

when i bought it , last year and half, it worked 1 year with no problem at all untill the 3rd upgrade.