NEW RELEASE: WD Discovery 3.7.214 - My Cloud Home Desktop App Sharing Feature

WD Discovery 3.7.214 is being released for phased auto updates and contains the new
Sharing feature for the My Cloud Home Desktop App. This version is currently not available for manual download at this time.

WHAT’S NEW?

  • My Cloud Home Desktop App will be able to access Private Share Folders via the Shared Tab.
  • Resolved the issue with Google import failed
  • Resolved the issue with MCH Desktop Sync High CPU usage
  • Support PIDs for easy store

Answer ID 28861 My Cloud Home Desktop App Sharing
https://support-en.wd.com/app/answers/detail/a_id/28861

1 Like

It’s not autoupdating here on macOS (Catalina, 10.15.3). Either when set in French or English.

1 Like

Nor on Windows (10, 1909)

@AustinForest it’s a staged roll out for WD Discovery - (25% on 3/23 , 50% on 3/24, 100% on 3/26)

Thanks for letting us know.
Does it also require the new firmware 7.4.0?

New firmware is not required but eventually 7.4 will be rolled out to 100% as well.

Edit: Resolved and now functioning correctly :slight_smile:
I worked through and fixed the problem myself after being frightened by the amount of work required to deal with the initial support response - one which I now conclude was designed to be some sort of cunning psychological thing, which clearly had the desired effect.

There may be an easier way but after inspecting error logs I tried the unofficial repair method, i.e. install over the existing one.
===>>> Log in to the web UI and click ‘get desktop app’ - if it ‘sticks’ then manually delete the discovery desktop shortcut if still there (and exit web UI and browser) and the installation should continue and complete successfully, and be the new version with a notification saying ‘successfully updated’.


[[ Shortened original problem: On windows 7 I am getting ‘update failed please restart and try again’ […snip…] update package downloads OK, extracts OK and gets a fair way through the installation before stopping.]]

The availability of the Shared folders on the Desktop has made a huge difference to the usefulness of the device!

So have a +1 and a :clap: with a :+1: and obviously some :cake:

But in the true spirit of giving with one hand and taking with the other :smiling_imp: this should have been available right from the start but better late than never :slight_smile:

1 Like

@SBrown It hasn’t updated on any of my machines - 3 x running Catalina 10.15.4, one running High Sierra.

Has the staged roll out been delayed or could something else be wrong?

1 Like

I still hav the issue with the icon not appearing in the menu bar on macOS while the system changes from dark mode to light mode and vice versa…

Another issue is the volume icon not showing up (sometimes) after waking up the Mac. (looks like a regression)

Another issue… Frightening. It looks like my Catalina’s Macintosh HD - Data has been renamed after the name given to my MCH.

See for yourself below. **What should I do? @SBrown **

I have this exact same problem.

1 Like

Hello,
I have been contacted by @wdsal after my message. He is from support staff and asked for logs and profile, which I sent.
Did they get in touch with you? Another way is to create up your own support.

I am really worried the app could have modified the name schemes of my internal volumes…

Good luck.

Hi @AustinForest - no, sadly no one has got in touch with me. Please let me know if the come up with a solution for you, and I’ll also let you know if I hear from them.

@wdsal and @SBrown maybe of interest for you I installed The new version with the full download manually as provided by @SBrown not the auto update thing. As auto update was not triggered automatically.

Well. without news from wd, I had to clean install my MacBook Air.

Just to let you that after resuming synchronisation with Discovery. First it was really slow, and secondly, add kdd’s CPU went really high (150% on my dual core) and even after synchronisation was over (all folders turned green), kdd’s CPU remains at 100-150%.

On the release notes, it reads that the new version solved high CPU usage… yeahhhh

  • WD Sync high CPU usage fixed.

It is back with 3.8.229 this time: https://community.wd.com/t/wd-discovery-3-7-214-huge-issues/249660/11?u=austinforest

:face_with_symbols_over_mouth: