New Release - Universal Firmware Updater for Smartware Supported Drives (3/30/11)

I cannot even download the updater. All I get is a web page saying “File not found.” Were the updaters removed due to problems?

We are currently working on the webpage.  The updaters that I post above should still be functional.

I wanted to download firmware update v3.0.0.10 but the Web page not found

firmware upgrade error.pngUnfortunately the update (Windows release 3.0.1.1 (updated 4/12/2011) )-( http://www.wdc.com/wdproducts/wdsmartwareupdate/firmware.asp?pid=0730&os=WIN)) doesn’t work. There is a small window saying there was an error during the copy of a file. On the same time i see a copy window with  the computer trying to copy a file named NFU.dll but with no success. I click the ok button on the error window and the update stops

i tried this on both my computers( one HP pavilion laptop with win 7 and one pc with win XPsp3, antivirus off)

Please help us. This makes me worried that if i try a future update i might loose my data

Just found out that after the upgrade failure a new zipped file is created named: SymwaveDevicePlugin.zip.

It contains 2 files named NFU.dll & SymwaveDevicePlugin.dll

Man,

Did the update thought it went through fine.  Now it does not recognize any files to be backed up and some of the files already on the Passport drive got corrupted. Not a happy camper.

Passport USB 3.0, Windown XP

–Ken

Hi,

I also have been trying **bleep** always is partially complete.

when I try to upgrade to the new firmware it completes the download but then when i click button “upgrade firmware” it comes back with message “one module failed to install” and i tried everything. i also noticed when it tries to upgrade it copies a .zip directory to the same directory as the firmwareUpgrade.exe directory.

i am thinking may be it does not unzip during install. but when i unzip it and try to run the .exe file it still gives same message.

I have no other USB devices, my laptop is Sony Vaio and visa hom premium using a wireless home connection.

It is very **bleep** hassle free, 2 months later still not working. i bought it to travel overseas on a job and now stuck with it?!!

WD Technical team staff PLEASE HELP US. 

Sometime ago I removed the Smartware software from 2 ea. 500 GB Passports, but want to reload that software now so it can provide continual backup for for a Dell desktop. I succeeded on one laptop a week ago.

I have unsuccessfully tried on 2 different hp laptops (Win 7 - 64 bit and XP/32 bit) and 1 Dell desktop (Win 7 - 32 bit) to load the firmware and SmartWare programs (updates) on the 2nd Passport 500 GB drive. I’ve tried many times to install the firmware updater and keep getting the message like many others reported  – “… Safely unplug all drives with the exception of the one you want to update; then click rescan…”   I have only one internal hard drive on each of the 3 computers which I tried to use for this effort, and yes I did unplug every USB cable with the exception of the target Passport. I also turned off Norton anti-virus and firewall (on the 2 laptops) and McAfee on the desktop, but the same message kept appearing. I want to eventually use this Passport on the Dell desktop.

I reformatted the Passport - it still wouldn’t download the firmware – same goes for the SmartWare. The drive is good (I used Win 7 to backup the desktop’s data as a test).

Please provide a step-by-step procedure for getting past this erroneous message (and a link to the latest firmware/Smartware downloads). Like others, I’ve spent considerable time trying to get this solved.  Thanks for any help or direction on this. 

I have the same problem as some of the other forum members. Before trying to update via the universal firmware updater, I disabled antivirus, antispyware, got connected to my broadband etc. and then my drive was detected. No other external drive was plugged in. After I pressed “Continue Update” as the download started, an error message popped up saying “error copying file NFU.DLL”. A zip file called SymwaveDevicePlugin and the folder WDPlugin was created as well. Why this glitch? My WD external drive is a USB 3.0 2TB My Book Essential, updated to firmware 1.014. For the record, the last update I did about 3 months ago to update firmware to version 1.014 was glitch-free.

Maybe WD should scrap this Universal Updater thing and go back to the previous type of updater that users can manually choose and download to the computer (like v1.014). Either it’s some sort of server glitch or a problem with the “smart” detection and file transfer.

just got notice that there is new firmware (1.016).  firmware updater 3.0.1.1 wants to do update.  i shut down anti-virus, turned off windows defender, stopped these services: WDDMService, WDFME, WdiServiceHost, WdiSystemHost, WDSC.  yet when i try the update, the s/w tells me the drive is in use…

help.  something is wrong here.

it would be better if the firmware updater could shut down everything needed.

Edit:

windows 7, 64 bit

to get the update to work i had to power the drive down and back up in addition to the above steps.  and even then i had to wait on the drive’s spin latency to stop before the update worked.

The error I got for my My Book Essential USB 3.0 was probably similar to Blogmaster, since the same files were created. I was trying to download using the WIndows 3.0.1.1 universal updater when the persistent NFU.dll error appeared. My system is a WIndows XP SP3 by the way. WD Smartware 1.4.5.2, current firmware version 1.014. Trying to upgrade to the new firmware (v1.016?) without success for at least the fourth time. Something’s seriously wrong with the current firmware implementation since my previous v1.014 firmware update worked like a charm, the files already on the drive intact, etc. WD Technical Staff, some help soon? Please?

I’m getting the “phantom drives” bug with the firmware updater on WInXP Pro 64-bit.  I’m gonna try disabling the USB hubs like people have posted about.

I still have the same problem even with the new edition .016. I am very dissapointed witht WD ignoring this problem. Anyone who has solved this problem?

I have following System and can not run the firmware update tool for my WD150000C033-001. I get always the message that more than two drives are connected. No antivirus ore other programs are loaded.

My system :

Computer: Computertyp ACPI x64-based PC Betriebssystem Microsoft Windows 7 Ultimate OS Service Pack Service Pack 1

Internet Explorer 9.0.8112.16421

DirectX DirectX 11.0

Computername HANS-64PC (Hans-64PC)

Benutzername Hans Domainanmeldung HANS-64PC

Datum / Uhrzeit 2011-09-12 / 11:24

Motherboard: CPU Typ QuadCore , 3566 MHz (36 x 99)

Motherboard Name ASUS P8H67-MPro

Chipsatz Unbekannt

Arbeitsspeicher 8173 MB DIMM2: Kingston 99U5403-034.A00LF

4 GB DDR3-1333 DDR3 SDRAM (8-8-8-22 @ 609 MHz) (7-7-7-20 @ 533 MHz) (6-6-6-17 @ 457 MHz) DIMM4: Kingston 99U5403-034.A00LF

4 GB DDR3-1333 DDR3 SDRAM (8-8-8-22 @ 609 MHz) (7-7-7-20 @ 533 MHz) (6-6-6-17 @ 457 MHz)

BIOS Typ AMI (02/05/10)

Anschlüsse (COM und LPT) Communications Port (COM1) Anschlüsse (COM und LPT) Printer Port (LPT1)

Anzeige: Grafikkarte AMD Radeon HD 6900 Series (2048 MB) Grafikkarte AMD Radeon HD 6900 Series (2048 MB) 

Monitor BenQ FP991 [19" LCD] (1405307)

Monitor BenQ FP991 [19" LCD] (1410410)

Multimedia: Soundkarte High Definition Audio-Controller [1002-AA80] [NoDB]

Soundkarte Realtek ALC892 @ Intel Cougar Point PCH - High Definition

Audio Controller Datenträger: IDE Controller Intel® 6 Series/C200 Series

Chipset Family 2 port Serial ATA Storage Controller - 1C08 IDE Controller Intel® 6 Series/C200 Series Chipset Family 4 port Serial ATA Storage Controller - 1C00

IDE Controller Standard-Zweikanal-PCI-IDE-Controller Festplatte ST31000524AS ATA Device (931 GB, IDE)

Festplatte WD My Book USB Device (1397 GB, USB)

Festplatte WDC WD5000AAKX-001CA0 ATA Device (465 GB, IDE)

Optisches Laufwerk DTSoftBusCd00 Optisches Laufwerk TSSTcorp CDDVDW SH-S223C

ATA Device S.M.A.R.T. Festplatten-Status OK

Partitionen: C: (NTFS) 931.4 GB (806.9 GB frei)

D: (NTFS) 156 MB (94 MB frei)

E: (NTFS) 465.6 GB (289.9 GB frei)

H: (NTFS) 1397.3 GB (335.6 GB frei) Speicherkapazität 2794.4 GB (1432.5 GB frei)

Eingabegeräte: Tastatur HID-Tastatur Maus Ergo 525

Maus HID-konforme Maus Netzwerk:

Netzwerkkarte Compact Wireless-G USB Adapter (192.168.1.32)

Netzwerkkarte Microsoft Virtual WiFi Miniport Adapter

#3 Netzwerkkarte Realtek PCIe GBE Family Controller

Peripheriegeräte: Drucker \ACER4750G\HP Photosmart C6200 series Drucker Adobe PDF

Drucker Fax Drucker HP Photosmart C6200 series Drucker Microsoft XPS Document Writer

USB2 Controller Intel Cougar Point PCH -

USB EHCI #1 Controller USB2 Controller Intel Cougar Point PCH -

USB EHCI #2 Controller USB-Geräte Compact Wireless-G

USB Adapter

#3 USB-Geräte Ergo 525hanced Device USB-Geräte Generic USB Hub USB-Geräte Generic USB Hub USB-Geräte System Serial Number DMI System UUID 00B31F17-CB5BD911-B6FEBCAE-C56CBBD6 DMI Motherboardhersteller ASUSTeK Computer INC.

DMI Motherboardprodukt P8H67-M PRO DMI Motherboardversion Rev 1.xx DMI Motherboardseriennummer MF70B4G01101109 DMI 

BIOS ] BIOS Eigenschaften: Anbieter American Megatrends Inc. Version 1003 Freigabedatum 05/10/2011 Größe 4096 KB Bootunterstützung Floppy Disk, Hard Disk, CD-ROM Fähigkeiten Flash BIOS, Shadow BIOS, Selectable Boot, EDD, BBS Unterstützte Standards DMI, ACPI Erweiterungen PCI, USB

hi,

When using the universal updater, always says internet connection issue, and can’t download firmware.

while my downloads of other software from WD support page reaches 200kb/s