New Release - Universal Firmware Updater for Smartware Supported Drives (3/30/11)

WD is happy to announce our new Univeral Firmware Updater for Mac and Windows WD SmartWare supported drives.  This Universal Firmware Updater automatically detects and installs the latest firmware update available for your hard drive.



(Note: the My Passport Studio, My Book Studio, and My Book Studio LX are not supported under Windows.  However, they are supported in the Mac OSX firmware updater.)


Please post your experiences with this new firmware updater to this thread.

I have tried four to five times to update my Firmware for My Book Essential USB 3.0/2.0 External Hard Drive and after i follow all directions i get the same message " you can only update one drive at a time"

What do i do?

Is this a bad FIRMWARE UPDATE?

Please Respond ASAP


Do you have any other drive connected to your computer?

I have the same problem and no>>>  one drive.

Add me to the list, I get the same message.  I DO have more than one WD Passport, but only had one attached.  I tried each drive individually, twice.  I also made sure to disable anti-virus/anti-spyware software.  Actually, I followed the instructions to the letter, but still no luck.

I’m running Win7 64 bit version, which I thought might be the issue, since I’ve run into compatibility problems before.  From the looks of things, however, I’m not the only one with problems here.

So, since the request for feedback was put out there, my feedback would be “It doesn’t seem to work . . .but I’m confident it’ll get worked out”.

If anyone has any ideas or fixes, I’d appreciate the help.


Same problem here.I just bought a Western Digital “My Passport Essential SE 1 TB” external harddrive yesterday on Saturday.After installation,it showed a pop-up asking me to update.

I downloaded the firmware update first as instructed and ran it with my antivirus,firewall and all other programs disabled.Also my mouse,cooler and other usb attachments for my laptop was removed.

After accepting the license agreement,the program displayed 

"You may only update one drive at a time.

Safely unplug all drives with the exception of the one you want to update;then click Rescan."

Next I disabled all my startup programs and non-mircosoft services from msconfig,restarted and ran the updater.It showed the same error message.

I tried it in safe mode with networking with no luck.

I am running Windows 7 Ultimate 64 bit and my current firmware revision shown in WD SmartWare is “1.012”

As I couldn’t update the firmware,I just downloaded and installed the WD SmartWare program update.Current Version is “”.

I am looking for any solutions or fixes.

Thank you.

Same problem  “You may only update one drive at a time…” here. No Anti Virus Software is still running and no other USB Harddisk is connected.

My Book Essential (USB 3.0) 2 TB

OS: Win 7 x64

Need Help…

i had the issue of being told i could only update 1 drive at a time.  

i turned off my hp printer (which has card input slots) and was able to do the update.

hope this helps some of you and wd to fix their software.


Thx george_lol.

After i turned off my hp printer (which have not card input slots) too, i was able to do the WD Firmwareupdate.

Believe the software is checking to see if any USB slot is being used for any purpose, and if so, then the software is concluding that the slot is being used for a storage device.  Well, that’s not always the case; a lot of wireless mice and keyboards communicate with the CPU via a USB dongle.  And if all a person has for input devices are a wireless keyboard and a wireless mice, then unplugging the dongle is a non-starter.  This firmware loader, in other words, needs some serious corrective work.

Many thanks for the tip about the HP printer… this has been driving me mad for the last few days, but I unplugged the printer and the update worked perfectly.

PS - I have a wireless keyboard and mouse connected via a usb dongle - and the update worked fine without having to unplug them.


" then the software is concluding that the slot is being used for a storage device."

not so.  I have both a wireless keyboard/mouse and a webcam connected via usb.  these are input only devices.   the hp software setup is different.  the op sys sees the printer as an i/o device.  if i were to plug my cell phone into a usb port then the update would probably see it as an i/o device also (because of the s/w interface on my computer [i can send and receive to/from the phone when it is plugged in]) and block the firmware update until i disconnected my phone.  

What is the model of HP printer that you have connected to your computers?


Then the issue is something else entirely, and not necessarily limited to USB ports.  I have not only a wireless keyboard and mouse, I also have a wireless HP printer.  I powered down the printer while trying to run the loader software and still got the “can only do one drive at a time” message.


HP Photosmart 3100 series


sorry, i posted what worked for me, my printer is plugged directly into a usb port.  i made assumptions in the rest of my comment.  are yours connected via a router (i assume? or some other usb connection), the router is an i/o device per se.  all in all, it appears to be a wd software issue.  my wireless keyboard/mouse (logitech) are connected  via a tranceiver plugged into a usb port.

so what do you do if you don’t have an HP printer but an HP computer? i am connected to my passport essential through a NOKIA cable however, might that be the problem? i dont really think it should be.

Have no HP Printers. BUT a HP 8530w laptop.

My solution to solve the problem  :

In Device Manager, Expand “Universal Serial Bus Controllers”

There I disabled all Usb Root Hubs that have any “attached devices” under Power sections.

After that the Update Driver worked.

After that i enabled one after one. And the one who stopped the firmware update

was “HP Integrated Module with Bluetoot2.0 Wireless technology”.

Hope this will help some of you,

Enviroment :

Windows 7 x64

HP 8530W


Tried on my My Book Essential USB 3.0/2.0 External Hard Drive, too. Didn’t work either. =(

Thanks for the additional information Tony.

For those of you who are having problems updating, we archive the previous stand-alone firmware updaters that are model specific.

Please note that WD recommends backing up your data prior to updating your firmware.

My Book Essentials and Passport Essentials (USB 3.0) for Mac -
My Book Essentials and Passport Essentials (USB 3.0) for Windows -
My Book Essentials and Passport Essentials (USB 2.0) for Mac -
My Book Essentials and Passport Essentials (USB 2.0) for Windows -

My Passport Studio:

My Book Studio: