New Release - My Net Router Firmware Updates (8/14/12)

WD is happy to announce its release of the My Net Family Router firmware updates for the…

Please feel free to post your experiences here in this thread.

Here is the fix list according to the release notes for the Net Central N900 (The one with built-in HDD)

Resolved Issues:
 Fixed router stopped traffic from the WAN after more than 39 hours
 Fixed parental control not working with Guest Access
 Fixed port forwarded relay issue after firmware install
 Fixed DLNA video playback timeline “Seek/Pause” are not working.
 Fixed accessing SMB share through WDTV Live
 Fixed Parental Controls - device policy take priority over master policy
 Fixed Network Drive password required when storage device set to public

What I was interested in testing was the the SMB share access issue and I am not sure what WD fixed but I still have the same issue that I have reported to the community before in this thread

Bottom-line. The firmware update worked and got upgraded to **Firmware Release 1.04.08 (8/14/2012) **but I do not see any changes that indicate the problem is fixed.

I still have issues in accessing folders from WDTV Live /Live+ Hub and Media Streaming product from WD. 

As stated before the bug manifests itself only  if you have more than 200+ nested sub directories. It displays them as ’ UNTITLED VOLUME’ and the directory structure displayed on WDTV live series is all messed up.

Also, the problem wherein accessing the router from an Android device will not allow you to access lower folders (Sub directories) which is also a SMB server problem on the router. Not that the release notes say anything regarding this fix but I tried it anyway without any luck.

I did not see any fixes in the 5Ghz Radio mentioned in the firmware release notes either But I tested it anyways and the range still is very poor.

All-in-all no useful fixes for me that I can see…

Hope this helps others.

Thanks for reading this post.



5GHZ range issue is important and serious for a top of the line router. Any response from WD technicians will help. Is there any temp fix for this???

I’m curious about the 5 GHz range issue for others.  I’ve been using only 5 GHz because the 2.4 band constantly drops (despite 5 bars).  The router is in the basement and I get 4/5 bars on the second floor - opposite side of the house.  Win7 Network/Sharing shows 180-240 Mbps and we have no problem streaming HD  at that range.  Not sure what’s  different about my unit…other than 2.4 being broken…  :slight_smile:

I’m having some issues trying to upgrade from 1.03.06. When I press “Update Now” it tried to download the new FW then says “The Network may be Disconnected or the Download Speed is Too Slow.” … but everything else seems fine. So I go to WD’s website and DL the FW file manually. I try to upgrade from file it says “Request Entity too large”

am I doing something wrong here?

I haven’t been able to get the firmware to install, it gets to the point where it says that it’s upgrading the firmware and shows a counter, says not to turn anything off but then after reaching 0 seconds the page times out. I left it for ten minutes but it doesn’t come back, the power light on the router just blinks and I have no conectivity to anything. If I power it down and back up it works fine but is still using the old firmware. I tried downloading the zip and loading it that way but it does the same thing. Tried it over the wired lan as well as wireless.

i had the same problem , do a factory default and then it should work

1 Like


I’ll give that a shot.


that did the trick, thanks again!

On a side note the saveing and reloading of the config works like a charm but I notice that when you pick the file to upload it doesn’t show it in the field, it still shows as blank, might just be a browser issue? I think it did the same thing when I picked the bin file to upload for the firmware update. I’m running Opera 12.1

Due to the new firmware releases, this thread is closed.