New Release - My Net Router Firmware Updates (12/20/12)

WD is happy to announce its release of the My Net Family Router firmware updates for the…

Please feel free to post your experiences in this thread.

Any in the works for the N900 Central?

I still have to reset it about once a week or so when it loses wireless and drops all the connections.

I second that request…I am having wireless connection problems daily…


I am too.  Constantly slows down or loses connection.  I have the mynet n900.

What kind of connection problems are you having?

  1. Both wireless networks cannot be seen by wireless clients.
  2. Wireless networks can be seen but cannot connect.
  3. Able to connect to wireless networks but cannot access local devices
  4. Able to connect to wireless networks but cannot access the Internet
  5. Are you wired Ethernet devices able to access the Internet and router’s web interface?

For me, I was having the following:

1 was the most recent issue

2 happened before when I was trying to get the ipads connected to the non-guest network

no for 3

no for 4

yes for 5

Since I have “cloned the mac address” on my laptop, as suggested by tech support, I haven’t lost the connection to the wireless network…however, my in-laws with their two added ipads have left for a few days as well.  They will be back this weekend, so we will see if the problem comes back.  Also, I want to disable the guest network and get my ipad connected to the regular secured network, and will try that in a week or so. 

I am having a problem actually seeing anything (pictures stored on the hard drive 9internal one on the mynet central) with the ipad app.  What is the trick to getting that to work?  I have put in the secure code generated with the laptop onto the ipad, but it still can’t see anything.

I can however see the following path \MYNETN900C\Public\Shared Pictures

with my Windows 8 laptop just fine…so I know the drive is actually working and the pictures are there.


I am hoping there is a firmware update as I have to reset/reboot my router daily. I have almost a dozen cases created addressing persistent issues with the N900 router.  The hardware is an excellent design, now if only it weren’t so buggy. I was a top troubleshooter in automation and associated network issues for GE and another automation company, and have never experienced the amount of issues I have seen in the past 5 days that I have had this in use.

Yeah if I were you I would just  get rid of it and go with a tried and true Cisco and a stand alone wd drive.  I no longer have the luxury of returning it or I would no longer have this junky thing.


I was looking for a good router with unlimited DLNA and QoS, parental control, and more than 4 RJ-45s.  Reviewing the competition like Linksys or Netgear doesn’t make me feel any better.  A lot of claims, but they all seem to fall short.

I have the same issue…The internal storage on my 2TB My Net N900 Central was working fine then, one day (about a week after I bought it), I had to power cycle because I lost network and storage. When it came back up, I could not see any of my media no matter what I did. I could see the unit as a Media Server but could not access any shares even though I could see those as well. There was nothing I could do except start from scratch! I reset to factory defaults and started the configuration process again! Needless to say, I lost all of my data and had to use R-Studio to recover data off old disks…I’m not one to give up so, I managed to get the router to work after repeated attempts of power cycling during the configuration. The WD Smartware Utility states that there is no writable WD partition found even though I’ve formatted about 3 times! My Net View shows the following. The last entry is the back-breaker and it would be nice to know the actual problem!


  • Device Type

  • Wireless Gateway

  • Manufacturer

  • Western Digital Corporation

  • Model

  • MyNetN900C

  • Model Number

  • MyNetN900C

  • Description

  • Dual Band Wireless Router

  • Serial Number


  • Device Home Page

  • http://192.168.X.X

  • Host Name

  • **bleep**

  • Capacity

  • 0.00TB

  • IP

  • 192.168.X.X

  • MAC Address


  • Vendor Name

  • Western Digital Corporation

  • Status

  • Needs Attention Volume is reporting problem.

This router is a good idea but, WD has got tons of work to do in order to make it reliable. I wanted to get rid of my home domain by scaling down to a Media Server/Router configuration however, it does not look like this product will fit the bill for me! I’ll take a trip tomorrow to return it to Best Buy and find an alternative. I’m so tired of manufacturers putting out **bleep** ahead of its time…

If anyone has any revelations please let me know.




I opened a ticket and asked for them to buy this **bleep** back. Bought it because I thought I liked WD, even after my World Book II died and I replaced it with a LiveDuo. Linksys E3000 died after a two year run (exceptional for my router experience), so I thought I would give the N900 a try for the 7 Ethernet ports.

This is a terribly unreliable router to depend on: cannot remote access, loses internet connectivity, picky about whether it streams or not, LOUSY WiFi range in either band, especially compared to a dead 2-year old E3000!

The LiveDuo is not a reliable item either, but it mostly works. Still, WD, other than bare HDDs, is a foul name in my household. What is wrong with this company?

Having been a top troubleshooting automation engineer and having an education in aerospace engineering speciualizing in computer systems, I can usually troubleshoot the worst of problems. I cannot make WD respond to these problems and have a fix. I am getting to the point on considering returning this unit to Staples or having WD but the unit back plus the extended warranty I purchased. I have found turning off QoS does help. Deselecting any option you are definitely not using may help as well. As I have said, I reviewed the competition and haven’t found anyone else that I would consider reliable. It’s sort of like choosing a President when none of the above is NOT an option. I just hope WD can put some good USA engineers to work on this and get this resolved.  No India, China or other foreign input, sorry they just don’t have the troubleshooting skills, but are very happy to assist you.  WD - fix the problems and save your reputation and company.

1 Like

@RocketScience: I share your frustration. Regarding your comments about national origins and technical prowess, though, I thought you’d be interested in this paragraph from a recent column posted on

“Networking technology today comes from chipset manufacturers like Broadcom, Marvell and QCA. And the real product knowledge lies with Taiwanese OEMs and ODMs. The networking companies we all know are mainly marketing and distribution entities, skinning the technology and spinning the marketing messages.”

Now, back to the topic at hand…

My latest update:  Still having issues connecting my new ipad to anything but the guest network on this router.  I can select the usual secured network, the ipad connects, then immediately looses connection to the network and (since i already have the guest one still set up) will fall back to that one and connect to it and seemingly work fine.  I just don’t get it at all.  It is not working properly and as discussed above, the tech support seems lacking.

As a side note, the internal storage on the drive still is not showing up in the router config, yet the share I created to put my 1.5TB of pictures on is still available through windows explorer on my windows 8 laptop,. but with the wd app for the ipad it says nothing is there (because the router doesn’t think there is any internal storage set up).

Can you say total junk?

I have just tonight hooked up another 3tb drive to the usb port on the router so I can offload all of the pictures to that, then I GUESS blow away the drive and try and re-format it so the router will see it??? 

Anyone else have any ideas on this one before I go this route?


OK, so it is getting worse, not better…here is what just happened about 2 hours ago.  The 3tb usb3.0 drive chained off the router was seen just fine.  I know, I know, off to a great start…but wait for it…I decided to do a test copy of a small folder of pics from 2001 (yes I had digital pics back then) I am sure many others out there did as well.  Anyway, that copy seemed to go fine from the internal storage (you know the 2tb that is still not seen by its own router :)).  over to the attached 3tb drive.  So, I decide, great let’s copy a few more years’  worth.  OK, years 2002-1009 totaling about 30,000 pictures, the estimated time to copy is 20 hours.  Swell.  I would have thought it would be faster, but whatever.  Now, all of a sudden after just a few min. I get an error that the folder is no longer accessible…great now what.  It seems as though the router has now dropped all of the connections (both wireless and wired!) Sweet…thanks WD for such a **bleep** product that I can’t even move the pictures off the device to return it.  Now what do I see when I go look at the router a few hors later after total frustration and a cooling off period (watched a few hours of the walking dead) now I feel like shooting the router, but that is beside the point…Now the router is in full fan mode, spinning like a jet engine, the attached WD drive (Yes, I admit I bought a WD drive to attach to it), is just blinking like it lost its marbles as well…

The only option here is to shut off the router.  Turn it back on, and both drives power back up…

Get back on the wireless laptop, (you know because I can now after having to reset the **bleep** WD router again) and low and behold, it has copied one folder from 2007 with about 30MB of pictures in it from the internal drive that it doesn’t think is there, to the externally  attached storage. 

I now go into the router config to see what is going on and guess what…now not only does it not see its own internal drive, but it now doesn’t see the 3tb drive attached to it either…

Now, on the laptop I can no longer see the “Pictures” share with all the 1.5tb of pics I copied to it, but I DO SEE the new drive shared out still with the 2001 pictures in it.

Complete **bleep**.  I am really not sure I want to waste more time on this.

I am not sure what to buy, but WD routers are not it at all.

Super frustrated, and pissed that I will most likely not be able now to get the pics off, even after attaching another 3tb drive to the router.


@ erikkur

I would call tech support for help in your case.

1 Like

Yeah, thanks.  I have already contacted them as stated in previous posts.  They really are of little help.  This router is going back to amazon, if the replacement one I get is just as bad, (without replacing the firmware it comes with because the latest is junk), the second one will also go back and I think I will purchse this instead:±+Dual-Band+Wireless-N+Gigabit+Router+with+4-Port+Ethernet+Switch/6639326.p%3btab=reviews?id=1218768195258&skuId=6639326

RT-N65R from ASUS, seems to get good ratings, doesn’t have a drive built in, but I already now have  a 3tb usb 3.0 drive to attach to it.


@erikkur: I don’t blame you for wanting to try another brand of router. I like the high-end ASUS routers, but, while no router has been as fast as the ASUS Black Knight that I tried, for me it was plagued with disconnects. Most people report really good results with ASUS routers, though.

My experience with routers over the past few years is that no piece of computer hardware is more sensitive to a particular installation environment than a wireless router. I don’t know much about the technical side of things, but it appears that wifi transmission and reception are affected by all kinds of variables. In my case, I suspect the aluminum siding on my house – the signal has to pass over a deck through two outside walls to get back into the house and reach the room where our TV is – and also maybe a kitchen appliance or two. As far as I know, there might be a problem from masses of electrical wiring, old landline phone wiring or kitchen plumbing hidden behind walls.

The upshot, as best I can tell, is that a router that works great in your place may bog down in mine, and vice versa. I’ve been through numerous generations of wifi routers, and with each upgrade I tried as many different routers as I could get my hands on, exploiting the generous return policies of online merchants and big box stores. I found that the router which would work best in my setting was never the router that was most highly rated in the online reviews, nor necessarily the most expensive one.

For what it’s worth, I’ve had very, very good results with Amped Wireless routers and and still fall back on my old Amped Wireless wifi router when I need to use a backup. It’s been solid as a rock for me. Other people have reported differently, though. My next router will probably be an Amped Wireless. Their tech support is outstanding, by the way. When I had a question about a firmware upgrade once, I left a phone message with Amped Wireless and got a callback immediately. The agent even called again a couple of days later to make sure things were still working. Maybe because of their immense size, WD doesn’t seem to be able to manage that kind of service.

I just got a call frfom a L2 tech support rep in California.  I guess that my cries were heard and WD does care.  They are sending me a replacement router as I have a myriad of weird issues that should nou be happening.  Despite several attempts at a f/w update, the router just was misbehaving.  Time will tell, but now that I know WD is willing to work with me, I am more than willing to work through these problems for everyones sake.

1 Like

The cooling fan never spins, regardless how hot the router gets. There should be a setting that would allow the user to have the fan turned on at all times.