New Release - My Cloud Firmware Versions 2.31.174 (3/26/19) - Discussion & issues

Does someone notice this:

It was released in the quite again.
Feel free to discuss positives and nagatives.

When checking for firmware, auto update cannot connect to the server (my Internet connection working fine), and when I download the file manual update gets stuck on 0%, then logs out.

Rebooted several times with same result.

EX2 Ultra currently 2.30.165 trying to update to 2.31.174

Any advice?


strange, that all the last updates are only for manual updating, while update search from the Dashboard never find new version. … for what a strange reason? @WD_Admin

I don’t mind so much auto update doesn’t work - I can’t even apply the update by manual process as it fails to start. Nothing in the logs, just sits at 0% until UI times out (I’ve extended that out to 30mins to see if that had an effect)

it was just a notice of mine to the WD Staff

I dont understand why people dont post their issues with the last update 2.31.174 here. I was thinking there are no issues so far :face_with_raised_eyebrow:

I don’t know if the issue is related, but since I updated the firmware I have had a problem accessing My Cloud. Every day since the update, I have to update the security certificate and nevertheless the site is considered not secure by Chrome. It never happened before.

I have reported the issue to WD but still have had no response.

I’m also experiencing issues since this firmware update. After some minutes I cannot access the device anymore. After a reset I get access to the dashboard for some minutes but it is very slow. I tried setting a static IP and disabled standby modes but still the same issues. Also the status LED after the reset initially blinks blue but after some time it just goes off (the network LEDs are still blinking).
I will try to do a downgrade to the former firmware and see if that helps.
In the meanwhile, does someone have any other tips or ideas?

Please report here if the downgrade helps the use the device properly again

unfortunately same thing happen to me WD Support referred me to 3rd party company to try to recover data didn’t offer any solution to a problem the new framework created and as i read more i can see alot of people having the same issue like what was written here…
“I went away for a few days at the end of March. When I came back, the WD Mycloud was unresponsive and had a fast blinking blue light. I tried the 4 and 40 second reboot, changed the network cable, tried waiting half an hour before rebooting and had no luck. Now I’ve learned that a new firmware update was released. It has been running its supposed ‘disk check’ for well over 48 hours now. Clearly this is not working. It’s just a 2 TB unit, about 2/3rds full. Long story short: WD’s firmware upda…”
needless to say the cloud contain a valuable data for business so when the support guy tell you you should have backup hardisk for the mycloud 8tb disk it is disappointing, wd support offer me a discount on my next purchase but i dont need new one i need only to get this one fixes since i now it isn’t damage only the framework error… if anybody fond a solution it would be most appreciated

I think this should be the solution:

have you try this? Or it does not work for you?

eiddum, you are not alone. I too have encountered this issue. I have two EX2 Ultras (8TB and 20TB). The 8TB has updated with no issue while the 20TB has the same issue that you have raised. Based on other member comments and the fact that my 20TB NAS is stable on release 2.31.149, I have decided to turn off auto update on this and monitor progress on the 8TB.

I wanted to share my experience upgrading to the 2.31.174 firmware on my new MyCloud Pro 4100. I got it as a gift a few days ago. It had 2.31.149 onboard. I have a Linksys gigabit router and a 27" 2015 iMac running Mojave 10.14.4. I spent 4 days setting up the MyCloud on my network (no custom apps or OS mods) before wanting to tackle the firmware (I turned Auto Update off).

TL;DR: It works. Be patient and don’t overreact.

The upgrade install process is flakey. On the dashboard, the Settings: Firmware Update: Available Updates: Check for Updates button often just freezes and reports the server can’t be reached. It worked this morning. When it wasn’t working last night, I downloaded the .bin file from the WD servers and tried using Update from File. The file transferred to the NAS fine. Then the Upgrading… progress bar appeared, changed from 0% to just % and stayed there until the interface timed out. No upgrade. I tried again this morning when the Check for Updates button worked and again Upgrading changed from 0% to % and hung. I tried it a third time and surprise! it progressed to 100% and the NAS rebooted. Persistence.

I let the reboot complete and all drive activity settle before trying anything.

Firstly, I couldn’t reach the NAS’ web interface. Turned out it was using a default IP address. I pulled the network cable, counted to ten, and plugged it back in. Ding! Web interface was back. Well, for a while. After about 5 minutes the NAS stopped responding to the browser.

Second, the NAS behaved strangely from the Finder window. It disappeared from the device list. It appeared under the list of network devices but when I opened it (as guest) it revealed all 9 of the shares I had created earlier disregarding view permissions. A guest should only see 2 of the shares and I could see all 9 listed. I was blocked from actually opening any of the shares without “guest” permission but just seeing them was a security worry. [EDIT: Later, in Windows, I saw this is normal SMB behavior; still don’t like it]

Third, when I mounted the public shares in the Finder they did so using smb. This was weird because for days before, everything mounted using afp. That leads to…

Fourth, the afp share icons mounted on my iMac desktop STILL WORKED after installing the firmware and rebooting the NAS. I could only mount new smb shares but my existing afp links still worked. I read and wrote files to the afp shares to be sure I was’t looking at a cache. I could not however access the afp shares using GoodReader on my iPad although that worked the night before. The MyCloud app also gave errors. :thinking:

I had already read this thread and was worried the firmware broke my device too. I was thinking about what to do (pull the plug, call WD, revert to 2.32.163, …) when the background browser window I’d forgotten about sprung to life with the NAS login screen. Also the PC-shaped WDMYCLOUDPR4100 icon in my Network window changed to a Mac-shaped “WD MyCloud PR4100” icon. :grinning: I dismounted all the WD shares from my Desktop/Finder. They remounted as afp shares and the “guest” ability to see unauthorized shares was gone. My iPad could now connect perfectly. The NAS was fully restored.

While it took less than 5 minutes to upgrade the firmware and reboot the NAS, it really took close to 45 minutes for the entire system to be stable again. Be patient and don’t overreact.


In my case for new firmware 2.31.174 update , all you need keep setting in firmware update for auto , internet ip set to STATIC , that all
And wait , it should update firmware , reboot and settle all drives and passwords by self . Remember set the IP ADDRESS TO STATIC . this what happen. To many one have a problems after updated . Cheers

After i got the update to my MyCloud Mirror, my WD TV live hub is just restarting all the time.
If i remove the internet from my WD TV live hub, it don’t restart. But as soon as it gets internet and it connect to the MyCloud Mirror, it starts restarting.

It worked just fine, before the update…

Can you please fix this, or tell me how to fix it?

I did try to reset both my WD TV live hub and MyCloud Mirror, and testing them both for fails but didnt help.

This is not the MyCloud Mirror forum, please ask in the right one.

In the latest update, my dashboard, is so slow, that it doesn’t load…
It loaded once on my phone, and after a refresh, it get’s stuck on “loading to long, do you want to exit this page”…

For me, no problem with the update as I have static ip. The issue now is my remote backup is not working. When I am reconfiguring the the remote backup, its just waiting upon clicking the destination folder. and this was working with the previous firmware.

which update version do you mean? 2.31.174 or the newer one .183 released a few days ago?

All of them.
My dashboard is simply REALLY slow.
Nothing works.
I sometimes can get it showing on my phone.
But if i refresh the page, it’s gone.