New Release - My Cloud Firmware Versions 2.31.163 (1/8/19)

#24

Cool idea! Will keep this in mind, if I run into a similar situation.

#25

Well well well…I just updated the firmware on my EX2100, same error and the kicker is this: The disk status shows the exact same measurements on the disk threshold values for the SMART data… I still think this firmware has a bug in it.

1 Raw_Read_Error_Rate 200 200 51
3 Spin_Up_Time 200 198 21
4 Start_Stop_Count 98 98 0
5 Reallocated_Sector_Ct 200 200 140

This is exactly the same data on my DL4100, which threw an error after the update. Too strange not to doubt it.

#26

There is an ongoing problem with the MyCloud OS firmware and it involves UPnP.

I’ve just had to reboot the router. MyCloud services and Transmission are set-up and I’ve had to reboot the router. Transmission re-established it’s UPnP port mapping on its own after the router was restarted, but the My Cloud OS in the DL NAS has not.

Router says:

DL says (after about 10 minutes of the router being restarted.)
image
… and…
image
… showing that the HTTP port map is OK, but it’s not. The router is NOT forwarding the port and the Firmware in the DL NAS is not noticing that the router is forgotten the UPnP port mapping. If Transmission can notice this (it’s operating on the DL NAS) and the MyCloud OS3 can not then what’s wrong, what’s the bug? Now can this be fixed where MyCloud OS3 can monitor the router and if it’s noticed that the UPnP port mapping on the router is lost, for the MyCloud OS3 firmware to continue to re-establish the needed port mapping?

Clearly the status of OK is not correct. The work-around is to re-visit each network port mapping on the DL NAS and click on save where it seems the DL NAS then sends the necessary UPnP data to the router to re-establish the correct port mapping.

For the record, on the Sky Internet supplied broadband router the firmware does not allow setting up manual port forwarding where the internal and external ports are different. This can only be done by a device on the LAN side of the network that can send to the router the necessary port forwarding configuration.

If someone suggests to get another cable router and set-up the other router to be on the DMZ on the Internet Service provider’s router then my reply to that is that a double NAT configuration it not really a very ideal situation.

#27

It installed fine, but there is a bug. Tried to change a share from no access to read only for a user while viewing the user’s record on the DL4100 and getting the following error appear.

image

I also found by accident that there was a new firmware release this year as the pinned post was edited, but I didn’t get any e-mail notification that there is a change. Also, how come, again, it’s a manual download?

#28

@Myron Please PM me your My Cloud system logs and steps to duplicate the error message.

#29

I have PMed you, but I can’t see any way of attaching the log file to the PM. Also the share permission does not changed to Read-only. It’s stuck on the no access setting. All I try and do is set the share’s permission from “No Access” to “Read-only”.

Problem seems to be confined to the “Anti-Virus Essentials” share that’s used by the Anti-Virus app. On the dashboard I’m signed on using admin user.

#30

Log files sent to you as requested.

#31

Will this become an automatic upgrade in the future? I assume it isn’t at present due to still being bug-tested?

#32

That is a really good question. :slight_smile:

For me it’s so far it’s working fine in general. Just a pain when the ISP resets the router or changes the public IP address on the router. @SBrown, any chance you can communicate this to the team(s) responsible for NAS firmware maintenance?