New Release - My Cloud Firmware Versions 2.31.149 (10/19/18)


#1

WD is happy to announce the release of My Cloud Firmware 2.31.149 for manual download at https://support.wdc.com for the following My Cloud products.

· My Cloud
· My Cloud Mirror Gen2
· My Cloud EX2 Ultra
· My Cloud EX2100
· My Cloud EX4100
· My Cloud DL2100
· My Cloud DL4100
· My Cloud PR2100
· My Cloud PR4100

What’s new?

Security Fixes

• Resolved multiple command injection vulnerabilities including CVE-2016-10108 and CVE 2016-10107.
• Resolved multiple cross site request forgery (CSRF) vulnerabilities.
• Resolved a Linux kernel Dirty Cow vulnerability (CVE-2016-5195).
• Resolved multiple denial-of-service vulnerabilities.
• Improved security by disabling SSH shadow information.
• Resolved a buffer overflow issue that could lead to unauthenticated access.
• Resolved a click-jacking vulnerability in the web interface.
• Resolved multiple security issues in the Webfile viewer on-device app.
• Improved the security of volume mount options.
• Resolved multiple security issues in the EULA onboarding flow.
• Resolved leakage of debug messages in the web interface.
• Improved credential handling for the remote MyCloud-to-MyCloud backup feature.
• Improved credential handling for upload-logs-to-support option.

Components Updated

• Apache -v2.4.34
• PHP -v5.4.45
• OpenSSH -v7.5p1
• OpenSSL -v1.0.1u
• libupnp -v1.6.25 (CVE-2012-5958)
• jQuery -v3.3.1 (CVE-2010-5312)

Other Bug Fixes

• Resolved high CPU utilization with ufraw-batch process.
• Improved remote host port handling


#2

#4

It all installed fine, There are vulnerabilities dating back to 2010, 2012 and 2016 in this update and I have the question in my mind; “What other reported vulnerabilities are stil there to be fixed?” . Happy to see some of the core components like PHP and Apache being updated. Just curious why just for manual update?


#6

Unfortunately the update has not fixed this particular issue.

image

Every time the NAS is restarted the Media Scan soon stops. This was occurring with the previous firmware.


#7

It’s still working, but something that I don’t really need is not working and that’s the option to allow the NAS to hibernate and wake-up on a schedule. The scheduler will turn off the DL4100, but it will not power-up at the designated wake-up time.

It’s this feature I’m on about …


#8

@Myron are you sating the power schedule is no longer working after you updated to firmware 2.31.149 ?


#9

It has never worked at any firmware revision. It will shut down but does not wake up


#10

@SBrown as @Gramps stated, it’s never worked. It would have been useful to hibernate the NAS during the night when it will not get used.


#11

I wonder how many NAS owners have installed this update since it was released? (Just curious.)


#12

E-mail notifications do not work. I have configured it correctly as I can get the NAS to send a test e-mail. Something that needs fixing.


#13

This shutdown/startup feature has worked for me. I hear it shutdown at 10 PM and when I come home from work it is powered up just as I set it to do so. I will upgrade to the new firmware tonight and see if it still works for me.


#14

curious
I do off at say 10pm and on at 7am
does not wake up


#15

I don’t know why mine works. I do have mine plugged into a UPS via the USB port if that has any effect.