New Release - My Book Studio Firmware update for Mac (5/20/10)


#1

WD is happy to announce it’s My Book Studio firmware release for Mac computers.


#2

Hello!

I’m very disappointed, that this update tool is not working! I tryed it with USB and with FireWire 800. The Terminal gives me this message: “Studio IV Firmware Updater[938] *** -[NSURL initFileURLWithPath:]: nil string parameter”.

I hope that this problem will get fixed soon, cause I wasted too much time on this and now I’m really mad!

Regards…


#3

Hello ThePlayaBHS,

FYI:

Make sure to remove the password protection from the drive before do the firmware update.

Use the USB connection only to update the firmware.

If you could provide which WD Studio external drive you have?

WD Studio, WD Studio 2 etc…

Which version of the WD drive firmware?

Which Mac Operating System you are running?


#4

This firmware has bricked my drive. 

The only thing I can see that might have caused this is that I did not remove the password from the drive before doing the update. Now my drive, and several other peoples will not connect back up to the Mac.

 If this is the problem then the instructions were not clear enough about it. I read then as meaning that you had to have connected and entered the password. Not that it had to be removed.

Please help, can the drive be fixed ???


#5

@thanarath:

I surely unlocked the drive and connected it via USB, like the instruction sais. But after this did not work at all I disabled the password protection of the drive.

I have Mac OS X Snow Leopard (v 10.6.3) running and I did just buy the drive like a couple of weeks ago. So it should be a really new model of the My Book Studio version, with the firmware v1.0.0.9 and 1 TB capacity. Its the one with the display and with a Fire Wire 800 and USB 2.0 interface. Hope that helps!


#6

I updated 4 My Book Studio (2TB each) and 1 My Passport Studio (500GB) using the last firmware and SmartWare updates, with success, in both PC and Mac. The only issue I had is that 2 of the My Book Studio in PC was keeping saying drive was busy (probably some software in my PC trying to read/write on them), but when I plugged them to my Mac updated successfully. The other 2 drives were updated on in PC (with success) and the other one directly in Mac.

It’s important to mention that this is not supposed to delete the Virtual CD, but to hide it. I successfully got all of them hidden using WD SmartWare (“not that smart”).

It was a late solution, but better than never.


#7

This firmware update also bricked my Western Digital MyBook for Mac. Serious problems here.

I bought mine 4 weeks go, no password protect at time of firmware update to WDEssential_and_Elite_FirmwareUpdater_v1.0.0.16(2.003) .

The drive spins up but I note the indicator light on the front does not show level of usage anymore just the single led dot at the bottom.

This is my first Western Digital drive and I really hope the moderator here can instill confidence in me by giving me a strategy to have this resolved.

Does anyone have locations of old firmeware to try and step out of this?


#8

I don’t know if it’s going to be possible to un-brick the bricked.

Looking at the drive through the system info on my system, all it shows is 

Vendor-Specific Device:

  Product ID: 0x1617

  Vendor ID: 0x13fd  (Initio Corporation)

  Version: 1.00

  Speed: Up to 480 Mb/sec

  Location ID: 0xfa200000

  Current Available (mA): 500

  Current Required (mA): Unknown (Device has not been configured)

Where as my other usb portable drive shows all the drive info. It looks like the firmware has screwed up royally.



#9

Hello Everyone,

This My Book Studio Firmware updater for Mac is for My Passport Studio and My Book studio.

*****It is silver looking case with both USB and Firewire connections only*****

Please carefully follow the instruction as it will lead you.

Use the USB connection only during the firmware updating.

Disable or remove security or password protection before doing the firmware update. 

Be sure to wait for the firmware updater to finish.

Restart the computer and power cycle the WD My Passport  Studio or My Book Studio drive after firmware update is finish.

If you have WD external drive with black case you do not want to use this firmware or it might brick your drive.

I updated my My Book Studio 2TB  firmware 1.009 to 10.12 from this link shown above and it went fine:

Product ID: 0x1112

Vendor ID:  0x1058

Version:       10.12


#10

AIUI the USB-SATA bridge chip has an internal PID/VID, in this case 0x13fd and 0x1617. FWIW, I suspect the chip may be an INIC-1617, assuming such a device exists.

These bridge chips will report their generic ID in the absence of an external EEPROM chip, usually an 8-pin serial type. Otherwise, when the EEPROM is present, the device will identify itself using the OEM’s PID and VID.

I suspect that the EEPROM data were corrupted during the firmware update, in which case the checksum would be invalid.

Some (all?) bridge chips have a manufacturing mode which can be invoked by means of a jumper. In this mode, the firmware can be downloaded. Of course that doesn’t help the end user. :frowning:


#11

So no word from Western Digital on several of the comments made in this forum (including my own).

This is a bit of a joke.

I am also interested in the comments of the Trusted Advisor below my original post. I appreciate your careful words about certain firmware being for certain devices. This is a fair comment if I just went to Western Digital’s website & tried to load a firmware however I only upgraded my firmware due to the bloody software continually annoying me on boot up and saying hay there is new firmware … install it.

For the past 20 years I am barely ever installed firmware updates as I know their impact however I assumed as the management software which had to be installed knew the device at its end that it would only notify me of an install requirement & then actually undertake it if it was the appropriate device.

Again this is my first use of a Western Digital product and it looks like it will be my last. On that slight chance someone from WD is reading this. Appreciate you have not responded. I will vote with my next money and not return… and with the risk of sounding like an ■■■■■ - I am an influencer in the tech market and will take pleasure in spreading the word about your pathetic firmware lifecycle management & execution…


#12

I am experiencing the exact same behaviour here. I too have the 1TB Studio Drive with firewire 800 and usb. I unlocked the drive, connected it via usb. But still it won’t work. I will wait a couple of days for another update and if this won’t happen i will send the drive back and buy another one from antother manufacturer. Pity as i used to buy plenty of the ordinary wd drives (elements and others) and was quite satisfied so far. But i guess there’s enough competition. As i am a multiplier for purchasing decisions of my friends and colleagues i guess this will be worth a few thousand bucks per year :) 

I am not willing to pay an extra fee just to be left with non-working software and a lousy Smartware app. I am a Mac Developer myself and just don’t get it how such a lame error can be actually distributed to customers.


#13

Thank You 

 I have a 500 gig my book that I bought about a year and a half ago and it has  just stopped showing up. This is the 2nd one that seems to have died on me . Is there a data recovery place or should I send it back to WD for that?


#14

 this update under OS X 10.6.4 + My Passport Essential SE 750GB worked perfectly for me. No problems whatsoever.

edit: and i probably shouldn’t have posted this here since my drive is a different model (and maybe diff updater as well…) 


#15

gustune wrote:

Thank You 

 I have a 500 gig my book that I bought about a year and a half ago and it has  just stopped showing up. This is the 2nd one that seems to have died on me . Is there a data recovery place or should I send it back to WD for that?

 

You would need to send the drive to a data recovery company.  If the drive is still under warranty, you will need to send it to one of our data recovery partners to maintain the warranty on the drive.  We do not do in house data recovery.


#16

WD warranty is **bleep**… My drive is bricked and they wont do anything about it… I will NEVER update hell never buy another WD product as long as I am an IT Manager… 


#17

I wish I would have visited this forum before updating the firmware on two WD External drives, both of which are now bricked. Looks like this has been going on for months now and I cannot believe that WD has not pulled the half **bleep** firmware that they released. Their Customer Service acts as if this is the first time they ever heard of this situation and that I did something wrong. Luckily I do not trust anyone and backed up my data on other manufacturers drives before installing the firmware. I too will vote with my wallet and will never buy WD again and will influence as many others as I can to not buy their ■■■■.


#18

I updated the firmware also, and now it wont read on my mac either. I followed all the step listed on the site. this is redicuious!