New Release - Firmware Version 3.09.18 for WD TV Live Hub (1/24/13)

Just my Experience…

Updated to Firmware 3.09.18 … No Problems with HDMI (Picture and Sound OK)

The XML files content has changed - NO & tags. I would edit the XML file to adjust the Cover Art to a tag that was the right language or to insert tags to add Cover Art (pointing to my own server) for those TV Shows and Movies that did not have them.

Did notice that the new XML files have Carrage Returns at the end of tag sets - thanks.

I have developed a Web Based Application using PHP that parses the XML files and display a Nice formatted

output that can be saved as html to show the “Inventory” of what is on my Hub without using a TV.

Without the former XML tags this makes any development to parse the data from the XML files useless. I updated my PHP code to use the 's - but these images are wide-screen.

So you don’t know what firmware you are on, but someone has gave you it for Beta testing…beta testing what?

It sounds to me that you need to read the manual, or stop drinking. :slight_smile:

You trying to say WD gave you a Live Hub with a firmware that has never existed, but we are at 3.XXX XXX and you can’t upgrade to test it.

Haha best post I’ve seen on here !

Hello Tony, I am still on 3.00.28 and i used your xml fetcher tool to add all my TV shows and then had to follow up

by using text crawler so the shows would sort correctly as episodes 1 thru 9 didn’t have a leading 0 which placed

the first 9 episodes from all seasons out of order. It took alot of work to sort all my shows and i’m concerned if

i take any updates that they may reverse all the hard work i’ve done.

I have each TV show in it’s own directory and each season for each show in their own subdirectory and i’m just concerned about taking any WD updates as it was WD’s firmware that created all the work that had to go into

the tv shows that are stored on the device. 

Current layout example :

.TVshow.S02E01.backdrop

.TVshow.S02E01.jpg

TVshow.S02E01.mkv

TVshow.S02E01.xml

It’s been awhile since i’ve tinkered with the wd tv live hub and was wondering if you thought an update would have my shows all mixed up and require hours to straighted out… If the update didn’t affect my filenames it may not take hours to correct.

Thanks

David

Are you sure you have the 1TB HUB? The Firmware you’re referring to sounds like an old FW for an older ‘WD TV LIve Plus’ (2nd Gen).

Dutchman23 wrote:
Hi Everyone - I searched and didn’t see an answer to this question so apologies if it’s already been addressed.

I was given a WD TV Live Hub Media Center for beta testing but the program wasn’t all what I was hoping. Is there anyway I can force the latest firmware on the device. I’m stuck running 1.00.03 (i believe) and when i try to install the latest firmware the devies doesn’t show an update is available. I don’t want to throw it away, so I’m hoping there is a way around what appears to be a beta firmware lockdown.

Would very much appreciate anyone’s input.
Thanks,
Devin

http://community.wdc.com/t5/WD-TV-Live-Hub-Firmware/New-Release-Firmware-Version-3-00-28-for-WD-TV-Live-Hub-11-17-11/td-p/295308

opps… sorry

Returning subject line to original.

I have been having issues all day long trying to upgrade to the latest firmware. This is the first time Ive ever had issues updating before.

Multiple times I have attempted to upgrade via the network connection and each time recieve the following message:

NEW FIRMWARE DOWNLOAD FAILED DUE TO INCOMPLETE FIRMWARE DOWNLOAD.PLEASE CHECK YOUR NETWORK CONNECTION AND TRY AGAIN.

Firstly, I have no issues with my network connection and tried again multiple times.

I then attempted to upgrade manually which I have also done many times in the past without problems. After downloading the zip file to my USB storage, and then subsequently extracting, I recieved the following error message:

_ G:\wdtvlivehub_3.09.18.zip: CRC failed in wdtvlivehub.bi2. The file is corrupt _

Am wondering if anyone has had a similar issue and can offer some advice so I can get this resolved??!!

It has to be something your side mate.

I updated via the hub last night and all went well, I just manually downloaded it to my PC and it passed with no errors, using the test option via Winrar.

Where can I download the previous firmware version?  This update seems to freeze the video whenever the drive may be in use (as a windows share).  I do not believe this happened on the previous firmware version.  It never freezed before.  I think it may be due to syncing the media way too often.

Here’s the problem I’m having after the update. First thing I notice is the video is not as clear as it was, 2nd) after watching a video file (no matter which one, or which type) I loose audio, period. I push the mute button and it comes back, but why is this happening. I also updated the 2 WDTV Live with no problems at all. Only on the Live Hub. I guess I will roll this firmware back until that is fixed.

If anybody wants to rollback to a previous firmware then visit the page below and follow the instructions. You could try a reset to factory defaults before you do that as there is a possibility that this may cure your problem. To reset go to the setup / system menu.

http://wdc.custhelp.com/app/answers/detail/a_id/5860

1 Like

richUK wrote:
If anybody wants to rollback to a previous firmware then visit the page below and follow the instructions. You could try a reset to factory defaults before you do that as there is a possibility that this may cure your problem. To reset go to the setup / system menu.

http://wdc.custhelp.com/app/answers/detail/a_id/5860

Thanks for the quick reply, that did the trick. Thanks again!   (much easier than a roll back)

The screen on my 42" 1080i Philips plasma TV flashes after upgrading my WD TV Live Hub to firmware version 3.09.18. I was unable to resolve the issue by specifying a compatible HDMI setting, rather than HMDI (Auto), or even resetting my WD TV Live Hub. Rollback to most recent firmware available under KBA # 5860, version 3.07.14, made the screen stop flashing. Hoping that the online upgrade to 3.09.18 might have simply become corrupted, I tried reapplying the upgrade via USB, but the screen flashing returned as soon as the upgrade began, just as during the original online upgrade. For some reason, firmware version 3.08.14, which I had been running most recently, was not available for rollback under KBA # 5860.

" Resolved TV Shows content info is incorrectly sorted" - NOT THE CASE!!

Seriously!! How hard can this be to fix???!!! This has been an ongoing issue for years!

C’mon WD, why cant this once and for all be sorted out??

This was the main fix i was waiting for in this new release!!

the new firmware pulls in incorrect director information for movies.  try rescanning an existing movie and you will see.

Rolled back to 3.06 just now. I watch Netflix 98% of the time and couldn’t stand the sticky subtitles.

80sGuy wrote:

Rolled back to 3.06 just now. I watch Netflix 98% of the time and couldn’t stand the sticky subtitles.

Sticky subtitles?

using the PLAYTO feature of windows 7 where i you can play a media file on windows and have it show up on the TV (via the WDTV)

i now get the at the bottom of the screen a block box with a long white line in it… this is actually the box that shows the

[] ------------------------------------------------------------------------- start/end time

this box remains on the screen… if you stop and trying play again (a few times) it eventually goes away… but will remain on the screen until you do something about it.

also once the program finishes you get this ugly message saying “This is sharing content from Windows”. this message wont go away unless you hit the STOP button on the remote. before it would return back the WDTV screen it was on prior to media being played.

this never happened on the 3.06 firmware.

I’m experiencing the director bug as well – I’m not even sure where the **bleep** it got the director name from because the listed director isn’t listed as being involved in the movie anywhere (not moviedb, not imdb).

After the firmware upgrade, every single video on my hub and attached USB drive are now marked as favorites.

Has anyone else experienced a ridiculous drop in speed when copying files over a network to a USB attached to the hub? Copying 1gb now takes 40 minutes compared to the previous 5-10 minutes. I haven’t checked to see if something occurred with my network around the same time as I updated the firmware… yet.

EDIT: Oh, and the episode sorting HAS been fixed, but only in Media Library view – not when filtering by folders.