New Release - Firmware Version 3.06.14 for WD TV Live Hub (7/26/12)

WD is happy to announce our latest firmware update for the WD TV Live Hub Media Player.

If you experience any issues with this firmware, please report them in the WD TV Live Hub Issue Reporting exchange.

Also, please keep in mind that the What’s New option in Settings still isn’t working in this firmware update.

Feel free to post your questions or experiences in this thread.

7mins to upgrade and … everything still working fine.

Can’t really comment on fixes as either don’t use those features, or never had an issue.

Main thing is upgrade was fine, movies music and pictures are all still working … so good news :slight_smile:

this sounds like a lot of useful fixes, downloading it right now…

Bill is it possible to get some detailed infos about the UI Fixes, has there been general changes / add ons or just funny language gaffes?

Keeping my fingers crossed for this release :slight_smile:

Version 3.06.14:
Resolved Issues:
• Supports .aifc file types.
• Resolved Deezer not available in all supported countries.
• Resolved clear media library does a rescan issue.
• Resolved Netflix does not display in full screen after previewing a video in
• Resolved media library not scanning at set intervals issue.
• Resolved several issues with media library scanning on NAS storage.
• Resolved unable to display .jfi, .jfif, .jif, and some .jpe photo files.
• Resolved FLV CODEC audio sync issue.
• Resolved unable to play ADPMC CODECS with the .WAV or .WAVE containers.
• Resolved playback issues with videos transcoded with Handbrake version 0.9.6.
• Resolved issue OGM playback missing audio or video stream.
• Resolved ID3 tag data not used for get content info in music.
• Resolved Spotify View Biography missing album cover issue.
• Resolved Spotify issue device UI will freeze when browsing artists with 100 or more albums.
• Resolved VUDU issue pressing options during video playback exits to home screen.
• Resolved VUDU issue video playback with composite video output reboots device.
• Resolved German translation issues.
• Resolved YouTube Leanback login credentials not saved after reboot or restarting.
• Resolved several general user interface and translation issues.
General Info:
• Note: YouTube Leanback will require login after firmware upgrade.
• Note: Yota service discontinued operation as of J

DeVicious wrote:

this sounds like a lot of useful fixes, downloading it right now…

Bill is it possible to get some detailed infos about the UI Fixes, has there been general changes / add ons or just funny language gaffes?


Keeping my fingers crossed for this release :slight_smile:

Aside from what Rich just posted, I don’t know.  I will be updating tonight to see for myself.

After the update apparently downloads to 100% I keep getting the message: “New firmware update failed due to network connection error. Please check your network connection and try again.”

Internet and LAN are both working perfectly and as I said, the download reaches 100% before displaying the message. So what gives?

Well I updated the firmware last night and the update went fine

However an hour later while watching an mkv file, I received an invalid format on the screen follow by no signal on my TV screen. Unplugged and reconnected everyting and rebooted multiple time and I am still getting a no signal on my TV screen. The hub is only 2 months old! Should have never update. Hope I can exchange for another one

Dear Srs,

Mts and M2ts files isnt working well.

Netflix Brazil not yet :frowning:

Thank you

Which firmware were you using?

3.05.10 worked well with WD Photo and WD Remote apps on my Samsung Android Galaxy II Epic Touch. Updated to 3.06.14 and lost WD Photo access to WD TV Live Hub.

What exactly happened?

I upgraded to f/w 3.06.14. Checked WD Photo access and received “No photos.” I checked SetUp menu and selected Local Storage, All Photos on my WD 2TB SATA attached to my WD TV Live Hub. Notified “No Photos.”

What you were doing?

Installing the latest firmware from the device connected to internet.

What hardware and media were you using?

WD TV Live Hub Media Center with 1TB disk internal and USB-attached 2TB WD SATA external drive.

Does it happen every time?

Since the latest firmware was installed

Does it happen with previous firmware?

Lost WD Photo app access on Android phone; problem occurred when updating from 2.08.13 (worked) to next version (stopped working).

Does power cycling the unit solve it?

No, it didn’t. Mutliple attempts.

Does resetting to factory defaults solve it?

I do not want to execise this option.

Have you tried this on other devices?


[deleted for privacy]

kennethleon wrote:


Kenneth F. Leon



You do realize that you’re posting your personal info all over the world, right?

1 Like

Thanks Tony.  I wouldn’t have seen that.

Updates just fine here, not that I’m going to notice any changes…

Still holding out for a much better audio player experience.


Through the last few upgrades of firmware(this one included) your Black Mamba theme survived them all…Maybe this wasn’t the right place to post, but I though I’d give ya kudos…

I’m baffled. I downloaded the new firmware while I was at work to my flash drive… eager to install it when I got home. I did this because I cannot get the WD to connect to the internet or my computer. It works. It doesn’t work. It works. Lately not at all. Whatever.

I turn the WD on and to my surprise it already had an IP address! Days ago it had nothing at all… and I couldn’t even get it to work. Now today all of the sudden it works out of nowhere.

The update downloaded and installed just fine.

… and for the first time in a long time YouTube played a video completely without any pauses or lag.

Seems an old bug is back with external HDDs

The hub recognized my external WD 2TB drive but the folder contents are empty. ScanDisk doesn’t find errors, i cleaned the library and let it rebuild again under the new firmware, unplugged the drive several times from USB and power but the folder contents came back up.

The solution is to unplug the Live Hub which takes aproximately 3 minutes and which is a pain in the (you know where)

Reproduced it 7 times today and since I already had this problem a while ago and it disappeared with a firmware upgrade it is save to assume that this is a firmware related bug.

I am officially disappointed.

Good morning.

Does anyone know if the Component Video bug that’s been around since after 3.0.28 has been fixed in this update?  It’s been very frustrating to try each update and see all the new features, only to have to rollback to 3.0.28 when I power cycle and it no longer outputs to the Component Video ports… (Resets itself to composite)

Thank you!


I just noticed something… I don’t know if it’s related to the new firmware or not. You know the blinking light on your ethernet… indicates activity I guess… well, the orange light on my D-LINK USB adapter is blinking a lot more than it usually does. It used to flash once in awhile when the unit was not in use. I get that, but now it’s pretty constant.

In a related/unrelated note the air conditioner in my living room started going crazy. It’s got a remote control sensor on it and last night it kept beeping… Some how the “timer” function kept going on and off. I couldn’t get it to turn off, so I unplugged it. My Girlfriend plugs it in this morning and the first thing it does is start doing the same thing.

They WD and the air conditioner are apart from each other on different sides of the living room, and right now it’s working fine, but I may unplug the wireless on the D-LINK to see if that was an issue.

kennethleon wrote:


Does resetting to factory defaults solve it?

I do not want to execise this option.



Any reason why you don’t want to exercise this option?

After upgrade to F/W 3.06.14, WD Photo app on my Samsung Android smart phone does not see any photos on my WD TV Live Hub.

WD Photo app worked well with F/W v 3.05.10.  Also worked with F/W v 2.08.13. Other F/W upgrades failed with WD Photo.

I have repeated the problem with no photo access after multiple tries, multiple phone reboots, and mulltiple cache clearings of the WD Photo app.

I think I have misunderstood the option. I do not want to reset my Samsung Android to factory default. If the statement refers to the WD Live TV Hub, please tell me where the factory default option resides in Setup. Thank you.