New Release Firmware Release 04.04.02-105 (1/27/2016)

The question would be how does the other My Cloud get mounted to the current My Cloud. Usually to see another device it needs to be mounted. So you could do a “df” command on your My Cloud. That will tell you if it is mounted and under what name.

RAC

To be honest with you rac8006 I am not really sure how My Cloud “B” is mounted to My Cloud “A”. I have setup a “SafePoint” on My Cloud “A” (To My Cloud “B”) using the safepoint wizard, if I may call it that. If I remember correctly, I had the My Cloud “A” search the network and it found My Cloud “B”. Then I completed the setup, gave the safepoint a name and it has worked ever since, it took forever to complete. (Actually that was my second try … the first one was a test to see if it worked).

The caveat is, I only do “Manual” Safepoints and not scheduled safepoints … not sure if that makes any difference.

Minor update on the “the safepoint is in an invalid state, try updating to fix the problem.” error message I was receiving after doing a Safepoint. Did a System Only restore via the Dashboard, and that appears for the moment to have fixed the issue as the error message no longer appears when I did a Safepoint backup to an external USB drive.

And for the moment it appears the My Cloud properly mounted and saw the Safepoint on the USB drive after ejecting it (via the Dashboard) and then reattaching it to the My Cloud.

So for those having trouble, try doing a System Only restore via the Dashboard > Settings > Utilities page to see if it fixes things. Downside is the need to do a Safepoint from scratch when/if the My Cloud cannot find it on the external USB drive.

There should be a new firmware release soon. Once everyone finds out the latest one gives users access to shares they shouldn’t be able to access.

Hi,

any experience with this Firmware and the standyby Modus?
After so many spent hours my WDMyCloud finally went into standby mode after all.
I have updated the Firmware yesterday evening and it seems the disc will not go to standby mode again.
I have disabled all Services, like SSH, MediaServing etc…
any ideas?

I have just been looking into the SafePoint issue this morning and found a way of seeing the old SafePoints and mine are currently updating the original SafePoints without having the recopy the entire drive.

First I turned ON “USB Content Availability” so I could see the USB files on the PC (just to make sure what was still there).
Secondly, I noticed the the Share name for my USB had been duplicated (“Elements” and now “Elements_2”). I could see in the Shares section that Elements (my original backup share was showing 0K) and “Elements_2” was showing all my files. I simply removed the “Elements” Share and renamed “Elements_2” to the original name. Now when I went into SafePoints, my WholeDrive backup was visible once again. I had to re-enable the daily backup schedule and clicked on “Update” and off it went once again.
I do not normally have USB Content Availability turned on (as it’s for backup only) so have disabled that once again.
Hope this helps somebody?

4 Likes

I was wondering how many users have Safepoint working correctly? I have never been able to get it work.

Great news, davies0121. Next time I will try this.

Paul

1 Like

Yeah commented on the USB name change happening above as well. Happens from time to time for some reason. Although I didn’t try deleting one and renaming the other as you did. Hopefully others who experience this strange issue can now solve their Safepoint problem if this works for them.

1 Like

Thanks for the post! I also have a safepoint share created on an external, local USB drive. After the firmware update, my dashboard homepage started showing an extra share which turned out to be the renamed original safe point. On the safepoint page, I had no known safepoint. After reading your post, I went back to the shares page and deleted the original (zero length) share and renamed the new safepoint share (non-zero length, _2 name extension) to original name and reset the share access rights… When I went back to the safepoint page, the old name now showed up as a safe point. I went to Windows explorer and checked the safepoint share content and found all the directories I expected. Double checked the update schedule and when the appointed time came around, the safe point was updated. All that happened without a reboot or system-only restore, just the delete/rename sequence. I greatly appreciate you taking the time to share that technique.

1 Like

I have also duplicated the remove / rename process for the “new” USB share and the previous SafePoint was reemerged intact. I did have to reestablish the update schedule but beyond that, all good. Thanks,.

1 Like

Mine is working fine even after last FW upgrade

Tried your method. I already had USB Content Availability turned on. My old USB drive share wasn’t connected. Double clicking on the share gave an error that it couldn’t connect. So I disconnected that share and made a new one with the same name. My safepoint was still gone. The files are on the drive because now I can access the drive with the new mapping but MyCloud can’t see the safepoint still.

So I’m creating a new safepoint with the old one still there. Named it the same thing as my old one. It’s currently backing up my files for a full safepoint backup so it’s going to take awhile.

Hi:

I tried a number of the series of possible solutions proposed in a different thread regarding the issue of not seeing MyCloud in File Manager (under Network). One worked for about a week and then Windows 10 started behaving erratically, there were unexpected consequences. I have since moved back using the Restore Point. (This is just for context. Thanks to Mordten2004 & Bennor)

My question to you is that you state “This is not related to WD, this issue need to be solved by Microsoft.” In dealing with a number of people at Microsoft, they either do not know of this issue or think it is related to WD’s My Cloud. These people might not be in the loop, hence my questions.

How is WD trying to get Microsoft to resolve the issue?
Any timeline as to when the issue may be resolved?

[Yes you can map shares in file manager but it was cleaner when you did not have to go through that process but just access the drive as though it was a network drive.]

Thoughts?

Sincerely,
Craig.

Even in some Technet forums, this issue can be found and the teams responsible to solve this, are involved.

one of them but maybe the longest one:
http://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_web/windows-10-network-file-sharing/18fba63e-7b6c-46fe-ba23-575a634fcee8?auth=1

Same as with a similar Apple issue, we are engaged here too.
It’s not our problem but as we are affected, we engage.

Thank you for your prompt reply and the information you supplied.

A perusal of the link you shared showed some tangential posts but that link was not found by any searches I did. I realize that knowing the right nomenclature allows you to find the right information but network novices like me are not going to know the right words. Searching for ‘File Manager’, ‘MyCloud’ and ‘not showing in Network section of File Manager’ led to general information that did not address my questions nor indicate any actions. Looking for SMB1 helped but this is not a word I should know and I should not have to learn about networking to have a question answered.

The original question being why can I not see the My Cloud in File Manager after moving to Windows 10?
This leads to your second response which was you/some staff/the company are engaged in a solution. That answer was what I was seeking. A time frame would also help but even I realize that might not be possible to indicate such information. Given your statement, you indicate the problem is with Microsoft, and that may be true, but it is your product I am using. When I can’t find either a solution or an indication that you are searching for a solution, that is what can get frustrating. The WD Community has been helpful and much appreciated but they are not the company, though company staff do respond there.

A clear, “we know there is an issue on [blank] and are working on it” would help a lot. Whether the issue is Western Digital’s or Microsoft’s is irrelevant to me. Your product, you should post something about it. A post with known issues that can be easily found and perused (in common language terms) would also help.

Sincerely,
Craig.

Thanks for your post!
your method works fine also for me. I have deleted 4 empty safe point in the share tab and the real one now is listed in the SF tab.

thanks again.

1 Like

Hi Craig

you will find a lot more about this unpleasant “whatever” (I want to avoid the word Bug as nobody seems to know what causes this), if you search for “network shares not showing up”. This was the criteria I used. As I said prior, this phenomina is not bound to My Cloud devices (only) but causing a lot more “headaches”.

We are aware of this issue but a fix is not within our “field of responsibility”, means we cannot solve it by ourselves. As you can see, even the internet communities are not able to present a quick solution to solve it.

I keep getting the following when I try to update the firmware. Anyone else having issues ?

updateFirmwareFromFile.sh:02/11/16 04:36:32:check_size=
updateFirmwareFromFile.sh:02/11/16 04:36:32:version_current=040400308
updateFirmwareFromFile.sh:02/11/16 04:36:32:version_newfile=040402105
updateFirmwareFromFile.sh:02/11/16 04:36:32:package_newfile=sq
updateFirmwareFromFile.sh:02/11/16 04:36:33:master_package_name=sq
updateFirmwareFromFile.sh:02/11/16 04:36:33:master_package_new=sq
updateFirmwareFromFile.sh:02/11/16 04:36:33:update_container=
updateFirmwareFromFile.sh:02/11/16 04:36:46:new_upgrade_version=2
updateFirmwareFromFile.sh:02/11/16 04:36:46:current_upgrade_version=2
updateFirmwareFromFile.sh:02/11/16 04:36:46:Newer upgrade scripts in update package, use normal update method
(Reading database … 26399 files and directories currently installed.)
Preparing to unpack /CacheVolume/updateFile.deb …
dpkg: symbol lookup error: dpkg: undefined symbol: setexecfilecon
dpkg: error processing archive /CacheVolume/updateFile.deb (–install):
subprocess new pre-installation script returned error exit status 127
Errors were encountered while processing:
/CacheVolume/updateFile.deb

I’ve noticed that since the new firmware, my blue LED is off. I cycled power, got the white LED while it was rebooting, but when it was fully awake, there is no blue LED. I can access it from the OS X WD My Cloud app just fine, the Dashboard app says the diagnosis is “ok”. What gives with the LED?