New Release Firmware Release 04.04.02-105 (1/27/2016)

I have gone ahead and updated my 2TB Cloud with the new firmware. It took only 10 minutes + a few more for it to reboot and … all is well. No issues in the upgrade and after the device completes the (mandatory) scan we’ll have a peek and see whats up.

Paul

Thanks Paul … please keep us posted.

Tried a 40 second (factory restore) to what end? The firmware update worked fine and the safepoint create was progressing nicely. It was only the power failure at our home which cause the safepoint create to fail.My only concern was why there was no partial safepoint after the restart.

Interesting results after the FW update. Once the Cloud rebooted itself, it did not recognize (find) my attached USB Safepoint drive. So, I powered down the USB drive and powered it back up and after a while it appeared in the Dashboard and now I’m waiting for the Safepoint scan to be populated.

More later (hopefully all good news)

Paul

Yes. I still have the problem with the 0K and the USB drive not being mounted with my Toshiba 1T USB 3.0 external USB drive.

Unable to create share
 
A share could not be created on a USB device (vendor: Toshiba, model: External USB 3.0, serial number: 2011111316674, file system: ntfs, label: TOSHIBA_EXT, share name: TOSHIBA_EXT).

Friday, January 29, 2016 11:53:27 AM Code 1122

It appears as if the USB drive is recognized, but the existing Safepoint is not. It reports 0 Kb available.

I’m working on it.

paul

So far, the FW update seems to have messed up the Safepoint process.

I am attempting to see if there is a workaround. The Cloud does not recognize the previous Safepoint and it also reports no space available on the USB drive. Unloading and reloading the USB drive didn’t help. The Safepoint process will not show any existing Safepoints. If you click on [+] to add a new Safepoint, the process seems to get stuck reading the drive for retrieving partitions. I’ve waited 30 minutes (never took this long before) and nothing.

Next, reboot the Cloud.

More later.

paul

Unfortunately, the Safepoint process now seems to be unable to connect to a previously created Safepoint.

From the release notes for 04.04.02-105
 Resolved issue of USB volume with large directory tree causing
inaccessible/unresponsive/sluggish device behavior

I wonder if that fix messed up something else? I am still waiting for all the scans etc. to end before I pull the USB drive and reset it.

Later.

Paul

@ Morden2004
This is what I was afraid of … losing previous created Safepoints, this does not sound good at all. It takes way too long to re-create any Safepoint and the possibility of losing them is nerve racking to say the least. Just give it some time, which might be an understatement, but it once worked for me. I hope it straightens out on its own after the scans.

@ Bennor
This doesn’t sound good either. I have never used a USB drive on either My Cloud. I use my second My Cloud as a safepoint for the first.

To be honest … ever firmware update gives me the shivers!

No go. I tried several tricks and was unable to get the 04-04-02 software to see anything on the USB drive. The data is there and the file structure looks fine. I checked and scanned the drive on my Win 10 system and then I tried again. Still no luck.

So I have temporarily plugged the USB drive into one of my ASUS routers as a Samba share and I’m currently creating a new Safepoint. I’m bummed.

Paul

I don’t normally use Safepoint. But I’ve had that USB issue with that one Toshiba drive and one other generic docking station when it held a 1T drive since the introduction of the OS3 firmware. Other USB hard drives and flash drives (all smaller than 1T) seem to work fine with the OS3 firmware.

It just gets more interesting, but not better.

This is what has happened trying to create a new Setpoint. Starting to worry. :confused:

Paul

It just gets more ugly as we get deeper into it. There is a Safepoint there and I can access from Win10. When I tried to create a new one in Safepoints, the Cloud reported that “you cannot use an previously used name” so now I have to blow away my Safepoint and start from scratch. Fortunately, yesterday I added the WDMyCloud to my mirroring software and I have a backup on the mirror drive.

Ugly.

Paul

@ Morden2004

The name of the Safepoint (.04_02_02_105) was that generated by you or the My Cloud? I know when I lost my safepoint there is no way to force a search for any previous named safepoint and you are forced to create a new one … that $ucks, to be totally honest. I am really starting to doubt if I should update my firmware. I have had many issues with both My Clouds, but every firmware update seems to be a “Try at your own Risk” approach.

@ Bennor

One would assume that the size of the USB drive wouldn’t matter. I certainly can understand the format of the drive would matter … but not the size, especially 1TB. I was really hoping that OS3 would solve a lot of issues.

I selected the name and it was created my the Cloud in Safepoints. The Safepoint did not show up and when I tried to create a new Safepoint ([+]) using the old name, it failed.

It’s a Seagate 1TB external and it’s worked fine as a Safepoint drive for more than a year.

In my case the two drives worked prior to the OS3 firmware. Post OS3 firmware both drives won’t mount properly. We’ve had prior threads discussing this particular issue of certain external USB drives not being properly mounted or accessed by OS3 firmware. I’ve sent logs off to WD support but no word on any possible solution since then (been several months).

One would assume after several months, that this firmware update would have solved/addressed the issue with USB drives. There has always been an issue with WD Support making the customer feel unimportant by not responding when they asked for the information. I’m sorry to hear this Bennor. This kind of behavior, on WD’s part, is really unacceptable.

I’ve noticed on the new firmware that several processes of wdAutoMountAdm.pm are running. One has a parameter of shutdownCleanup The others have a parameter of getDrives. The processes are waiting on a lock owned by the shutdownCleanup process. The cleanup process is waiting to open a pipe.
This is not happening on previous firmware. It would appear on the new firmware that when you
open the dashboard a parent and child process with parameter getDrives is created.

RAC

SectorGZ, there is (I’m sure) a long list of items WD has to fix and that list gets longer each time they release a new firmware version that fixes some previous issues but introduces even more issues to fix. One can see many of those fixes or request to be fixed in the Cloud Ideas subforum. There are potentially many more issues that should be more important for WD to fix, like remote drive mapping (that was removed when the WD2Go.com site was revamed and rebranded MyCloud.com) and fixing the Safepoint problems that many appear to be having. My USB issue doesn’t appear to be wide spread as such its probably way down the list of things they are working on.

I had a safepoint schedule set up, but after the latest firmware update it has disappeared.
It’s by no means the only problem I have.
I think I am one of those Mycloud owners who wants to throw the thing out the window and buy something professional that actually works as it says it will.