New Product - My Book Essential (10/5/10)-a Not Working Product (11/15/2010)

Just tried the new released USB 3.0 My Book. and it seems to be dead, even on a USB 2.0 machine , with another My Book of a USB 2.0 type working currently on the same computer, although the two  were not running together.

I had no WD Smartware recognition, and no computer recognition of the 3.0 My Book even with seven hours invested time.

I have returned the drive, only to find the same attempted installation response on a replacement additional 2.0 My Book obtained in an exchange. Inadequate support led to the exchange impulse.

If the WD installation made some sense,  and support solved technical problems the drive would be my next standard device - possibly four or five of the 2TB ‘USB 3.0’ speed My Book.

Where is the stability and ease of use we should be purchasing?

I have to wonder if we might share the same problem… … But I think my model is not as new as yours. Please post if you find the fix :slight_smile: