New portable 2TB My Passport keeps getting disconnected on USB3 ports

I just got my new 2TB/USB3 My Passport today. I was backing up stuff and everytime it never stays connected long enough to complete my transfer. I am using a Win 7 (64bit) system and i have installed all the drivers and utilities from the website. I even turn off the power management from the Windows Device Manager and yet it still doesn’t work. I tried with 3 Win 7 machines on their USB 3 ports and still no go. SO the last thing i tried was just simply plug it into a USB 2 port and all my transfers went smoothly without any interruptions.

Anyone can shed a little light on this matter? Is it a WIn 7 issue? A USB3 issue? hardware issue?

( i have already tried 2 different USB 3 cables on different machines and still unsuccessful file transfers)

Check if you have the latest USB 3.0 drivers on your computer, also use the USB cable that came with the passport and avoid using USB hubs.

I am not using any hub. I am using the cable that came with the drive. Drivers already updated.

Go into power options and make sure sleep is not enabled for USB.