New PiDrive is only showing 500GB


#21

Thank you so much for the fast and efficient service!  I’m definitely glad I went with WD  :)


#22

WD Support, if you’re reading this, I too have a drive reporting 500.1GB capacity after fdisk. Please help.

VR,

–Mike

Edit: I just saw the Windows fix on the previous page. I will try this ASAP.


#23

My Pi drive was also showing 500 gig. Ran the Capacity Restore listed above and all is well.
On a side note, when I plugged the Pi Drive into the USB of my Win7 desktop, the drive showed up in My Computer as a USB drive with 0 (zero) capacity.
However, when I ran DataLifeGuard Diagnostics (ver. 1.29) for Windows, the drive showed 500gig before the restore and 1000gig after.
Larry


#24

Same problem here. Tried the capacity restore prog (after finding a windows computer – I have Macs)… no go – does not detect drive.


#25

Add me to the Me Too list and start a new list for slow to the game.
The zip file expanded my Drive to 1TB !!


#26

Is the software supposed to work on larger drives? I have a Passport that is really 4 TB but it is showing 2TB. I’ve tried this fix, but it doesn’t recognize the disk as being there. Is there some trick to make this drive the “targeted” drive?

Many thanks,

Bill


#27

I should have mentioned. I’m referring to the “WD Drive Capacity Restore” program.