New Patch release for ShareSpace units on firmware version 2.2.9 affected by slow transfer rate


#25

Hitting ‘preview’ deleted 20 mins of typing and refining! The short of it: -2tb sharespace arrived the other day. Updated to latest firmware. -Replaced drives with four 1.5tbs in raid 5. After 2 attempts and 36hrs the raid was finally going. -Plugged a full 1tb MyBook into front usb port began transferring files ranging from a few kb to several gb each (800gb total). -Got ~3mb transfer speed. -Applied latest patch. -Now getting ~4mb on usb transfer speed. -file transfers of gb files (50gb total) over my 10/100/1000 router is giving me 800kb - 2.5mb transfer speeds!!! This product is not living up to any selling point. Having been exclusively loyal to WD products for 15yrs now, I cannot be more disappointed! No, wait. I can be. In doing my research I could have sworn this had a print server going. Looking at so many products, I must have switched notes somewhere along the line. Assuming the speed issue I’m experiencing is resolved, I cannot encourage the engineers to make this product comparable to others by including a print server in the next firmware upgrade. The further thought that this device will not support the new 3tb and larger drives now coming down the pipe is also a major frustration. WD abandoned the MyBook, hobbling that perfectly functional hardware by limiting it to 500gb drives, will the sharespace suffer the same fate? To think I thought this sharespace would be the backbone of my home office network looks foolish of me. Might I just as well have lit the cash on fire than give it to WD in this case? I’m hoping it’s user-error regarding the speed issue I’ve got going right now. (To those with ~10mb speeds, you have my envy. And to those with proper ~30mb speeds, please send me your sharespace!) And to the product management at WD, you MUST work to bring this device up to par with other NAS devices. It is sorely deficient in it’s lack of printer support and it’s (probable) lack of support for future larger drives. Sincerely, Tom.


#26

Very cool. This post deleted all my above formatting too?!? It was laid out in paragraphs and points. Now it’s one jumble of text. Great.


#27

Speed has dropped to 900kb for the last hour.


#28

It takes ~10 mins for transfers to break 1mb, but then climbs up to ~4.5mb/sec for an hour or so then over several hours drops down to ~1.5mb and then well below 1mb/sec. I haven’t let it go slower than that before just killing the process out of disgust. This is the same whether it’s from a usb port on the sharespace or over my gigabit network.


#29

Isn’t disabling Samba server signing as simple as changing “server signing = auto” to “server signing = no” in the /etc/samba/smb.conf file?


#30

Transfer speeds have been hovering ~700kb/sec since my last post 10+hrs ago.


#31

New patch didn’t help. In corresponding with WD support, I received following answer: “…the WD ShareSpace max transfer speed is 8-11 MB/s on a local network. The drive does not transfer any quicker because that is the maximum throughput that the enclosure’s CPU can handle”.

They have “escalated” this issue to the developers of the WDShareSpace.

Any optimists out there?


#32

Interesting… does that mean that the technical specs might be fundamentally out of whack with what the unit is capable of??

I’m on firmware 2.1.92 at the moment getting transfer speeds of:

~12.25MB/s write

~11.25MB/s read

(measured with 100MB files) and this is through the basic mapped drives in windows (I think this is an SSH connection?) … I know it seems wierd that it would be slower on the read, but apprently this is not unusual.

Anyone care to offer an opinion as to whether I should bite-the-bullet and upgrade to 2.2.9- or just be happy with what I;ve got…I have such little confidence in the WD unit/firmware/update process at the moment that I feel I should be thankful that its working at all!


#33

IMHO, *DO NOT* “upgrade” from 2.1.92!!!  That release provided the best performnace and unless you absolutely need some feature in 2.2.9, I’d stay with 2.1.92 – I wish I had! Having said that, since disabling Samba server signing on firmware 2.2.8, I now see read transfer rates of up to 230 Mbs (mega *bit* per second…) between the NAS and a Windows 7 PC.  That yielded about 14.9 MBs (mega bytes) per second when copying a 3 GB file.  I’m not touching the 2.2.9 release.


#34

Thanks pannetron,

That’s kinda what I suspected from reading other posts, i.e… that the 2.1.92 version was OK and that it probably isn’t worth the risk updating to the 2.2.9 version. 

Its weird that most people who opt for WD products are probably loyal to them because of WDs reputation for being solid and dependable… and yet now

pannetron wrote:

IMHO, *DO NOT* “upgrade” from 2.1.92!!!  That release provided the best performnace and unless you absolutely need some feature in 2.2.9, I’d stay with 2.1.92 – I wish I had! Having said that, since disabling Samba server signing on firmware 2.2.8, I now see read transfer rates of up to 230 Mbs (mega *bit* per second…) between the NAS and a Windows 7 PC.  That yielded about 14.9 MBs (mega bytes) per second when copying a 3 GB file.  I’m not touching the 2.2.9 release.

I’m NOT updating the firmware on one of their products because I would rather settle for mediocre performance…  I never thought I’d be in a position to be second guessing WD OR settling for mediocrity from them…!!


#35

Patch did not help in my case I’m still getting speeds of not even 1 MBps


#36

Upon arrival, my 2tb sharespace was on firmware 1. something. So I had to upgrade. There was no option except that latest that I could find. While my XP box IS getting very solid transfer rates that I would expect, the win7 64bit laptop is averaging under 1mb/sec and gets slower the longer it is transferring. While XP Pro sp3 just hums along real nice. I regret that for other reasons, I have to upgrade my desktop to win764 and lose the expected transfer speeds. That is until someone who knows what’s going on posts a solution here so many people like myself will be happy again.


#37

Good advice which I wish I had followed. If only I had come here and read this before I upgraded. Now I don’t know what I should do. All I know is my sharespace does not perform good enough anymore.


#38

XPsp3 32 bit is giving me 360+mb/min with the latest WDSS driver, but Win764bit is yielding under 30mb/min. But even that 360mb/min is slow compared to what people are posting here.


#39

This has not resolved my problem. The side of the box clearly states “WD ShareSpace outperforms USB 2.0/FIreWire 400”. The marketing on the box clearly indicates I should be able to transfer at > 30MB/S. Even after setting “server signing = no” in “/etc/samba/smb.conf” I still rarely break 12MB/s Apparently WD has admitted that this limitation is due to CPU bottleneck. Perhaps they should escalate to the marketing department too.


#40

 I don’t like being cynical, but the latest answer I got from WD support, is more like an appropriate punch-line for a stand-up comic. And I quote: “The 40 MB/second is achievable in an ideal network setup and is more theoretical”. And realistically, what, if anything, is being done about it ?!


#41

What I have not mentioned before is I happen to own 3 WD NAS devices, 2 MBWE (white light) and the WDSP.  All 3 would stream DVD ISO’s to my media centre, I have two of them a hacked apple TV running XBMC and a hacked Xbox 1 running XBMC.

My network is  Gigabit using Cat5e cables and a ProSafe 8 port Gigabit switch.  Up until the firmware update on the ShareSpace all worked the same - i.e. all would stream all of my content perfect, sometimes to many devices all at the same time.  After the firmware update my ShareSpace can’t stream a single DVD ISO to just one Media Centre now without buffering and stuttering.

My MBWE (whitelight) remain un affected and so I conclude that its not any of my equipment at fault and IS defiantly the new firmware.  The thing is what is WD doing about it ???  I get the impression that they think its sorted with the new firmware patch they released, but as we keep saying this is not the case.

I have tried everything to fix it, except a full restore to factory settings because this is a ridiculous suggestion - no-one can back up 5 TB of data without another NAS of this size and if I had one I would simply use that one instead and sent them my old one back !!!

I would like to go back to my original firmware of 2.1.92 as this worked for me.  I don’t understand the problem of going back to an older firmware, this is my device, I paid for it, its only a large hard drive, Its not like a phone nor is it tied to a contract - so WHY ???


#42

If  not being able to go back is the big issue why the hell don’t you just release the “old” firmware as a “new” update and this fix the issues with this piece of ■■■■…I swear these people are clueless!!


#43

“The 40 MB/second is achievable in an ideal network setup and is more theoretical”

Between two machines connected to the same switch I’m able to easily break 45 MB/s. Blaming my network simply convinces me that WD doesn’t care about the customers it has falsely advertised to.

The marketing material for this product still states “Provides data transfer rates up to 1000 Mb/s when used in a GigE network. Gigabit networking and transfer rates are five to six times faster than other network storage systems. This performance is comparable to USB 2.0 direct-attached storage. Tests based on comparison between a 1 TB dual-drive system using 7200 RPM drives and a 1 TB dual-drive system using WD’s GreenPower drives.”

WD, could you please share with us the results of this test you are claiming to have run? I find it hard to believe that a 200mhz risc processor ever performed that well.


#44

Hi,

So like alot of guys here I’m convinced that the biggest factor contributing to the poor data transfer issues that so many are experiencing is *NOT* down to anyone’s setup; their network configuration or other individual circumstance, but is *ACTUALLY* an issue with the firmware.

The fluctuations in transfer speeds that have been widley reported between the firmware versions confirms this (and the issue of the patch to “correct” the 2.2.9 version would support this assumption too).  Trying to side step this issue is really not playing ball. You must know that you’ve gaffed somewhere along the line, if you don’t recognise this then it serious calls into question your basic competance. Debating this further is a waste of time.  The firmware/unit is at fault.

So, as a paying customer, and a UK resident, I have legal recourse to Trades Descriptions legislation to challenge a manufacturer who is mis-selling their product.  I haven’t read of ANYONE getting the claimed transfer speeds in any tests they’ve made, and WD have been quoted as saying t hat the transfer speeds are more ‘theoretical’ than factual, despite the fact that the markettng blurb suggests that this “theoretical” figure is backed up with a practical test. The fact that WD refuses to allow older firmware, which seemed to perform better, to be reinstated suggests that the solutions lie well within their reasonable means to implement.

So  - could we have a straight forwards answer to the question of what exactly what WD proposes to do to rectify the apparent mis-selling of their product, and to show a willingness to face up to the performace shortfall?

Suggestions I could make would be:

  • Issue an apology for the mis-leading marketing
  • Retract the misleading marketing on future units
  • Make downgrading of firmware  possible (or at lest re-release older versionas) to give users the choice to try different configurations and get the best transfer speed they can without risking a journey of no return
  • The most obvious suggestion might be to start from scratch with the firmware and build it around the idea that additional fuctionality is only interesting once the basics are working properly.

I find it shocking that a commercial organisation with WD reputation would risk so much bad feelings by the kind of users that, by their early-adopter nature, are probably more techically minded than most, and would potentially be opinion influencers for substatial portions of WD’s business.

Given the commerical risks, WD should recognise this as a much bigger issue, and the team in charge of this product/problem should be given more resources to fix this QUICKLY, and PLEASE give us more information about the progress/status!!

Feudal