New MyCloud user - help needed


I recently bought a 2TB MyCloud device, and instead of the “plug&play” experience, all I got is a mild headache :slight_smile:

I browsed the community and I’m not sure which post is the answer to my issue.

  • I started with the basic setup of the device and turned off DHCP.

  • Next I created a folder named “My Movies” and shared it.

  • Then the first issue appeared - for testing purposes I copied an 800MB .avi file to “My Movies” folder - and it took more than 10 minutes to finish - and this was a huge letdown

  • After the file finished copying, i browsed the MyCloud\My Movies using my Toshiba Regza Smart TV, tried to play it - Error! - “Unsupported file”

  • OK, now I thought that the file was corrupted so i detached my USB HDD from the TV and pluged it in the USB port on the MyCloud - next I navigated to the MyCloud\My Attached HDD\Movies and got the list of all my videos that normally played on my TV via the standar USB HDD and USB stick  - I tried to play the movie - same error - “Unsupported file”

Anyone has an idea how to work this out? Did I miss something during the setup? I would like the MyCloud to act as a simple network drive…

Next i tried the Twonky server and that’s a no go also… Starts the stream but nothing happens…

I would really appreciate some guidance from more experienced users. 

Thanks guys



I recommend you contact support in order to get assistance with this.

Contact WD