New MyCloud is showing up under Storage

When I originally installed the MyCloud device today I was able to see the Mycloud device under Network in Windows 7 Explorer. However, after using the device for about an hour and changing several settings, the device is no longer listed with the other network computers on my system. However, when I scroll down the right side of the Network devices, I see an option called Storage and the Mycloud device is listed in that section and I can access it.

Is this the normal behaviour for this device?

You said you made changes, what kind of changes?

When I click on Start>Network I see the followiing, see image below.

WD My Cloud shows under Network on the left and on the right it shows as a computer, Media Device and Storage.

I updated the firmware to the latest version I also changed the device to a static IP. I used the same IP that was given to the device using DHCP, but changed it to a static IP.  I turned off Drive Sleep and MAC Backups as I’m on a PC. I turned FTP access on and changed WORKGROUP to MYWORKGROUP. I also turned on email alerts for Critical and Warning.

So that is the extent of the changes. I have not added any users other than myself. I have turned OFF Public Access for my user name and have given Full Access to myself.

Is there something above that would turn off the Drive showing up with the rest of my computers on the network?

What is the name of the workgroup for the rest of your computers?


The following was copied from the User Manual.

Workgroup (Windows)

A workgroup is a name you assign to each member of a group of computer network devices in a network environment. The devices that have the same workgroup name can easily exchange information through the network. A workgroup does not require a central server. To name or rename a workgroup: 1. Enter a name for the workgroup (no spaces allowed). 2. Click Save. 3. Each time you add a device to your network, you can assign it this workgroup name.


Change the name back to WORKGROUP and see what happens.


This morning the Mycloud device showed up with the rest of the computers on the network as I expected. I did not make any changes to my configuration. So it appears everything is working, except that I am getting an error message in Cloud Access. The error message is “Port forwarding failed to connect on port 80 and port 443”.

I will open up a different thread to address this issue.