New My Passport Wont't start backup and i can't acces backup scheme

Hi I just installed my new passport with all the apps.

If i acces WD BACKUP i choose the wd passport and then i can choose 2 options make a backup scheme or give up a backup destination. If i press on of these 2, the app just closes.

In the lower bottom i also can choose to start te backup. If i press this, the app closes again… Nothing is happening!

I restarted my computer (windows 10)
Reinstalled the app
Eraised the backup
Reinstalled wd backup through the site

still same problem.

Can somebody help me out! First exprience is very frustrating


I haven’t seen this case before.

Have you tried creating a case with support about this.

I have Passport Ultra, began use June 2016, used as external backup Window 10 HP Desktop. Sent Computer for repair, which erased files to Factory default. Computer returned tried to use my Passport Ultra for Quicken backup. Found only Backups from 7/18/16, Have backed up prior to return on 3/5/17 [plus many backups after 7/2016]. Cannot find recent backups, do no know what to do. This information is important. Any suggestions??