New My Cloud User, just updated Firmware, device disappearing

Just bought a 3TB MyCloud last night. Worked fine for a couple hours, then disappeared from the network. Tried updating the firmware this morning and it worked fine for a couple hours, then disappeared again. From the reading I’ve done it appears to have to do with the fact that the devices IP address is changing. Apparently some users have changed network mode to “static” to resolve this issue but I’m not finding clear instructions as to how to look up my Netmask, Gateway and DNS Server info which I’m prompted for when switching to static mode in the Dashboard. I’m using an Airport Extreme and MacBook Pro with 10.6.8

Anyone have a link to clear instructions on how to resolve this?

Thanks in advance for any help!

I don’t have an airport extreme but this should work regardless… 

  1. on your mac, open network preferences from either the icons on the right of top menu bar or click on system preferences and then click on network.

  2. from the connected ethernet or wi-fi information write down the following, the IP, subnet mask, router, dns server (more then one separated by a coma). You will need most of this information to type into your Cloud device. When you are done, close this.

  3. in safari, bring up the dashboard of your cloud

  4. go to setting, then select Network

  5. you should see Network Profile

  6. now be very careful here as users have known to enter improper info and the device no longer responds since they don’t know the ip. but lets get started.

a) click on static under Network Services

b) click on details…

   ip address should be whatever the first 3 set of numbers from the ip that you wrote down from your mac

   so something like 192.168.0.xxx   <= this last number should be something like 190 or 150 but less then 240 (thereabouts)

   remember this ip number because it is your new Dashboard IP number from now on.

  Netmask = usually 255.255.255.0

   gateway = 192.168.0.1

   dns server 1 = from your Mac

   dns server 2 = from your Mac

click save

  1. replace your dashboard number with the new ip on the safari URL

   192.168.0.190/UI/

Check your time date

  1. settings / General

  2. Time Zone, and make sure NTP service is ON.

That’s it… 

Check with your Router to see what is your range of numbers for DHCP.  Usually this is something like Starting IP Address and the other setting is Maximum number of DHCP Users. So starting can be 192.168.0.10 and max is 100. or ending can be 192.168.0.110

You might also see Client Lease Time, so try setting that to 7200 minutes which is 5 days. (max on mine) 

good luck