New My Book Essential 2TB USB 3.0/2.0 not recognized under computer but in Devices and printers

I have read all post that I think would help me.  I am afraid I will make things worse.  Here is my problem.

1.  New WD My Book Essential 2TB USB 3.0/2.0 Desktop External Hard Drive.  (WDBACW0020HBK-NESN)

2.  OS:  Windows 7 Pro 64 bit running on a laptop

3.  Laptop has USB 2.0 only (buying new laptop with USB 3.0)

4.  Plugged USB in and installation started and completed

5.  Drive shows correctly in “Devices and Printers”

6.  Drive does not show when I open “Computer”  (all other drives I connect will show) 

7.  Downloaded Firmware update from WD website.  Ran it but showed module failed.

8.  Everytime anything fails I have disconnected properly, shut everything down, re-booted, and re-tried.  Several times.

9.  It shows in “Device Manager”.  It says device working properly.

10.  I have tried updating drivers.  Drivers are all current.

11.  I have tried on 2 other computers running Win 7 Home 64 bit with same results.

12.  In “Disk Manager” it does not show at top under listed drives but shows up at the bottom in graphical rep but shows as unallocated.

Is there anything else I can try?  If I need to format it, how do I do that if the computer won’t recognize it?

This is my fifth WD portable drive and have never had any problem with any of them.

Any help would be greatly appreciated.

UPDATE:  PROBLEM SOLVED:  I solved the problem by downloading WD Quick format.  Then I formatted the HDD and all works correctly now.  Thanks to all who help us who are a little computer illiterate.

MORE PROBLEMS:   I thought the problem was solved but now there are more problems. 

1.  Can transfer some files but some will not transfer.  Files are Exact same type and size.

2.  Files that have transferred won’t transfer back.  When accessed file is corrupt and will not work like it should.  Program such as MS word can not edit file.  Sometimes cannot even open file.

3.  Updated the SES driver successfully.

4.  WD Firmware Update for Windows failed.

5.  Drive “Failed” Data Lifeguard Diagnostic.

But at least it is recognized now.  Cannot do anything with it though.  Bought this as a back up.  Worthless now.  I am so frustrated and disappointed.

Any suggestions would be greatly appreciated.

That’s good to know…