New Firmware?

When will WD release a new Firmware for my cloud?

1 Like

Unless they’re working on a massive firmware overhaul… an update to the current firmware release is way overdue. I have to reboot the MyCloud running the current firmware at least once a week in order to get some performance back. The Web interface gets slower by the day… not to mention that copying from my desktop to a WD My Passport USB 3.0 attached to the MYCloud is impossible due to constant permission errors. No such errors when copying directly to the MyCloud drive.

1 Like

I don’t count on a fix now, and maybe not at all, this is just taking way too long and I get the impression that they don’t have a clue how to fix it at all.    If I was responsible for this product and had so many unfortunate, unhappy, desperate, sad customers, I would have picked up engineers from Mars, Pluto, Jupiter and the sewer if needed and work on a solution 24/7.   I would communicate daily about the progress and that way at least try and win my customers confidence back again and hope … that someday they would recommend this product again to others.   It seems like they don’t have a clue also how important it is to communicate clearly, set timeframes and most of all give specified updates.    Even if they don’t make it in time, the least they should do is give an idea where they are at, how close they are to a final solution.   All that **bleep** like “we’re collecting data, we’re testing, we’re working on it” doesn’t tell us [Deleted - Trancer], tell us if you are 20%, 65%, 98% close to a final solution and tell us at least what you have achieved already and what still needs to be done.   And do it in one clear sticky topic in uppercase characters “WD MYCLOUD DISCONNECTION ISSUES … WE ARE WORKING ON IT … FOT DAILY UPDATES CHECK HERE !!!”

So, a few months ago I turned off sleep mode, gave it a fixed IP and assigned this IP in my router to the MyCloud, since then I had no “permanent” disconnect related issues anymore.     The last time I updated it with the latest firmware, all my shares were invalid, deleted files would not increase the ammount of unused harddisk space so after a while it used up the full 2TB while there was only 500MB on it.    I bet this [Deleted - Trancer] will happen again when they release the next firmware.   So I had to go back to factory settings and start all over again.    It still runs stable for quiet a few weeks now so I just leave it the way it is.    The only minor issue I have is that when I watch a movie from the MyCloud, it sometimes cuts out (or disconnects) shorlty and then skips to the next movie.   Have to go back to the one I was watching and find the scene I was watching.    For the record, I do not access it from anywhere besides the network itself, no idea if that makes any difference or not.     

Anyway, I think WD should do what their good at, just make good harddrives and take their hands off of products like this because they are NOT good at this at all.    By now there are a gazillion unhappy customers who are stuck with this piece of junk and are less fortunate with it than I am at this time.   I learned my lesson, I investigated a lot before I purchased it, apparently I did not investigate enough.    Wish I had never bought this product, I wish non of you had either.     I did not loose my confidence in WD because of this product, I lost it because of the way they deal with it, the lack of “clear” communication, and it takes way to long for all of you who are still struggling with all these issues.   So if any of you knows someone from Mars, Pluto, Jupiter or the sewer, please do send them to WD and get us all happy again before summer is over !!!

1 Like

If any of you wonder why I came up with sewer … that is where pieces of [Deleted - Trancer] float around, that is where all these MyClouds will end up if there is no permanent solution soon.   :confounded:

1 Like

  Sorry if I am putting a dampener on this thread but, I have had my product for 6 months now and, apart from initial ‘teething troubles’ which were mostly down to my own incompetance, my cloud drive has functioned brilliantly, far better than expected and I couldn’t be happier with it.

  I recommended it to my brother for his business and he, too, is delighted.

I’m glad to hear it works for you.   Mine seems to be okay at this point as well but as I stated before, I only use it for direct access on my local network, that might make a difference.   Support contacted me to help out but at this point there is no need for it, besides I’ll be on vacation for a while.  

All I tried to achieve with my previous message is to make a statement.   There are way to many people struggling with issues and I guess I’m more frustrated because of that than the minor issues I personally have with it.

Clear communication and frequent updates about their progress is the key in my opinion, that is the only way for WD to give their customers confidence that they will get to a final solution.    When I checked out this forum for the first time I had get bits and pieces of information in too many different topics, took me ages to collect all the info and see what would work best for me.    I suggested one sticky topic to make it as easy as possible for new members to read all the options, tips and tricks, suggestions and WD’s progress.

P.s. For the record WD, in my previous message I had no intention to be disrespectful.   I’m Dutch and simply write what I think.   I sure hope you’ll come up with a solution that works for everyone who is dealing with this issue.   :manwink:

1 Like

This piece of hardware, contrarily to what most “mods” think, is a real pusher to learn more about networks.

After leaving it alone for a few weeks, out of disgust, I now came across new problems:

  1. I tried to connect the MC directly to my second network card (I have two on my motherboard) in order to boost speed during transers. It works, but only when the device is found (talking about Win7’s network explorer or WD’s brilliant softs). Which is once out of three tries. Not very satisfactory.

  2. Since the above solution was far from satisfying, I connected back the MC to a switch, which is plugged to the router.

Now I can only copy files to the device, but can’t copy them back to my computer. This happens as the drive is mapped and obviously found. Is it some kind of punishment for trying a direct connection to the computer ? Only god knows.

I guess I must have picked up another winning ticket at the “random MC problem lottery”. If I were that lucky with other lotteries, I’d be a millionnaire by now. Misplaced luck…

This is starting to consume so much time I’m considering to do a low level format of the data partitions and just get rid off it on some auction site.

kudos to rambler67! i fully agree with that.

WD needs to be more transparent.

for example, every member of the my cloud family got a new, improved firmware recently,

but the main user base for this product did not see any progress.

I believe that - when it is done right, the my cloud is a killer product. improve the auto-upload feature,

PRINT a manual to explain network speed problems, let more software engineers do their work.

btw, why did all other NAS manufacturers fix the openSSL flaws from june 5th that quickly, is the my cloud not affected?

i just want a clear statement from WD with this issue. is it serious or not?

1 Like