New firmware v5.06.115 docker SECCOMP error on EX2 Ultra

@WD_Admin, new firmware v5.06.115 has issues with SECCOMP and docker containers cannot be run.


root@NAS # docker --version

Docker version 19.03.8, build

root@NAS # docker container run hello-world

docker: Error response from daemon: OCI runtime create failed: container_linux.go:349: starting container process caused "seccomp: config provided but seccomp not supported": unknown.

ERRO[0001] error waiting for container: context canceled


Now that seccomp support is compiled into the kernel you can use the official docker builds located at I would recommend this particular build as docker-19.03.9 and above seem to have a dockerd binary that is not compatible with the EX4100 at least. Copy the extracted files from the tgz above into /mnt/HD/HD_a2/Nas_Prog/docker/docker if you are using the third party docker install for WD NAS that is floating around.



@JediNite, cool, thank you! will try that.


Linked Docker 19.03.8 on WD EX2 Ultra firmware 5.06.115 works for me.
Thank you, both.


1 Like

@JediNite, @WD_Admin, seems there is issue with libseccomp library version in OS5. Getting this error as described here. Any clues?

Please note you can’t use --security-opt seccomp:unconfined with docker create or docker build commands…

Mr Robert

This is the first build where seccomp has been available on arm so into new territory on this one. I’ve only got as far as installing portainer on my Ex4100 so not ran into the issue.

Someone suggested they fixed it in that link by updating to 19.03.12 but any versions above 19.03.08 seem to not have a working dockerd binary (at least for me), but could be worth trying in any case and see if you have better luck.


@Mr.Robert I’ve seen the same message with the arm32v7/ubuntu:latest base image.

The AskUbuntu answer suggests to update libseccomp:

Upgrade libseccomp manually on the host system.

I didn’t test this route, but using arm32v7/ubuntu:bionic image solved the issue for me.
Try downgrading your image if you can.

1 Like

Where can i get thr firmwarefile 5.06.115?
I dont get it un dashboard!

installing/updating anything on the host NAS OS is not easy since WD has the “auto-restore” after every reboot.

Indeed, going with bionic might be the way to go. Basing on Debian works fine as well, as workaround… :+1:

Works for me


Strangely on my end, after swapping the files on the destination docker stops working.

I start the application and then try to log to navigate it through port 9000 and get connection refused, it only starts working again after reinstalling the application. Did any of you guys had this problem?


Did you confirm that container restarted okay with “docker ps -a” ?



I’m in the same boat. Docker doesn’t respond on port 9000. Always connection refused.

root@MyCloudEX2Ultra docker # docker ps -a
CONTAINER ID        IMAGE                 COMMAND             CREATED             STATUS             PORTS                    NAMES
<HEX_ID>        portainer/portainer   "/portainer"        13 days ago         Created   >9000/tcp   pedantic_golick

I just discovered docker just after updating to OS5 and then really wishing I hadn’t updated. I installed the binary for my device and it just never worked.

I had to manually restart portainer to get it work.

In your output the container seems to be created 13 days ago, but not running.

Try running:

docker rm pedantic_golick

And start a new portainer instance by:

sh /shares/Volume_1/Nas_Prog/docker/

I see some error messages in the output, but the container starts up successfully and port 9000 is available:

# sh /shares/Volume_1/Nas_Prog/docker/
/shares/Volume_1/Nas_Prog/docker/ line 1: !#/bin/sh: not found
Error response from daemon: No such container: portainer
Error: No such container: portainer
Using default tag: latest
latest: Pulling from portainer/portainer
Digest: sha256:f8c2b0a9ca640edf508a8a0830cf1963a1e0d2fd9936a64104b3f658e120b868
Status: Image is up to date for portainer/portainer:latest
CONTAINER ID        IMAGE                               COMMAND                  CREATED             STATUS                  PORTS                    NAMES
4cf60f58beca        portainer/portainer                 "/portainer"             3 seconds ago       Up Less than a second>9000/tcp   portainer


So finally docker works on EXUltra2 with the latest file.
Download link for “docker_19.03.13_EX2Ultra.bin”

Thanks to “stefaang” from OS5 packages · Issue #57 · WDCommunity/wdpksrc · GitHub

1 Like