New Firmware Update - now can’t connect to movie files on external disk

Just updated the firmware, and now can’t access (from my desktop computer) the folders in the external disk drive hooked up to the WDTV unit.  It tells me I can’t open them because I don‘t have permission to see its ciontents.  Worked fine before the upgrade.  Now I’m stuffed.  Any help would be greatly appreciated!  (I reset to factory defaulrs, but this was no help.)

SOLVED!  This came from another Q&A stream, but it worked for me!

Re: No write access to external hard drive with Mac Finder


‎01-22-2012 03:07 AM

I had the same problem:

I connected the external hard disk (hfs+ not journaled) to my mac, then updated all the disk permissions to read/write to all files on the diskand then it worked when connected to the wdtv via wifi

to do so:

connect the disk to the mac

  • right clic (control click) on the disk icon on the desktop
  • click Get Info
  • unlock the bottom right lock on the info window by typing yr os x credentials (if applicable)
  • give all the users (you - staff - everyone) read/write permissions
  • then click on the gear icon and select all included elements

that should do it when you reconnect the hd to the wdtv.

Thank for the info, richpot.