New Firmware Killed My Box? Help?

Just keeps looping at the loading menu, if I hit back on the remote I can get the options screen to show mememtarily but not long enough to do anything.   The hard reset buton is not even working.  WD TV Live.

Hello try downgrade your firmware to fix the problem. I could’nt use my dwa 140 from dlink because it

had the wrong firmware version. So i downgraded from the new 1.06.15_V to the old 1.01.17 version and now

i works like a charm :laughing: But follow this link first that shows how to trick your box to belive it is new firmware

your getting and see if it works in your case?   LINK:

Hope it helps or get back :slight_smile:


I have the same problem.

Surely, there is a fix and we don’t have to downgrade?

Same here, and im not happy.

Now I have to spend my evening downgrading.

Same here. Spinning wheel with occasional micro glimpses of the normal menu.

Is a downgrade even possible I thought you had to choose an option from the menu to do firmware off usb and we can not even get to the menu.

Don’t know if this will work for others. On my PC, I downloaded the new firmware again from here


I extracted the three files to an empty jump drive. I then pulled the power cord on the WDTV Live and plugged in the jump drive.

After 10 seconds I plugged the power cord back in.

The light in the jump drive then showed activity. After a short time, a message was displayed announcing inability to do something or other (didn’t have a pen handy to write it down), with an OK button. Once I clicked OK, the regular menu was displayed. And the device seems again to be working normally.

Happier than I was a few minutes ago. We’ll see if it lasts.

Thanks, I will try this, seeing that Im still battling to find a download of the previous version (1.06.15)   I had.

Did download .34 so will try.

And even if I do get it working they report a couple of problems with .34 on this topic:

 New Release - WD TV Live Firmware Version 1.06.34_V (9/24/12)

We are investigating this issue. Please reply or private message me with the FW version that you are upgrading from.

Thank you.

Kathy G.  

I had this problem on the live plus. The hard reset button fixed the loop issue. I pressed and held it down while the loading animation screen.

Was upgrading from 1.06.15 to 1.06.34

Then this endless loop thing.

Blowhands’ solution did work for me but not from boot.

While the endless busy meter was going, I removed the flashdrive and pushed  it back.

The message:   autoplay content cannot be accessed     [ok]

I pressed ok and got the menu back.

Only problem is that when I reboot (even pull the power cable) the same thing happens, and I need to push the flashdrive in to repeat the above process  to get the menu back.
But worse of all is that my D-Link wireless N 150 does not work at all anymore.

Same here…

I know this won’t help anyone who has already installed the latest firmware. As I was attempting to install the lastest version I came here to read about it and discovered other people’s problems. I got to about 80% of the install and pulled the power cord from my router fearing the worst. The install falled and after doing a power cycle to my unit it  is no different than before I tried the install. I will check here before attempting another firmware install.

Downloaded and installed without any problems.

Haven’t tested all the functions yet, but those tested work fine…

This is caused by the auto play being enabled.

I stopped it from happening by putting a previous firmware on a usb drive and plugging it in to the WDTV Live this stopped the loop, after that I noticed the failed auto play message so went in and turned off auto play in system settings, switched it off  and removed the usb stick and it booted normally.

Apart from this terrible oversight the firmware works well for me. I love the addition  of BBC IPlayer.

Can someone please help me find previous firmware versions like 1.06.16_V (and others) for download so that I can start downgrading.

Fixed the auto play problem, but it does not help if I cant use my D-Link and cant access shares.
This box is now useless to me.

The endless loop is caused by the autoplay function!


When you reset your device, it will turn autoplay off, hence fix the problem. However, there are still many other problems with this firmware (slow loading etc), so you’re better off rolling back to the previous firmware.

Is there a list of older firmwares which can be downloaded? I don’t know what version my unit was on before this stupid “upgrade” which basically makes the unit unsable. This link has some firmwares, but the non-American one seems really old (v.  1.05.04_V) :,333/session/L3RpbWUvMTM0ODU3MjYyNC9zaWQvTTY0Um03N2w%3D

1.05.04 was the latest one for the european box and is fine, I’m running that one now :slight_smile:

Just to let you know turning autoplay off did not fix my problem so please do not post in bold that this is the solution…it worked for you but I see no one else reporting that it fixed theirs.  I am still having the issue with autoplay off.  I can get to the menu options by booting with a firmware on a usb drive put it and cancelling on the error message.  Checked all my settings as well as turning autoplay off and it still loops continiously if I try to boot normally.