New firmware broke my WDTV!

Sometimes, when this happens to me, it helps to reset the network (even though the WD reports that the network is connected).

Go into Network Settings and select to setup the network; just choose Automatic. After the WD box reports that it has successfully connected to the network, the Windows shares then show up in the Network Shares list.

The next time that I shut off the WD box and turn it on again, the same thing happens (the Windows shares do not show up).

I found a fix! I am not sure which of these steps fixed the problem, but this is the process I followed.

[1] Disabled homegroups on Windows 7

[2] Enabled the Guest account in Windows 7

[3] Created a login especially for the wdtv

[4] On the password page in the WDTV for the computer, i simply entered the username and password WITHOUT the machine prefix. 

Previously, I needed I7PC\Josh and the password (ie prefixed with the machine name).

I dropped the I7PC prefix. 

I can now play from network shares!

If your machine is on a domain, and you need the domain prefix for authentication, I believe this may cause you a problem. 

It works, for now. 

I have rolled forward to the latest update, and it is still working. 

I’d like to add a comment to this.

During my research to solve this problem, I was shocked with the amount of issues firmware updates have caused on this device. I may still need to roll back if I encounter those. My next media player will not be a WD. 

Thanks to everyone who posted their experiences on my issue. 

So we can say that the firmware did not ‘break’ your WDTV.

Hello,

i almost have the same issue.

Since the last update, when i try to access my Synology NAS Server, i get the message “The network shares cannot be accessed”. To fix this problem i tried to do the following things with no luck:

  • Reset to factory default

  • Check the workgroup name

  • Change the ip adress

  • Clear login info for network shares

  • Check right access on my NAS (even if i knew everything is fine as i accessed them just before firmware upgrade)

  • Synology server reboot

Any idea on how to recover access to my NAS shares ?

As i use 99% of time the WD to access network shares, it became useless.

Note: i own the WD TV live for several years, performed every upgrades and this is the first time i’m encountering such a thing.

Thanks

EDIT: as a last test, i set “Auto logon to shares” to “OFF” and it did the trick. i can now access the shares.

Very strange behaviour as i had cleared login information previously

I leave my post as it can be useful to someone… maybe :wink:

Matt

To whoever said “so we can say it did not break my WDTV” :-

** Yes, it did BREAK my WDTV.  **

Then, I spent four hours repairing it. 

This community is so full of people desperately trying to get basic functionality working after these updates that I am amazed there are those who would leap to its defence. 

**bleep**, there are those desperate to get something as basic as network shares working on the OUT OF THE BOX DEVICE.

And we haven’t even started talking about the other issues these forums are full of.

Look at what poor old Ikeke went through. 

Suddenly, he sets auto logon to off, and everything works.

So at the very least, in his case, we can say that having auto logon ON completely disables the devices ability to access network shares. 

It’s top quality stuff :smiley:

Note that once auto logon has been set to OFF, i’ve been able to enter credentials to connect to my shares.

Once this previous step done, i’ve been able to set back auto logon to ON and access my shares again.

i wouldn’t say this firmware broke my wdtv (as i’ve been able to fix it) but there’s definitly an issue with upgrading process as, as you say, it should “work” out of the box.

Now, this is the first time i encountered such an issue in several years and multiple updates, this thing can happen even if it’s highly annoying when you have to deal with it.

@joshash

“having auto logon ON completely disables the devices ability to access network shares.”

Confirmed.

If set to OFF, box will ask to log on to network share every time. Annoying, but now network shares somewhat functional.

Alternatively, auto setup network in network settings every boot. Once again, annoying but functional.

I’m in no way defending WD’s absolute botching of this release. Very disappointed.

@sewercycle

“If set to OFF, box will ask to log on to network share every time. Annoying, but now network shares somewhat functional.”

Once you did it once, you should be able to set it back to ON. I did it this way and i still have access to my shares

@ikeke

Even after cycling power?

@sewercycle

Yes. i already powered off/power on my WDTV 3 or 4 times, and i’m still able to access my shares with auto logon sets to ON.

Maybe it’s because i proceed this way:

  • Clear Logon information

  • Set Auto Logon to OFF

  • Connect to shares with proper credentials

  • Set Auto Logon to ON

@ikeke

thnx!!!

I will give it a try and report back.

You’re welcome.

Yes please, i’d like to know if it did the trick for you.

@ikeke

So close, but no joy.

Followed instructions as detailed. Device saved network share details for 1 soft power cycle (from remote control), network shares worked fine, then failed with no response to selecting network shares icon on subsequent soft power cycles.

I thought this may just be an aberration so tried again.

Saved network shares for 2 soft power cycles then failed on selecting network shares icon of the 3rd cycle.

Bugger.

@ Sewercyde

Sorry to see that it didn’t work for you.

I hope you’ll find a solution soon

I did a power-cycle (pulling the plug) and then I could connect with auto-connect set to ON. The NAS share is accessable to anonymous and techflaws. I had not entered any login/pw.

@techflaws i had similar shares. 1was anonymous username and no password, the other was via windows username/password combo.

I relented and rolled back the firmware.

@ikeke
thanks for the help.
hopfully WD will release a new firmware soon.
:confused:

I had the same problem last night after updating the firmware.

I needed to re-enter/re-submit the workgroup name, then it would re-start the network. After that, everything looks fine so far.

See if my recent post here helps anyone get up and running again:

http://community.wdc.com/t5/WD-TV-Live-Firmware-Networking/New-Release-WD-TV-Live-Plus-Firmware-Version-1-06-42-1-17-13/m-p/534946#M17212