New firmware broke my WDTV!

So I installed the latest update attempting to get WDTV Remote support. 

None of the network shares worked. They simply said “There is no media in the current folder.”

So I rolled back to the previous version of the firmware, and still the problem persists.

I’m a professional software developer with 10 years experience and I’ve never seen such a joke in my life. 


I cant use my device at all that I paid money for. 

None of the network shares will play. 

It’s a good way to win customers isn’t it - to break their devices with an update.

This is one of the biggest jokes in software development I’ve seen!!

So what are we supposed to do, since we can’t roll back to any previous version - go out and buy another one from a shop that still has the old firmware on it??

You’re clearly upset … i can understand that.

So, don’t bite my head off trying to offer a couple of suggestions.

After Updating Firmware and Rolling Back Firmware have you gone to …

Settings > System Settings > Reset Back to Factory Defaults?

and then after that, disable your Network Shares … then Re-Enable them

and also Re-Check the Network Settings (after doing the Reset Back to Factory Defaults)

I own a WDTV Live Hub … and 99% of the time after doing a “Firmware” Update (and/or Rollback)

i have to Reset Back to Factory Defaults to get things working again.

Anyways, I’m posting this in good faith … to hopefully provide some suggestions to fix the problem.


Thanks for your reply, but I have tried all that, and am left with a bricked device.

Yes, I have tried factory resetting. 

I have tried disabling and re-enabling my network shares. 

I’ve restarted the sharing computer, done a power pull of the WDTV, and have confirmed my network shares are working correctly from another device.

I have rolled back to 1.06.15_V but still nothing. 

Where can I get a previous version of the firmware, I believe I was on the original 1.04

you realise there are " 4" versions of 1.04?

Which One ?


remember… you need to edit the wdtvlive.ver to a higher number in order for it to detect as New Firmware.


Read through the Release Notes to pinpoint the version you had:

Thanks, It was 1.04.22_V - I had TuneIn Radio

However the release notes of the latest update say it can break the device completely going to anything less than 1.05? 

It would appear the Media Server function still works, however the Network Shares functionality is completely broken. 

Do I take the risk of installing a 1.04, or just accept the fact that Network Shares is broken forever and try to download a media server?

Obviously, I’m now in the market for a new media player for my TV :frowning:


I’m certain i read somewhere here on the doing a “sequential” firmware rollback will work


Rollback to 1.06.15_V   1st       click

then 1.05.04_V  *click*

then from there to 1.04.22_V  *click*

remember to edit wdtvlive.ver to higher numbers each time, and yes it’s a long boring process … but stick with it.

gotta go, it’s getting late … good luck  (Sincerely)

Joshash, if it’s not too late, I offer the following tips:

Make sure your WORKGROUP names are the same on all your devices.   Older versions of Live/Live+ didn’t have a dependency on workgroup name.  Not sure if this new version does, since I’ve moved on to newer boxes.

Also, make sure your PC that is sharing the files can see the WDTV in the workgroup browser:

For that, see if this tutorial for troubleshooting helps:

Did anyone find a fix for this?  When I click on Network Shares it doesnt do anything.  It is like i am not even pressing the button on the remote.  This worked fine before the update.  I have tried reseting to factory and also unsharing my drive and sharing it again.  Still when i click on network shares it does nothing.

Sometimes, when this happens to me, it helps to reset the network (even though the WD reports that the network is connected).

Go into Network Settings and select to setup the network; just choose Automatic. After the WD box reports that it has successfully connected to the network, the Windows shares then show up in the Network Shares list.

The next time that I shut off the WD box and turn it on again, the same thing happens (the Windows shares do not show up).

I found a fix! I am not sure which of these steps fixed the problem, but this is the process I followed.

[1] Disabled homegroups on Windows 7

[2] Enabled the Guest account in Windows 7

[3] Created a login especially for the wdtv

[4] On the password page in the WDTV for the computer, i simply entered the username and password WITHOUT the machine prefix. 

Previously, I needed I7PC\Josh and the password (ie prefixed with the machine name).

I dropped the I7PC prefix. 

I can now play from network shares!

If your machine is on a domain, and you need the domain prefix for authentication, I believe this may cause you a problem. 

It works, for now. 

I have rolled forward to the latest update, and it is still working. 

I’d like to add a comment to this.

During my research to solve this problem, I was shocked with the amount of issues firmware updates have caused on this device. I may still need to roll back if I encounter those. My next media player will not be a WD. 

Thanks to everyone who posted their experiences on my issue. 

So we can say that the firmware did not ‘break’ your WDTV.


i almost have the same issue.

Since the last update, when i try to access my Synology NAS Server, i get the message “The network shares cannot be accessed”. To fix this problem i tried to do the following things with no luck:

  • Reset to factory default

  • Check the workgroup name

  • Change the ip adress

  • Clear login info for network shares

  • Check right access on my NAS (even if i knew everything is fine as i accessed them just before firmware upgrade)

  • Synology server reboot

Any idea on how to recover access to my NAS shares ?

As i use 99% of time the WD to access network shares, it became useless.

Note: i own the WD TV live for several years, performed every upgrades and this is the first time i’m encountering such a thing.


EDIT: as a last test, i set “Auto logon to shares” to “OFF” and it did the trick. i can now access the shares.

Very strange behaviour as i had cleared login information previously

I leave my post as it can be useful to someone… maybe :wink:


To whoever said “so we can say it did not break my WDTV” :-

** Yes, it did BREAK my WDTV.  **

Then, I spent four hours repairing it. 

This community is so full of people desperately trying to get basic functionality working after these updates that I am amazed there are those who would leap to its defence. 

**bleep**, there are those desperate to get something as basic as network shares working on the OUT OF THE BOX DEVICE.

And we haven’t even started talking about the other issues these forums are full of.

Look at what poor old Ikeke went through. 

Suddenly, he sets auto logon to off, and everything works.

So at the very least, in his case, we can say that having auto logon ON completely disables the devices ability to access network shares. 

It’s top quality stuff :smiley:

Note that once auto logon has been set to OFF, i’ve been able to enter credentials to connect to my shares.

Once this previous step done, i’ve been able to set back auto logon to ON and access my shares again.

i wouldn’t say this firmware broke my wdtv (as i’ve been able to fix it) but there’s definitly an issue with upgrading process as, as you say, it should “work” out of the box.

Now, this is the first time i encountered such an issue in several years and multiple updates, this thing can happen even if it’s highly annoying when you have to deal with it.


“having auto logon ON completely disables the devices ability to access network shares.”


If set to OFF, box will ask to log on to network share every time. Annoying, but now network shares somewhat functional.

Alternatively, auto setup network in network settings every boot. Once again, annoying but functional.

I’m in no way defending WD’s absolute botching of this release. Very disappointed.


“If set to OFF, box will ask to log on to network share every time. Annoying, but now network shares somewhat functional.”

Once you did it once, you should be able to set it back to ON. I did it this way and i still have access to my shares


Even after cycling power?