New firmware 1.04.17_v

I applied the update tonight and cannot play any video files. MKV,AVi etc.

I also tried to roll back to a previous version but I cannot seem to get the usb drive to be recognized as having a firmware version that can be loaded. This is extremely frustrating.

Any help would be appreciated.

I managed to get back to ver 1.03 … but still cannot play file that I previously could ?

In then end all is fine. I had to cycle my router.

Take out your USB drive, unplug the power, turn it on again and plug in the USB drive again. That have worked for me when I have had that problem.  I have tried reset and many other things, but the unpluging of all drives is the only thing that worked for me.

  • Henrik

I applied the update today and now I  cannot play any video files. MKV,AVi etc.

Try the following:

reset via the side paperclip button with the unit on (1 sec press)

reset to factory defaults via the internal menu

unplugged the unit from power for some minutes

do all 3 before using the unit.

Its recommened that you do the above after you update the firmware particularly if you have problems.

I applied the update and every thing is going well , thanks WD team.