New files don't show on DLNA TV

I apologize if this is a duplicate message, but I can’t seem to find anything. I recently bought the WD TV Live Hub and it seems to be working great except that whenever I add new files to the hub and try to see them on my DLNA TV they don’t show up until I reset the hub. They always show up on the hub and I can see them though the various folders, but not on any other devices. Once I rest the hub I can see the files on all my other devices and They show just fine. Is there something that I’m not doing right? I’ve tried rescanning the files on the hub and they still don’t show. I’ve also tried turning off the media library and turning it back on so it would rebuild, but that didn’t work either. I also tried clearing the media library so it would rebuild and it still didn’t work. The files just don’t show up on other devices until I reset the hub. Any help on this would be greatly appreciated. Thanks.

You need to log into the Twonky UI and have it rescan.

Thanks for the quick reply. Unfortunately I’m very new to the unit so I don’t know how to do what you’ve suggested. Can you provide some instructions on how to log into the UI?

Thanks again for the help.

Http://(ip address if your WD):9000 Will get you there. Then go to the MAINTENANCE menu.

Thanks again for the reply. Unfortunately it didn’t work. I did the rescan and the files still didn’t show up on my device. I don’t know if it makes a difference or not, but I’m just dragging the files over useing my MacBook Pro Finder. I copy the file from my MBP and put it in a folder on the hub. I just copied a file over and I was watching the File Count on the Files tab on the hub and I saw the New Files count go up as soon as I started copying the file over. The hub picks up the files, but I just can’t see them on other devices. I did the rescan on the TwonkyMedia site a couple times and it still didn’t show up. 

I hope that helps.

Thanks again.

Update: When I’m in the TwonkyMedia Server site and I click on Media browser it shows three new videos, which is correct, then I click on Videos and it shows 6 next to the header “Videos [6]”, also correct, but when I click on All Videos it only shows five “All Videos [5]”, incorrect. I don’t know what happened to the sixth video. For some reason it doesn’t show all the videos. Something had to have gotten updated to show the correct count for uploads and for total number of videos, but the files themselves, don’t seem to get updated.


The numbers aren’t significant of the number of videos.

If you note, when you see VIDEOS[5], you will see five selections underneath.  

When I click VIDEOS, I see:


   - All Videos

   - By Date

   - By Folder

   - By Year

   - Personal Rating

   - Playlists

… six selections, not six videos.

So, don’t use the numbers to always tell you the quantity of videos underneath.   

So the other thing to try is to completely REBUILD the database. 

If that doesn’t work, my only guess is that there’s something about that sixth video Twonky doesn’t like.

Is it in any way different than the others?


Makes sense on the numbers. Very odd coincidence that the numbers would work out that way. It looks like rebuilding the DB worked and all the videos showed up, but is that normal that Imhave to do that? shouldn’t it be automatic? If I have to do that each time, then I won’t ever be able to use the ratings and favorites options on the movies. It says all that’s going to go away when I rebuild. This is my second device because I took my original one back kbecause WD thought it was broken and I needed to get another one. What do you think? Does yours work this way? Do you have to rebuild each time or do you put your movies on a different way? Should I use Twonky to upload my movies onto the device? It seems so much slower. Thanks again for all the help. I should have come here first instead of bothering with WD.

Rescans are automatic, but Rebuilds are not. 

Sometimes the database gets out of sync with itself, and Rebuild is the last option (that’s why Twonky provides it.)

Rescans happen “Periodically.”

As to FAVORITES and RATINGS…  I’m not sure about that.

How are you “marking” these favorites and ratings? 

I definitely don’t use Twonky to do any uploads.  

When using the WD UI you can go into options on each movie and set options for favorites and you can rate the movies. You can then filter for movies based on those ratiings, but only in the WD UI not using the DLNA on other devices. I guess it doesn’t really matter because I probably won’t ever use it. It almost worked this time. It found two out of three movies I copied over. For whatever reason it didn’t find one of the movies. I don’t know why though they were all created using the exact same software. For now, rebuilding the database is a lot easier to manage then resetting the device and all the settings on it. Thanks for all your help and quick responses. Happy New Year!

Rebuilding the database doesn’t affect the ratings assigned by the Hub… That’s kept in the Hubs own internal database.