New EX2 ultra will crash any mac attached to it


#1

Christmas present: brand new EX2 Ultra WDBVBZ0080JCH-NESN.

It is plugged via USB directly into the central hub of my Ubiquiti AmpliFi HD WiFi.

Shows up on the network as expected, and a Share will readily mount on any of multiple Macs (both desktops and laptops) all running MacOS 10.14.2 Mojave.

If I mount the Share volume and copy a small folder (say 100 MB or less) it will copy just fine.

If I try to copy a larger folder, a few hundred items say 500 MB or more, it will start copying for a couple minutes then the Mac will freeze entirely and then reboot. I confirmed this on multiple Macs and got the same behavior on similar conditions.

I tried reformatting the EX2 from a RAID 1 to a JBOD to see if that had any impact - problem persists.

I tried disabling Oplocks for the target Share (what the hell) but that had no impact either.

Any ideas? Some update? Does EX2 not work with MacOS?


#2

I am finding that the EX2Ultra does NOT work well with AFP, but seems stable with SMB.

With AFP, I find the connection drops when copying a large amount of data, forcing me to reboot the Mac mini and/or disable/re-enable AFP on the MyCloudEX2Ultra.

My Mac mini is older, running High Sierra. With my laptop running Mojave, it was better, but I am now using SMB across the board.

It’s ironic, because I have a 1st-generation MyCloud 3TB that works well with AFP, but not the new Ultra.

I have copied about 6TB of stuff to mine, using SMB w/ oplocks enabled, from a Mac mini using a 1Gb Ethernet connection on the same switch.