New drive wont mount

I bought a “wd elements 1GB usb 2+3 WDBUZG0010BBK”.

So i got home and i put the drive in my laptop and everything worked. 

I put lots of family pictures and videos on it i even connected it to my linux file server and all of the important data i had on it. And i thought i made a nice backup disk and went along and formated some disk on the server. Not important but just to make clear that my data is lost!! 

After a couple of weeks when i tried to connect the wb drive again it spins but won’t mount.

Tried all kinds of stuff on all my computers and all of their ports but every time the same story. 

So it spins maks i soft clicking sound but won’t mount or start up. 

And in windows i hear the beep that lets you know that a usb is connected but nothing.

Ubuntu sees the drive name i gave it after like 10 minutes but i cant mount it.

It looks like it just wont power up i read a lot of forms but cant find nothing similar.

I’ve tried it on these comp’s laptop win7, laptop win8, server ubuntu 12.10 i even tried out a couple of linux boot usb’s but no luck i must notice that i have only usb 2.0 but that shouldn’t make a difference. So the led flashes like its starting up but i doesnt.

any one has any good ideas? 

br damian

If this is a USB powered drive make sure you’re not using a cable longer than the one supplied.


1 Like

just using the standard usb cable that came with the drive.