New drive not waking up when accessing

Received my drive yesterday and quickly learned you must use the cable that comes with it.

Got everything up and running.  Turned off the media stuff.  I am using this drive (MyCloud 4 TB)  for storage of many files.  When I installed the software that will be using the drive for download to and storage media as well as the library collection of video media (for making custom movies) the drive will not allow access.  It locks up the program.

If I go into the browser and enter the IP address, I can access the drive.  If I search in Windows Explorer, there is a red X shown and accessing is difficult.  It causes my program that I am trying to use to save directly to the drive to freeze.

I am using the supplied Ethernet cable and have/had the blue light when installing.  I also have the user.

I have a WD Duo that works great, just having difficulty getting this one to function the same way.


BTW, just curious why stitch0852 is against nickname policies.  Stitch is the name of my dog and the number is a license plate number but the forum would not allow me to use it.  Said it violated nickname policies…just wondering.  thx

Please try mapping the drive and then see if you have the same connection problems.

Mapping a Personal Cloud drive or WD NAS drive on a Windows PC

My mistake, I had already mapped the drive.  I am very familiar with that procedure. 

Tried accessing it again today after it slept and again it would not wake up and allow read/write access to it.  This is through the wired connection on the router not via wireless “cloud” access.

(EDIT) After reboot it allowed the software that was trying to make the directory as a save place, but when I tried to save an actual file to it, it refused stating no permissions.  (END EDIT)

That seems to take a bit of time and is not what I expected in a “cloud” device.  My duo works great and I have had no problems.  It sits in another room, wakes when I need it and sleeps when it isn’t needed.  I was expecting the same sort of functionality with the My Cloud but that hasn’t happened yet.

This drive is a short rope away from being repackaged and returned.  I wish the place I purchased the duo still had them, I would have gotten one of those instead.  I will be leaving my frustrations there as well. 

This drive was specifically purchased for Digital Juice work space and data storage of the large files.  It is failing me miserably in both aspects of that slowing my progress with video editing.  Thanks for your response, though.

This seems to be the defacto fix for all… 

Workaround for Disconnect Problem - Works for all my and my dealers clients

The summary for that is to use a fix ip outside the dhcp range. So lower your DHCP range from to and assign your Cloud drive a fix ip number like

and post back here to tell us whether that works out for you…

1 Like

I went through the website access of the drive and I am requesting support direct from WD.  If they fail, I will be replacing the drive with a competitor’s.  Cannot waste time and money this way (and I am not a troll, either.  Yes, I read the forum before posting.  I am a frustrated new owner of an expensive white brick that will not work for what it is supposed to be designed for).  Connecting one is not rocket science.  I have done it before with three LaCie drives, a Buffalo drive and a WD Duo.  Yet this one is not functioning correctly for me.  The light on the Duo changes to blue when it sleeps green when awake.  This one the light does not change colors between awake and asleep so no way to tell.  I do hear it’s box calling and Dell can have it back soon.

Did you give try using the EXACT same credentials in the setup of the share you’re saving to, as you did on the Duo?

The red X you speak of above doesn’t mean the Cloud isn’t awake … That just means Windows hasn’t connected to the share yet. What happens when you double click the icon that’s “X’d?” You said “access is difficult.” Unfortunately, that’s not a lot of info for us to go on. :wink:

If you can, post the exact error message you’re getting.

BTW, on the cloud, the Blue LED is solid ON when it’s awake, and fades in and out when the drive is spun down. But even if the drive is spun down, the NAS is still online…just like the Duo.

1 Like

Exact error is:

Source could not be downloaded as the folder did not have permissions.

This was the most helpful, so far.  But alas, I set my IP to static (it was DHCP).  I set it for 210 where it had been 108.

Subnet I set to

I restarted the drive and rebooted the computer to make sure all were on the same speaking level.  Tried saving the same file and got the same error.  No permissions. 

Your response gave me hope, but not fixed yet, thanks.

I do not know the exact settings of the Duo.  I set up the MyCloud using the questions it asked me during installation (just as I did the Duo running for a year).  I realize the red x is not meaning anything about access except sharing.  But it shows me there is something amiss.  I set the IP to static and set the address high (210) and rebooted all.  Tried saving from the internet connected to my computer via Ethernet and asked it to save it to the MyCloud connected the the same router via Ethernet and get permissions errors saying I cannot.  Exact error message in prior post.

I have never noticed the color of the LED anything but bright blue and not pulsing or fading.  So maybe it isn’t stuck asleep, just stuck.  :slight_smile:

I do have the SLEEP function enabled in the website access to the drive.

DHCP range on router is 101-199, just for info.

Mask is Is that the same as all your other devices? Seems odd for the average home net…

Ok, so you’ve got the share mapped to a drive letter.

Open the share in the windows file explorer.

Right click in the window, and select “new…” Followed by “text document.”

Does it let you create it? If so, then there’s no permission problem as far as Windows is concerned…

Lets see if we are on the same page for mapping a drive… and setting shares access 

Cloud Dashboard make sure the following

  1. click on Shares

  2. under User Access make sure the user name that you want to have access has full access to this share

Mapping the Devices as a drive

This is how I’ve been using the NAS device by mapping the device as a local drive. Samba for PC’s. After mapping the shares as a drive, with the gigabit ethernet, the shares almost feels local.

On the PC, 

1, click on computer

  1. click on map network drive

  2. click on browse under “what network folder would you like to map”

  3. click on WDMYCLOUD and if your shares has a userid and password, it will prompt you for it at this time

  4. you will see all your shares, select the one you want, Public is the default start up share

  5. click ok and click finish

  6. you can now see the NAS as a mapped drive in your Computer (treat it just like a local drive).

If you had set the ip to static then it should stay connected until you reboot your pc. Although you may have set it to login in again after you reboot your pc, it will probably not unless you have your user id and password identical to your PC. 

Also if you have multiple shares from different NAS units, you have to have the same userid and probably password. This is a Window limitation and not a Cloud limitation.

Also remember that we are just users of the device, just like you, and not WD support and we are just trying to help each other out…

1 Like

Let me first apologize if it appeared I was in any way being disrespectful of those assisting here.  Just my frustration showing through and not in any way directed at those assisting here.  I am sorry if that is how it came across, that was not./is not my intention.


My drive appears to never sleep.  The light (after sitting overnight) stays a steady blue, does not pulse, flash or otherwise change in appearance after the computer was off all night long.  So waking up in the title is incorrect, it is just outright disconnecting.

Mapping a drive:

I tried from scratch these are the results:

I go to Shares and all the permissions are greyed out with no way to change them.  I then made a new share.  It immediately greyed out all the access permissions.

If I turn off Public access, I am then allowed to modify the permissions.  So I select Full access and leave Public off.  I am not wanting to access these files outside my home network.  After doing that I go the Users and the share made for the user shows Full Access, but no access to other areas (such as Public).

I then map the network drive with the User Name and all seems well.

I can right click in the directory and make new folders.  I can delete folders in the Share directory I created through Windows Explorer.  I then went to the program I am using on the internet to save my purchased files to and changed the download directory to the one created. Error :  Get download file info could not continue as DJResources folder does not have enough permissions.

So I check through Windows Explorer, sure enough it says Read only.  Cannot change it here.

Back into the web user does not show access to Public or Smartware.  Nor does it show anyway to edit these accesses either in Users or in Shares. 

I then mapped another drive directly to Public.  Tried to save to public, but because nothing has been authorized access, I get the same error message and cannot save.

I also changed my IP back to DHCP so that it selects its own IP address. 

After all the changes I rebooted the computer and MyCloud.  Still unable to save directly to the drive.  So, I tried this:

In the application I want to use to save my downloaded files, I set the location to my local drive.  It then begins to save the file.  However, I set it to save to the WD Duo and got the same error message…Things that make you go hmmmmm.

What application is it that’s giving you these errors?

I have been fighting this drive issue for weeks.  I reset the drive, created a new share, ensured the new share had read/write access.  Made an account and ensured it had access to the share.  I then mapped the account and share to a drive letter.  Every time I tried saving through Digital Juice I would get permissions errors.

I removed the WD MyCloud today and setup the new Seagate drive.  I set up the exact same stuff and then I was able to save to my network drive.

(Did I mention I even did the WD update that was available before going this route?)  I did, still had a worthless brick that I could not use for the purpose it was purchased for (to save Digital Juice downloads to a separate, larger hard drive.

Same problem- I need to unplug -replug the powr everytime I need to use this drive- Is this normal? Have you resolved your problems? How?

1 Like

I hope this works. I’m going home tonight - (I work 200kms away during the week) to try this. If it does Kudo’s are owing.